Jump to: navigation, search

VIATRA/DSE/UserGuide/Installation

< VIATRA‎ | DSE

Installing VIATRA-DSE

  1. Download the Modeling Tools distribution of the newest Eclipse from here: https://www.eclipse.org/downloads/eclipse-packages/
  2. Click Help/Install new software and use one of the update sites found here: https://www.eclipse.org/viatra/downloads.php
  3. Select the VIATRA Query and Transformation and VIATRA-DSE feature under the VIATRA Core category to install.
+1. Download and import the TTC2016 example via git and run the SimpleCraDseRunner.java as a Java application.

As this component is still in incubation and is under development, it is recommended to use the CI update site (i.e. the most recent version) and update regularly.

Main Dependencies

  • Eclipse Modeling Framework
  • VIATRA Query and Transformation SDK
    • The query language is defined with Xtext
    • Transformations are most easily defined by using the Xtend language (transpiles to Java)