Skip to main content
Jump to: navigation, search

Sirius/4.1.1

Sirius 4.1.1 is a service release with only bugfixes.

Availability

Sirius 4.1.1 was released on 2016-10-25 (tag v4.1.1, commit 518629d71e27834a07be7c351dd0ed9a8b234dc9). It is available from the following update sites:

It is recommended you use the update-site matching the version of Eclipse you use to avoid potential issues at runtime.

The complete JUnit and SWTBot test suites used to validate Sirius are published along with all their dependencies in separate update-sites from the core, available at:

Compatibility & Requirements

Sirius 4.1.1 is compatible with the following versions of Eclipse:

  • Eclipse 4.5 (Mars).
  • Eclipse 4.6 (Neon). Neon is the reference platform.

If you want to install the org.eclipse.sirius.tests.support feature, which provides APIs to help create automated tests of Sirius-based modelers, you will need to add the following update-site:

New & Noteworthy

The complete list of (12) tickets fixed in Sirius 4.1.1 can be found here on the Bugzilla.

The release notes with highlights can be found here.

Back to the top