Jump to: navigation, search

Difference between revisions of "OSEE/TipsTricks"

(open selected ATS items in a new ATS World or Task View)
(quickly search the currently selected branch?)
 
(71 intermediate revisions by the same user not shown)
Line 1: Line 1:
 +
= OSEE Application - How do I...=
 +
 +
== open, close and customize perspectives ==
 +
http://www.tutorialspoint.com/eclipse/eclipse_perspectives.htm
 +
 +
== navigate the OSEE specific perspectives ==
 +
OSEE has a number of perspectives based on the included applications.  All perspectives can be accessed through Window pulldown > Open Perspective.  To easily navigate through OSEE developed perspectives, select the OSEE pulldown and select your desired perspective.
 +
 +
== use eclipse shortcuts ==
 +
http://www.tutorialspoint.com/eclipse/eclipse_shortcuts.htm
 +
 +
== activate the menu bar from keyboard ==
 +
Press F10 to activate the Menu bar
 +
 +
== make a view or editor active ==
 +
Press Ctrl+F7 to see a list of open views and editor area and switch to one of them.
 +
 +
== change OSEE icon in toolbar based on which workspace is open ==
 +
Once you have gotten used to running one OSEE, you'll realize that you can run 2 or more.  Or, if your a developer of OSEE applications, then you could have one for development, another for run-time testing and another for production use.  It can get confusing to figure out which to switch to in a windowing environment.
 +
 +
OSEE provides the ability to override the icon shown in the Windows toolbar.
 +
 +
OSEE > ATS or Define Perspective > Enter "icon" in the navigator > Select "Set Workbench Override Icon". > This opens an editor where you can select a 32x32 image to use as the application icon. > Select Run.
 +
 +
You'll now see that icon in the top left of your workbench and in the windowing toolbar. 
 +
 +
Here are a few that you can use
 +
 +
[[Image:osee_32.png|frame|center]]
 +
[[Image:osee_32_dev.gif|frame|center]]
 +
[[Image:osee_32_dev_run.gif|frame|center]]
 +
[[Image:osee_32_rc.gif|frame|center]]
 +
[[Image:osee_32_rc_run.gif|frame|center]]
 +
[[Image:osee_32_rel.gif|frame|center]]
 +
[[Image:osee_32_rel_run.gif|frame|center]]
 +
[[Image:osee_32_src.gif|frame|center]]
 +
[[Image:osee_32_src_run.gif|frame|center]]
 +
 +
== learn about the OSEE Architecture ==
 +
[https://wiki.eclipse.org/OSEE/Architecture Osee Architecture]
 +
 +
= Branch Manager - How do I... =
 +
 +
== show artifact / action related to selected branch ==
 +
Branch Manager > Select Branch > Open Associated Artifact > This will either open the Action or show the User that created the branch.
 +
 +
== quickly open an Artifact Explorer from selected branch ==
 +
Branch Manager > Double-click branch > This opens an Artifact Explorer to the branch selected
 +
 +
== show baseline branches first ==
 +
When OSEE starts collecting many Baseline and Working branches, it may be nice to see the Baseline branches first before all the Working branches.  By creating a Table Customization from the branch manager, this view and any branch selection dialog will sort/filter based on your saved and defaulted selection.
 +
 +
Sort and filter Branch Manager as you wish > Select Table Customization > Select Save Customization > Enter in customization name eg "Baseline First" > Select saved customization on left > select "Set as Default" > Select Ok in dialog.
 +
 +
[[Image:BranchManager_baselineBranchFirst.PNG|frame|center]]
 +
 
= Artifact Explorer - How do I...=
 
= Artifact Explorer - How do I...=
 
== show more information, like attribute values, on each artifact? ==
 
== show more information, like attribute values, on each artifact? ==
Line 24: Line 80:
  
 
[[Image:ArtifactExplorer_Quick_Search.PNG|center|frame]]
 
[[Image:ArtifactExplorer_Quick_Search.PNG|center|frame]]
 +
 +
= Change Report - How do I... =
 +
 +
== see the last modified date and author in Change Report ==
 +
Open Change Report via Branch Manager or ATS > Click the Customize icon in the top right > Search on "Last" in the 'Hidden Columns' list > Select 'Last Modified Date' and 'Last Modified by' and move to 'Visible Columns' > Select Ok
 +
 +
This will show the user that last modified the artifact and the time they did it.  Refreshing the Change Report will refresh these values.
  
 
= ATS - How do I...=
 
= ATS - How do I...=
 +
 +
== understand the difference between an action and workflow ==
 +
ATS was designed to be 100+ PCRs systems in one.  You can write an action against one thing, and then add new workflows as you learn all the teams and products that are impacted for that action. 
 +
 +
The "Action" is the top object that groups all the "Team Workflows (workflow)" that have work to be done.
 +
 +
A good example is a bug found in a software product.  You can write an action against the "code" and you will get the "action" object and the "team workflow" object created.  The "Team Workflow" is where the work is done by the Code Team.  Now, let's say the coder determines that the problem isn't a code issue, but a requirements one.  You can add a new "Team Workflow" to the existing action against the "requirements".  You now have one "action" object and 2 "Team Workflows".  You can then cancel the Code workflow with a note that it's a requirements issue.  Now, the requirements are changing which requires a test fix.  You can add a Test "Team Workflow".  And, you realize that some tool changes will be needed, so you can add a Tool "Team Workflow".  You now have 4 teams doing work to fix the single "bug" that was found.  Each team workflow is going through it's own flow of work to complete the task.
 +
 +
[http://wiki.eclipse.org/OSEE/ATS/Users_Guide/Intro#Terms Read more about ATS Objects]
  
 
== configure to automatically add new Actions to a Goal ==
 
== configure to automatically add new Actions to a Goal ==
Line 35: Line 107:
 
== visit recently opened ATS Actions ==
 
== visit recently opened ATS Actions ==
 
Write or open an Action, Review or other ATS object and can't find it?  Select "My Recently Visited" in the ATS Navigator to view all ATS objects viewed in the current OSEE session.  This list gets cleared after restart.
 
Write or open an Action, Review or other ATS object and can't find it?  Select "My Recently Visited" in the ATS Navigator to view all ATS objects viewed in the current OSEE session.  This list gets cleared after restart.
 +
 +
= ATS Actions, Team Workflows, Tasks, Reviews - How do I... =
 +
 +
== import Actions by spreadsheet ==
 +
Actions can be created in bulk by importing from a spreadsheet.
 +
Select "Import Actions Via Spreadsheet" in the ATS Navigator > push the "Open Excel Import Example Spreadsheet" button > Save this sheet off > Using the examples, add appropriate items to the existing columns and add new rows as desired > In OSEE, push the "Select File" button > select your spreadsheet > Select "Email POCs" if emails to assignees is desired > Select Goal to add to, if desired > Select Run
 +
 +
== import Tasks by Simple List ==
 +
Open Workflow to add tasks to > Select "Tasks" tab > Select gear icon in upper right > Select "Import Tasks from Simple list" > Enter titles of tasks, one per line > Select Workflow state if tasks must be completed in a specific state > Select Assignees, if desired > Select Run
 +
 +
== add new Team Workflows to an existing Action ==
 +
Actions are the top level ATS object that groups all Team Workflows that are need to be completed.  As more information becomes available to the user, more Team Workflows may need to be created. 
 +
 +
Open any Team Workflow in the Workflow Editor > Select "Actionable Items" hyperlink > using the right window, select any number of Actionable Items > Select Run
 +
 +
New workflows will be created in the same Action.
 +
 +
== duplicate currently opened workflow ==
 +
And advanced feature exists in ATS that will duplicate an existing workflow in the same action.  This is good when the work being done by a team needs to tracked in separate Team Workflows.
 +
 +
Open Team Workflow to duplicate in Workflow Editor > Open "Operations" section at bottom of editor > Select "Duplicate Workflows" > Select approprate options depending on how you wish the new workflow to be created > Enter title for new workflow > Select Run
 +
 +
= ATS Searching - How do I...=
 +
 +
== search ATS for Workflows, Tasks, Reviews and Goals ==
 +
There are a number of ways to search ATS for what your looking for.  Searching by Id includes ATS Id, GUID (system generated unique id) or Legacy PCR Id.  Using specific searches in Navigator gives more detailed search options.
 +
 +
[[Image:ATS_Searching.PNG|frame|center]]
 +
 +
== quickly search open ATS actions ==
 +
The ATS Navigator has a quick search field to quickly find open actions.  This field will not only work for text, but also ATS ids (eg ATS10001) and system ids, like guids (A61fqvlZOGa83OyWbCQA) or artifact ids (12453).
 +
 +
The IC checkbox stands for "Include Completed/Cancelled" (cursor over to see tooltip notation).  This will include completed and cancelled actions in the search.
 +
 +
Remember, as with any search you want to try to limit the result set that comes back.
 +
 +
[[Image:ATS_quickSearch.PNG|center|frame]]
 +
 +
== find Actions that I originated ==
 +
The ATS User Search provides more searching criteria that would allow you to easily find an Action that was written by a user.  Once common case is finding an Action that you originated.
 +
 +
OSEE > ATS Perspective > ATS Navigator > Select "User Search" > Select User > Select "Originator" checkbox and un-select "Assigned" > Check objects you want to search for, Workflows, Reviews or Tasks > Select Team that Action was written against, if desired > Select Search
 +
 +
As with any search, the more fined grained the criteria, the faster it will return and the closer to the answer you'll get. 
 +
 +
You can also widen your search and use the advanced filtering, searching that ATS World provides to narrow in on what you're looking for.
 +
 +
[[Image:ATS_user_search.PNG|center|frame]]
 +
 +
== find Actions targeted for a version ==
 +
There is an easy way to show all Actions that were targeted for a version associated with a team.
 +
 +
OSEE > ATS Perspective > ATS Navigator > Expand "Versions" > Select "Workflows Targeted-For Version > Select your Team > Select your version.
 +
 +
This will open an ATS World to show all the Workflows in that version.
 +
 +
= ATS Navigator - How do I... =
 +
== show open ATS objects you are assigned to ==
 +
Select the world icon or select "My World" in the list to show all workflows, tasks and reviews you are assigned to.
 +
 +
== show ATS objects that you have marked as your favorites ==
 +
In the ATS Editor, you can select the yellow star in the menu bar and in ATS World, you can select items > right-click > Add to Favorites.  This will mark these items as your favorites.
 +
 +
In the ATS Navigator, you can select the yellow star in the toolbar or "My Favorites" in the list.  This will open an ATS World view of all items you have marked.
 +
 +
== show a Change Report managed by an ATS workflow ==
 +
If you have created a branch or committed changes via ATS, you can easily open a Change Report by selecting the "Open Change Report by ID" > enter in ATS Id.  Change Report for that ATS Workflow will open.
 +
 +
You can also select the "Open Change Report(s) by ID(s)" in the list to perform the same operation.
 +
 +
== open all ATS objects related to the entered ATS Id ==
 +
Select the "ID" toolbar icon > Enter in an ATS Id or a Legacy PCR Id or a guid.  All items matching that id will be opened in ATS World.  You can also open multiple items by entering in a comma delimited list of Ids.
 +
 +
= ATS Emailing - How do I... =
 +
 +
== email team leads / members ==
 +
ATS Team Definitions are configured with Team Leads, who automatically get assigned an Action when it's created, and Team Members, who have have extra configurations and permissions to operate on Team Workflows.
 +
 +
In addition, ATS has a feature that enables you to easily email Team Members, Team Leads or both.
 +
 +
Open OSEE > ATS Perspective > ATS Navigator > type "email" in filter box > You will see "Email Team Leads/Members", "Email Team Leads" and "Email Team Members".  Select one of these > Select Team > Select "Include all children Team Definition Actions" if you wish > select "ok" > OSEE will open your configured mailtool with the appropriate email addresses based on your selection.
 +
 +
== email groups of users ==
 +
OSEE has a User Group artifact type with a Users relation.  Create this artifact on the common branch and drag in User artifacts to this relation.  Then, from ATS, Select "Email User Groups" and select the appropriate group.  Osee will open your configured mail tool with the related User's email addresses.
 +
 +
== email message to a set of workflow assignees or originator ==
 +
Select "Email Message to Action(s) Assigness or Originator from the ATS Navigator > Drag in the Team Workflows, Tasks or Reviews into the "ATS Workflows" box > enter a subject > select the recipient (Assignees or Originator) > Enter the body of the message > Select Run.
 +
 +
The appropriate users will receive an email with your subject and message and the list of workflows that you selected which the user is an assignee or originator.
 +
 +
= ATS Action View - How do I... =
 +
 +
== show a graphical representation of Action, Workflows, Tasks and Reviews ==
 +
In the ATS Workflow Editor, select the "Action View" icon at the top of the editor.  This will open a graphical representation of the "Action", "Team Workflows", "Reviews" and "Tasks"
 +
 +
[[Image:ATS_actionViewIcon.PNG|center|frame]] [[Image:ATS_actionView.PNG|center|frame]]
 +
 +
= ATS Workflow Editor - How do I...=
 +
 +
== add a new impact/Team Workflow to an action ==
 +
To add a new Team Workflow to an action, select the "Actionable Items" hyperlink at the top of the ATS Editor.  On the right pane, select the other Actionable Items that are impacted.  New Team Workflows will be created as needed.
 +
 +
[[Image:ATS_actionableItemsHyperlink.PNG|center|frame]]
 +
 +
== show a hierarchical representation of Action, Workflows, Tasks and Reviews ==
 +
In the ATS Editor, select the "Open in World Editor".  This will open the object  starting at the "Action".  Expand-all will show all items in the hierarchy.
 +
 +
[[Image:ATS_openWorldButton.PNG|center|frame]][[Image:ATS_showHierarchical.PNG|center|frame]]
  
 
= ATS World and Task Editors - How do I... =
 
= ATS World and Task Editors - How do I... =
Line 91: Line 271:
  
 
= Editors - How do I...=
 
= Editors - How do I...=
 +
 +
== easily maximize and minimize the current editor or view ==
 +
Within the current editor or view, select Ctrl-M to maximize.  Select again to minimize.
 +
 +
== switch to different open editor ==
 +
Ctrl-Shift-E shows a dialog of all open editors with editor name and file path, if applicable.  Options to select editor to open, close all editors and save selected editors.
  
 
== restore changes or deleted files from local history ==
 
== restore changes or deleted files from local history ==
Line 103: Line 289:
  
 
= Workbench - How do I... =
 
= Workbench - How do I... =
 +
 +
== navigate using shorcuts ==
 +
Eclipse provides many navigation shortcuts.  [http://www.vogella.com/tutorials/EclipseShortcuts/article.html Click Here] for just a few very useful ones.
 +
 +
== show and open current workspace ==
 +
After selecting one or more of the OSEE views and editors, you will notice that the current workspace is shown at the bottom of the workbench.  You can see the full workspace path by placing your cursor over.  This will open a tooltip.  If you double-click this label, it will open an explorer window (OS Specific) to that location.
 +
 +
[[Image:Workbench_workspaceLocation.PNG|center|frame]]
  
 
== remove old workspaces from startup selection ==
 
== remove old workspaces from startup selection ==
Line 108: Line 302:
  
 
[[Image:Workbench_workspaceHistory.PNG|center|frame]]
 
[[Image:Workbench_workspaceHistory.PNG|center|frame]]
 +
 +
== learn the basics of the workbench ==
 +
One of the best things a new user of OSEE can do is learn how to navigate the workbench.  Switching perspectives, moving editors and views and restoring default are a critical part the efficient use of OSEE.
 +
 +
Select Help pulldown > Help Contents > Workbench User Guide > Getting Started
 +
 +
[[Image:Workbench_basicsOfWorkbench.PNG|center|frame]]
 +
 +
== go deeper into Eclipse usage ==
 +
OSEE is built on the open source eclipse.org integrated extensible development environment.  Learn more about Eclipse through this [http://www.vogella.com/articles/Eclipse/article.html Eclipse IDE Tutorial]
 +
 +
= OSEE and Earned Value Managment (EVM) =
 +
OSEE has a built in Problem Change Request and Configuration Management system called the [[OSEE/ATS/Users_Guide/Intro|Action Tracking System (ATS)]].  This tracking system has some powerful features that supports [http://en.wikipedia.org/wiki/Earned_value_management|Earned Value Management]
 +
 +
== OSEE Earned Value User Stories ==
 +
These are the intial requirements (user stories) for the inclusion of EV Work Package management in OSEE.
 +
*As a <b>Product Owner</b>, I want to <b>select from a list of active Work Packages for my team</b> to assign to actions
 +
*As a <b>Product Owner / Manager</b>, I want to be able to <b>create Work Packages</b> with
 +
**Work Package Id, Work Package Name, Program
 +
**Work Package Type: LOE, Discrete
 +
**Activity Id, Activity Name
 +
**Start Date, End Date
 +
**Percent Complete
 +
**Active
 +
*As a <b>Action consumer</b>, I want to be able to <b>see what Activity Id and Activity Name to charge</b> to on each action
 +
*As a <b>Cost Account Manager (CAM)</b>, I want to enter a <b>single percent complete</b> for each Work Package
 +
*As a <b>CAM</b>, I want to be able to <b>search for Work Package by Id</b>
 +
*As a <b>CAM</b>, I want to <b>see all related Team Workflows, Tasks, Reviews and Goals</b> for each Work Package and their <b>percent complete</b>
 +
*As a <b>Manager</b>, I want to be able to <b>import and re-import Work Packages</b> from excel spreadsheet with valid attributes
 +
*As a <b>Manager</b>, I want to <b>see the Start and End</b> date for each Work Package
 +
*As a <b>Manager</b>, I want to <b>see if Work Package is Discrete or LOE</b>
 +
 +
== Definitions ==
 +
'''Work Package''' = Active account that has calculated and reported earned value.<br>
 +
'''Planning Package''' = Planned work, not yet active.<br>
 +
'''Activity Id''' = End user account to charge.
 +
 +
== Product Owner / Manager - Create Work Packages ==
 +
#Open Artifact Explorer
 +
#Select Common Branch
 +
#Find Team Definition (SAW Code)
 +
#Create new child
 +
#Artifact Type: Work Package
 +
#Name: Earned Value task name (Work Pkg 01..03)
 +
#Open Team Definition (SAW Code)
 +
#Drag new Work Package to Team Definition -> Work Package relation
 +
#Add and set Activity Id and Activity Name (ASDHFA43 and HUF 210 )
 +
#Set other desired attributes
 +
 +
== Product Owner / Manager - Create Work Packages ==
 +
#Search your objects in ATS
 +
#Add the "Activity Id" column
 +
#Select one or more items
 +
#Right-click > Edit > Edit Activity Id OR Alt-Left-Click in Activity Id column
 +
 +
Note: Activity Id can be set on Team Workflow, Task, Goal and Reviews
 +
 +
== Action Consumer - View Activity Ids ==
 +
#Search your objects in ATS
 +
#Add the “Activity Id” column
 +
 +
== Account Manager - Search for Work Packages ==
 +
#Search your objects in ATS
 +
#Add the "Activity Id" column
 +
#Select one or more items
 +
#Right-click > Edit > Edit Activity Id OR Alt-Left-Click in Activity Id column
 +
 +
Note: Activity Id can be set on Team Workflow, Task, Goal and Reviews
 +
 +
== Account Manager - View all related items ==
 +
#Select "Earned Value Work Package Report"
 +
#Drag in Work Packages > Run
 +
#Report displayed
 +
 +
== Account Manager - Set Percent Complete ==
 +
#Edit all available attributes of your Work Package through Artifact Editor
 +
 +
= OSEE and Agile / SCRUM - How do I... =
 +
OSEE has a built in Problem Change Request and Configuration Management system called the [[OSEE/ATS/Users_Guide/Intro|Action Tracking System (ATS)]].  This tracking system has some powerful features that supports [http://en.wikipedia.org/wiki/Agile_software_development Agile Software Development] and [http://en.wikipedia.org/wiki/Scrum_(software_development) SCRUM Software Development]
 +
 +
== use Goals to track backlog ==
 +
The "Action" object in ATS exists to relate all the Team Workflows, Reviews and Tasks that are necessary to complete a single "action" such as "Make these changes to that widget".  The "Goal" object, in contrast, is used to group any ATS objects for any other purpose, such as an Agile backlog.
 +
 +
Goals can contain any Team Workflows, Reviews, Tasks and even other Goals.  In addition ATS objects can belong to multiple Goals. 
 +
 +
Items can be added to goals by one of the following methods
 +
* Opening Goal and draging items into the members tab
 +
* Adding the "Goal" column to any world view and selecting the Goal to add to
 +
** Alt-Left-Click the Goal cell
 +
** Selecting items > right-click > Edit > Goal
 +
* Configuring a Team Definition or Actionable Item to auto-add created Team Workflows to any goals.  [OSEE/TipsTricks#configure_to_automatically_add_new_Actions_to_a_Goal|More Information]]
 +
 +
Goals are ordered which supports the need for a ordered backlog. 
 +
 +
Items in the Goal members tab can be re-ordered by one of the following methods
 +
* Selecting item(s) and drag them to a new location
 +
* Selecting item(s) > right-click > Set Goal Order > Select new location
 +
* Alt-left-click the Goal Order column and entering new location
 +
 +
== use Points column to set points ==
 +
Add the "Points" column and select points by
 +
* Selecting items > right-click > Edit > Points
 +
* Alt-left-click Points column cell
 +
 +
== sum entered Points for a Sprint or selected items ==
 +
It is easy to sum the points column for the selected items when using the [[OSEE/TipsTricks#use_Points_column_to_set_points|Points Column]].
 +
Add the "Points" column > Select items to sum > Right-click the "Points" column header > Select "Sum Selected for Column" > a dialog will popup with the sum of points for the selected items.
 +
 +
== use Targeted Version, Groups, Notes or Category to track Sprints ==
 +
There are a number of different ways to track Sprints in OSEE.  Targeted Versions are normally used to track builds and releases, but could also be used to track Sprints.  If Targeted Versions are already used for builds or releases, other text-based columns can be used.  Among these are the "Notes" column or any of the 3 open "Category" columns.
 +
 +
== use Goal Members tab to support daily stand-ups/scrum meetings ==
 +
A common characteristic in Agile is a daily stand-up or scrum meeting.  These meetings are commonly held using a post-it-note task board.  Another option is by showing the backlog Goal with current spring items at the top or by having another Goal containing only the current sprint items.  The team members can call out the current item order number they finished and which they will work on next.
 +
 +
== automatically add new Team Workflows to a backlog Goal ==
 +
Since an Agile backlog is supposed to contain all items, ATS has a configuration that will automatically add new Team Workflows to any number of Goals.  [[OSEE/TipsTricks#configure_to_automatically_add_new_Actions_to_a_Goal|How to configure]]
 +
 +
== use import features to automatically create actions, workflows and tasks for backlog ==
 +
OSEE has a number of existing features to easily create ATS objects for use in backlogs.
 +
 +
Among these are:
 +
 +
#[[OSEE/TipsTricks#import_Actions_by_spreadsheet|Importing Actions via spreadsheet]]
 +
#[[OSEE/TipsTricks#import_Tasks_by_Simple_List|Importing tasks from simple list]]
 +
#[[OSEE/TipsTricks#add_new_Team_Workflows_to_an_existing_Action|Add Team Workflow to existing Action]]
 +
#[[OSEE/TipsTricks#duplicate_currently_opened_workflow|Duplicate existing Team Workflow (advanced)]]
 +
 +
== use OSEE to support Agile/Scrum in the future ==
 +
As OSEE is used more an more for Agile/Scrum, new features will be incorporated. 
 +
 +
Some ideas for improvements are:
 +
#Automated generation of Sprint Burndown charts
 +
#Web interface of backlog / sprint goals to support daily stand-ups
 +
#Web view of "Scrum Task Board"
 +
#Workflow Definitions tailored to Scrum states such as "to-do", "in-work", "testing", "done"
 +
#Easier ways to import items into OSEE/backlog
 +
#Automatic generation of items performed frequently by teams, some ideas are
 +
##Configure by Team or Actionable item to automatically create a set of tasks on Team Workflow creation
 +
##Configure a set of Workflows, Tasks an Reviews to be created for each Sprint
 +
##Configure a selectable list of items to create anytime they choose
 +
 +
NOTE: These are ideas only and are not yet scheduled for implementation.  As always, contributions to OSEE in this or any area are welcome.

Latest revision as of 18:34, 9 May 2014

Contents

OSEE Application - How do I...

open, close and customize perspectives

http://www.tutorialspoint.com/eclipse/eclipse_perspectives.htm

navigate the OSEE specific perspectives

OSEE has a number of perspectives based on the included applications. All perspectives can be accessed through Window pulldown > Open Perspective. To easily navigate through OSEE developed perspectives, select the OSEE pulldown and select your desired perspective.

use eclipse shortcuts

http://www.tutorialspoint.com/eclipse/eclipse_shortcuts.htm

activate the menu bar from keyboard

Press F10 to activate the Menu bar

make a view or editor active

Press Ctrl+F7 to see a list of open views and editor area and switch to one of them.

change OSEE icon in toolbar based on which workspace is open

Once you have gotten used to running one OSEE, you'll realize that you can run 2 or more. Or, if your a developer of OSEE applications, then you could have one for development, another for run-time testing and another for production use. It can get confusing to figure out which to switch to in a windowing environment.

OSEE provides the ability to override the icon shown in the Windows toolbar.

OSEE > ATS or Define Perspective > Enter "icon" in the navigator > Select "Set Workbench Override Icon". > This opens an editor where you can select a 32x32 image to use as the application icon. > Select Run.

You'll now see that icon in the top left of your workbench and in the windowing toolbar.

Here are a few that you can use

Osee 32.png
Osee 32 dev.gif
Osee 32 dev run.gif
Osee 32 rc.gif
Osee 32 rc run.gif
Osee 32 rel.gif
Osee 32 rel run.gif
Osee 32 src.gif
Osee 32 src run.gif

learn about the OSEE Architecture

Osee Architecture

Branch Manager - How do I...

show artifact / action related to selected branch

Branch Manager > Select Branch > Open Associated Artifact > This will either open the Action or show the User that created the branch.

quickly open an Artifact Explorer from selected branch

Branch Manager > Double-click branch > This opens an Artifact Explorer to the branch selected

show baseline branches first

When OSEE starts collecting many Baseline and Working branches, it may be nice to see the Baseline branches first before all the Working branches. By creating a Table Customization from the branch manager, this view and any branch selection dialog will sort/filter based on your saved and defaulted selection.

Sort and filter Branch Manager as you wish > Select Table Customization > Select Save Customization > Enter in customization name eg "Baseline First" > Select saved customization on left > select "Set as Default" > Select Ok in dialog.

BranchManager baselineBranchFirst.PNG

Artifact Explorer - How do I...

show more information, like attribute values, on each artifact?

You can show artifact types, versions and even valid attributes next to the name of the artifacts on a branch in Artifact Explorer. Simply use the white pulldown to select items you want to show. If you want to save these selections for future Artifact Explorers, just select "Store Label Settings".

ArtifactExplorer showMoreInfo.PNG

quickly open a new Artifact Explorer?

You can open a new Artifact Explorer using the "Open Artifact Explorer" button on the top right of the Artifact Explorer. It will open the new Explorer to the same branch as the one open.

ArtifactExplorer openNewExplorer.PNG

open the Action associated to the selected branch?

For branches that were created from an ATS Action, the "Open Associated Action" button will open those Actions in ATS. If a branch was created manually by a user, it will show a dialog of the user that created the branch.

ArtifactExplorer openAssociatedAction.PNG

open the selected artifact in another branch?

There is an easy way to open the selected artifact on another branch. Select that artifact > right-click > Reveal on Another Branch. This will open another Branch Manager and reveal the artifact on that branch.

ArtifactExplorer revealOnAnotherBranch.PNG

quickly search the currently selected branch?

Select the "Open Quick Search View" button. This will open the Quick Search view, set the selected branch to the same as the Artifact Explorer and place your cursor in the Search text box.

ArtifactExplorer Quick Search.PNG

Change Report - How do I...

see the last modified date and author in Change Report

Open Change Report via Branch Manager or ATS > Click the Customize icon in the top right > Search on "Last" in the 'Hidden Columns' list > Select 'Last Modified Date' and 'Last Modified by' and move to 'Visible Columns' > Select Ok

This will show the user that last modified the artifact and the time they did it. Refreshing the Change Report will refresh these values.

ATS - How do I...

understand the difference between an action and workflow

ATS was designed to be 100+ PCRs systems in one. You can write an action against one thing, and then add new workflows as you learn all the teams and products that are impacted for that action.

The "Action" is the top object that groups all the "Team Workflows (workflow)" that have work to be done.

A good example is a bug found in a software product. You can write an action against the "code" and you will get the "action" object and the "team workflow" object created. The "Team Workflow" is where the work is done by the Code Team. Now, let's say the coder determines that the problem isn't a code issue, but a requirements one. You can add a new "Team Workflow" to the existing action against the "requirements". You now have one "action" object and 2 "Team Workflows". You can then cancel the Code workflow with a note that it's a requirements issue. Now, the requirements are changing which requires a test fix. You can add a Test "Team Workflow". And, you realize that some tool changes will be needed, so you can add a Tool "Team Workflow". You now have 4 teams doing work to fix the single "bug" that was found. Each team workflow is going through it's own flow of work to complete the task.

Read more about ATS Objects

configure to automatically add new Actions to a Goal

Goal artifacts are used as an ordered list of Actions, Reviews and Tasks. If you want Actions written against an Actionable Item (AI) or Team Definition to be automatically be added to your Goal: Open an Artifact Explorer > Select to Common Branch > Open "Action Tracking System" > Expand down to find your AI or Team Definition > Open your Goal artifact in the ATS Editor > Select the "Workflow" tab > Expand the "Relations" section > Drag your AI or Team Definition to the "AutoAddActionToGoal" relation. > Save

ATS Auto Add Action To Goal.PNG

visit recently opened ATS Actions

Write or open an Action, Review or other ATS object and can't find it? Select "My Recently Visited" in the ATS Navigator to view all ATS objects viewed in the current OSEE session. This list gets cleared after restart.

ATS Actions, Team Workflows, Tasks, Reviews - How do I...

import Actions by spreadsheet

Actions can be created in bulk by importing from a spreadsheet. Select "Import Actions Via Spreadsheet" in the ATS Navigator > push the "Open Excel Import Example Spreadsheet" button > Save this sheet off > Using the examples, add appropriate items to the existing columns and add new rows as desired > In OSEE, push the "Select File" button > select your spreadsheet > Select "Email POCs" if emails to assignees is desired > Select Goal to add to, if desired > Select Run

import Tasks by Simple List

Open Workflow to add tasks to > Select "Tasks" tab > Select gear icon in upper right > Select "Import Tasks from Simple list" > Enter titles of tasks, one per line > Select Workflow state if tasks must be completed in a specific state > Select Assignees, if desired > Select Run

add new Team Workflows to an existing Action

Actions are the top level ATS object that groups all Team Workflows that are need to be completed. As more information becomes available to the user, more Team Workflows may need to be created.

Open any Team Workflow in the Workflow Editor > Select "Actionable Items" hyperlink > using the right window, select any number of Actionable Items > Select Run

New workflows will be created in the same Action.

duplicate currently opened workflow

And advanced feature exists in ATS that will duplicate an existing workflow in the same action. This is good when the work being done by a team needs to tracked in separate Team Workflows.

Open Team Workflow to duplicate in Workflow Editor > Open "Operations" section at bottom of editor > Select "Duplicate Workflows" > Select approprate options depending on how you wish the new workflow to be created > Enter title for new workflow > Select Run

ATS Searching - How do I...

search ATS for Workflows, Tasks, Reviews and Goals

There are a number of ways to search ATS for what your looking for. Searching by Id includes ATS Id, GUID (system generated unique id) or Legacy PCR Id. Using specific searches in Navigator gives more detailed search options.

ATS Searching.PNG

quickly search open ATS actions

The ATS Navigator has a quick search field to quickly find open actions. This field will not only work for text, but also ATS ids (eg ATS10001) and system ids, like guids (A61fqvlZOGa83OyWbCQA) or artifact ids (12453).

The IC checkbox stands for "Include Completed/Cancelled" (cursor over to see tooltip notation). This will include completed and cancelled actions in the search.

Remember, as with any search you want to try to limit the result set that comes back.

ATS quickSearch.PNG

find Actions that I originated

The ATS User Search provides more searching criteria that would allow you to easily find an Action that was written by a user. Once common case is finding an Action that you originated.

OSEE > ATS Perspective > ATS Navigator > Select "User Search" > Select User > Select "Originator" checkbox and un-select "Assigned" > Check objects you want to search for, Workflows, Reviews or Tasks > Select Team that Action was written against, if desired > Select Search

As with any search, the more fined grained the criteria, the faster it will return and the closer to the answer you'll get.

You can also widen your search and use the advanced filtering, searching that ATS World provides to narrow in on what you're looking for.

ATS user search.PNG

find Actions targeted for a version

There is an easy way to show all Actions that were targeted for a version associated with a team.

OSEE > ATS Perspective > ATS Navigator > Expand "Versions" > Select "Workflows Targeted-For Version > Select your Team > Select your version.

This will open an ATS World to show all the Workflows in that version.

ATS Navigator - How do I...

show open ATS objects you are assigned to

Select the world icon or select "My World" in the list to show all workflows, tasks and reviews you are assigned to.

show ATS objects that you have marked as your favorites

In the ATS Editor, you can select the yellow star in the menu bar and in ATS World, you can select items > right-click > Add to Favorites. This will mark these items as your favorites.

In the ATS Navigator, you can select the yellow star in the toolbar or "My Favorites" in the list. This will open an ATS World view of all items you have marked.

show a Change Report managed by an ATS workflow

If you have created a branch or committed changes via ATS, you can easily open a Change Report by selecting the "Open Change Report by ID" > enter in ATS Id. Change Report for that ATS Workflow will open.

You can also select the "Open Change Report(s) by ID(s)" in the list to perform the same operation.

open all ATS objects related to the entered ATS Id

Select the "ID" toolbar icon > Enter in an ATS Id or a Legacy PCR Id or a guid. All items matching that id will be opened in ATS World. You can also open multiple items by entering in a comma delimited list of Ids.

ATS Emailing - How do I...

email team leads / members

ATS Team Definitions are configured with Team Leads, who automatically get assigned an Action when it's created, and Team Members, who have have extra configurations and permissions to operate on Team Workflows.

In addition, ATS has a feature that enables you to easily email Team Members, Team Leads or both.

Open OSEE > ATS Perspective > ATS Navigator > type "email" in filter box > You will see "Email Team Leads/Members", "Email Team Leads" and "Email Team Members". Select one of these > Select Team > Select "Include all children Team Definition Actions" if you wish > select "ok" > OSEE will open your configured mailtool with the appropriate email addresses based on your selection.

email groups of users

OSEE has a User Group artifact type with a Users relation. Create this artifact on the common branch and drag in User artifacts to this relation. Then, from ATS, Select "Email User Groups" and select the appropriate group. Osee will open your configured mail tool with the related User's email addresses.

email message to a set of workflow assignees or originator

Select "Email Message to Action(s) Assigness or Originator from the ATS Navigator > Drag in the Team Workflows, Tasks or Reviews into the "ATS Workflows" box > enter a subject > select the recipient (Assignees or Originator) > Enter the body of the message > Select Run.

The appropriate users will receive an email with your subject and message and the list of workflows that you selected which the user is an assignee or originator.

ATS Action View - How do I...

show a graphical representation of Action, Workflows, Tasks and Reviews

In the ATS Workflow Editor, select the "Action View" icon at the top of the editor. This will open a graphical representation of the "Action", "Team Workflows", "Reviews" and "Tasks"

ATS actionViewIcon.PNG
ATS actionView.PNG

ATS Workflow Editor - How do I...

add a new impact/Team Workflow to an action

To add a new Team Workflow to an action, select the "Actionable Items" hyperlink at the top of the ATS Editor. On the right pane, select the other Actionable Items that are impacted. New Team Workflows will be created as needed.

ATS actionableItemsHyperlink.PNG

show a hierarchical representation of Action, Workflows, Tasks and Reviews

In the ATS Editor, select the "Open in World Editor". This will open the object starting at the "Action". Expand-all will show all items in the hierarchy.

ATS openWorldButton.PNG
ATS showHierarchical.PNG

ATS World and Task Editors - How do I...

filter out completed/cancelled items

Select the pulldown-menu next to the gear and select "Filter Out Completed/Cancelled". You can also use the Ctrl-F hotkey.

ATS filterCanceledCompletedAssignee.PNG

only show items assigned to you

Select the pulldown-menu next to the gear and select "Filter My Assignee". You can also use the Ctrl-G hotkey.

ATS filterAssignee.PNG

open selected ATS items in a new ATS World or Task View

You can easily open selected items in a World or Task View by selecting the World or Task icons in the top right of the editor. You can also right-click > Open With > and select the desired editor for the selected items.

ATS openSelectedInNewWorldEditor.PNG

ATS openSelectedInNewTaskEditor.PNG

Review - How do I...

show all review defects in readable format

The Defect table of a Peer Review only shows 5 lines by default which makes reading the defects difficult. In addition, the Description and Location columns are too narrow to see all the text. There are a few things you can do to help view this data easier.

  1. Make any column wider. Select the line between columns in header > drag the columns out to make it wider
  2. Make the table larger. Select the gray line under the table and drag down to show more rows.
Peer make table larger.jpg
  1. View the entire table with wrapped columns. Right-click anywhere in the table > select "View Table Report". This shows in an HTML format that wraps all the columns.
Peer show defects.jpg

Java Editor - How do I...

incrementally search a Java file

Open Java File > Ctrl-F (search) > Select "Incremental" checkbox > Enter text to search. This will highlight the first occurrence of what you type as you type.

JavaEditor Incremental Search.jpg

XViewer - Advanced Tree/Table Widget - How do I

The XViewer is an advanced and dynamic Tree/Table Viewer that has the filtering and sorting the capabilities of a spreadsheet while providing the users the ability to customize their table to suit their current needs and save/restore these customizations for future use by individual or group.

OSEE has used this widget in many of it's views and editors including: Branch Manager, Results Editor, ATS World Editor, ATS Task Editor, Change Report Viewer, Commit Manager, Merge Manager etc...

There are many advanced features of the XViewer that will help organize and manipulate your view of whatever you're looking at.

email, export to csv and print the contents

Select any item inside the table > right-click > View Table Report. This will open an HTML view of the data. The top left options allow for emailing, printing and exporting to csv. The export to csv will write the file to disk and open whatever application is configure to view comma separated value files, like Excel or Open Office.

XViewer viewTableReport.PNG

Editors - How do I...

easily maximize and minimize the current editor or view

Within the current editor or view, select Ctrl-M to maximize. Select again to minimize.

switch to different open editor

Ctrl-Shift-E shows a dialog of all open editors with editor name and file path, if applicable. Options to select editor to open, close all editors and save selected editors.

restore changes or deleted files from local history

OSEE stores versions of most text files as changes are made. You can access these versions to restore these changes. This includes a file or directory that was deleted. Select the file or folder in the Package Explorer > right-click > Restore from local history.

Editor restore from local history.jpg

prevent multiple editors from cluttering up your workbench

OSEE will show the '>>' indicator after 4 to 8 files are opened. You can configure your workbench to automatically close editors automatically. Select Window pulldown menu > Preferences > General > Editors > select "Close editors automatically" > enter number of editors open before auto-close.

Editor close editors automatically.jpg

Workbench - How do I...

navigate using shorcuts

Eclipse provides many navigation shortcuts. Click Here for just a few very useful ones.

show and open current workspace

After selecting one or more of the OSEE views and editors, you will notice that the current workspace is shown at the bottom of the workbench. You can see the full workspace path by placing your cursor over. This will open a tooltip. If you double-click this label, it will open an explorer window (OS Specific) to that location.

Workbench workspaceLocation.PNG

remove old workspaces from startup selection

If you start OSEE with multiple different workspaces, it will remember the last 5. To clear these you can go to Window > Preferences > General > Startup and Shutdown > Workspaces. You can also change the number of workspaces to remember.

Workbench workspaceHistory.PNG

learn the basics of the workbench

One of the best things a new user of OSEE can do is learn how to navigate the workbench. Switching perspectives, moving editors and views and restoring default are a critical part the efficient use of OSEE.

Select Help pulldown > Help Contents > Workbench User Guide > Getting Started

Workbench basicsOfWorkbench.PNG

go deeper into Eclipse usage

OSEE is built on the open source eclipse.org integrated extensible development environment. Learn more about Eclipse through this Eclipse IDE Tutorial

OSEE and Earned Value Managment (EVM)

OSEE has a built in Problem Change Request and Configuration Management system called the Action Tracking System (ATS). This tracking system has some powerful features that supports Value Management

OSEE Earned Value User Stories

These are the intial requirements (user stories) for the inclusion of EV Work Package management in OSEE.

  • As a Product Owner, I want to select from a list of active Work Packages for my team to assign to actions
  • As a Product Owner / Manager, I want to be able to create Work Packages with
    • Work Package Id, Work Package Name, Program
    • Work Package Type: LOE, Discrete
    • Activity Id, Activity Name
    • Start Date, End Date
    • Percent Complete
    • Active
  • As a Action consumer, I want to be able to see what Activity Id and Activity Name to charge to on each action
  • As a Cost Account Manager (CAM), I want to enter a single percent complete for each Work Package
  • As a CAM, I want to be able to search for Work Package by Id
  • As a CAM, I want to see all related Team Workflows, Tasks, Reviews and Goals for each Work Package and their percent complete
  • As a Manager, I want to be able to import and re-import Work Packages from excel spreadsheet with valid attributes
  • As a Manager, I want to see the Start and End date for each Work Package
  • As a Manager, I want to see if Work Package is Discrete or LOE

Definitions

Work Package = Active account that has calculated and reported earned value.
Planning Package = Planned work, not yet active.
Activity Id = End user account to charge.

Product Owner / Manager - Create Work Packages

  1. Open Artifact Explorer
  2. Select Common Branch
  3. Find Team Definition (SAW Code)
  4. Create new child
  5. Artifact Type: Work Package
  6. Name: Earned Value task name (Work Pkg 01..03)
  7. Open Team Definition (SAW Code)
  8. Drag new Work Package to Team Definition -> Work Package relation
  9. Add and set Activity Id and Activity Name (ASDHFA43 and HUF 210 )
  10. Set other desired attributes

Product Owner / Manager - Create Work Packages

  1. Search your objects in ATS
  2. Add the "Activity Id" column
  3. Select one or more items
  4. Right-click > Edit > Edit Activity Id OR Alt-Left-Click in Activity Id column

Note: Activity Id can be set on Team Workflow, Task, Goal and Reviews

Action Consumer - View Activity Ids

  1. Search your objects in ATS
  2. Add the “Activity Id” column

Account Manager - Search for Work Packages

  1. Search your objects in ATS
  2. Add the "Activity Id" column
  3. Select one or more items
  4. Right-click > Edit > Edit Activity Id OR Alt-Left-Click in Activity Id column

Note: Activity Id can be set on Team Workflow, Task, Goal and Reviews

Account Manager - View all related items

  1. Select "Earned Value Work Package Report"
  2. Drag in Work Packages > Run
  3. Report displayed

Account Manager - Set Percent Complete

  1. Edit all available attributes of your Work Package through Artifact Editor

OSEE and Agile / SCRUM - How do I...

OSEE has a built in Problem Change Request and Configuration Management system called the Action Tracking System (ATS). This tracking system has some powerful features that supports Agile Software Development and SCRUM Software Development

use Goals to track backlog

The "Action" object in ATS exists to relate all the Team Workflows, Reviews and Tasks that are necessary to complete a single "action" such as "Make these changes to that widget". The "Goal" object, in contrast, is used to group any ATS objects for any other purpose, such as an Agile backlog.

Goals can contain any Team Workflows, Reviews, Tasks and even other Goals. In addition ATS objects can belong to multiple Goals.

Items can be added to goals by one of the following methods

  • Opening Goal and draging items into the members tab
  • Adding the "Goal" column to any world view and selecting the Goal to add to
    • Alt-Left-Click the Goal cell
    • Selecting items > right-click > Edit > Goal
  • Configuring a Team Definition or Actionable Item to auto-add created Team Workflows to any goals. [OSEE/TipsTricks#configure_to_automatically_add_new_Actions_to_a_Goal|More Information]]

Goals are ordered which supports the need for a ordered backlog.

Items in the Goal members tab can be re-ordered by one of the following methods

  • Selecting item(s) and drag them to a new location
  • Selecting item(s) > right-click > Set Goal Order > Select new location
  • Alt-left-click the Goal Order column and entering new location

use Points column to set points

Add the "Points" column and select points by

  • Selecting items > right-click > Edit > Points
  • Alt-left-click Points column cell

sum entered Points for a Sprint or selected items

It is easy to sum the points column for the selected items when using the Points Column. Add the "Points" column > Select items to sum > Right-click the "Points" column header > Select "Sum Selected for Column" > a dialog will popup with the sum of points for the selected items.

use Targeted Version, Groups, Notes or Category to track Sprints

There are a number of different ways to track Sprints in OSEE. Targeted Versions are normally used to track builds and releases, but could also be used to track Sprints. If Targeted Versions are already used for builds or releases, other text-based columns can be used. Among these are the "Notes" column or any of the 3 open "Category" columns.

use Goal Members tab to support daily stand-ups/scrum meetings

A common characteristic in Agile is a daily stand-up or scrum meeting. These meetings are commonly held using a post-it-note task board. Another option is by showing the backlog Goal with current spring items at the top or by having another Goal containing only the current sprint items. The team members can call out the current item order number they finished and which they will work on next.

automatically add new Team Workflows to a backlog Goal

Since an Agile backlog is supposed to contain all items, ATS has a configuration that will automatically add new Team Workflows to any number of Goals. How to configure

use import features to automatically create actions, workflows and tasks for backlog

OSEE has a number of existing features to easily create ATS objects for use in backlogs.

Among these are:

  1. Importing Actions via spreadsheet
  2. Importing tasks from simple list
  3. Add Team Workflow to existing Action
  4. Duplicate existing Team Workflow (advanced)

use OSEE to support Agile/Scrum in the future

As OSEE is used more an more for Agile/Scrum, new features will be incorporated.

Some ideas for improvements are:

  1. Automated generation of Sprint Burndown charts
  2. Web interface of backlog / sprint goals to support daily stand-ups
  3. Web view of "Scrum Task Board"
  4. Workflow Definitions tailored to Scrum states such as "to-do", "in-work", "testing", "done"
  5. Easier ways to import items into OSEE/backlog
  6. Automatic generation of items performed frequently by teams, some ideas are
    1. Configure by Team or Actionable item to automatically create a set of tasks on Team Workflow creation
    2. Configure a set of Workflows, Tasks an Reviews to be created for each Sprint
    3. Configure a selectable list of items to create anytime they choose

NOTE: These are ideas only and are not yet scheduled for implementation. As always, contributions to OSEE in this or any area are welcome.