Jump to: navigation, search

VJET/Getting Started

Getting started with VJET JavaScript IDE is easy; simply create a VJET Project and begin coding JavaScript using the code assist features. 

Let's Get Started

  1. Make sure you are in the VJET JS Perspective.  If not, select the menu item Window > Open Perspective> Other..., then select VJET JS.
  2. Create a VJET Project.  Select the menu item File > New > VJET Project.  Enter your project's name, and click Finish.
  3. You can now begin coding JavaScript. Select the menu item File > New > JavaScript Source File.  Enter a file name then click Finish.

    Vjet new js file.gif


  4. With a VJET Project and JavaScript file, you can begin using the code assist features in VJET JS.  Code assistance is available for:
    • JavaScript primitive and native types
    • Browser and DOM types
While typing JavaScript, trigger code assist by pressing Ctrl-Space.  A list of code options appear; select an option and press Enter to insert the code.


Vjet help hover3.gif


Continue to explore code assist using native JavaScript and other  Browser and DOM types.  Drill down past the first selection by typing a period (.), then pressing Ctrl-Space for the next level of code proposals.


Vjet code assist drilldown.gif


What's Next?

The fastest way to become proficient with VJET JavaScript IDE is to code.  However, for a quick introduction of the major features in VJET JavaScript IDE, take a look at the following documents. 


Wiki Documentation

Eclipse VJET JavaScript Documentation

Since VJET JavaScript IDE is an Eclipse plugin, most of the documentation will be available in Eclipse, so you can step through tutorials and write code at the same time.  The VJET JavaScript IDE Installation Guide includes a section on VJET JavaScript Documentation in Eclipse.