Skip to main content
Jump to: navigation, search

MOOSE FAQ

Questions not answered here can be directed to the ICE development list by emailing ice-dev <at> eclipse.org.

My ICE workbench looks different than the screenshots in your tutorials

All the tabs and windows in NiCE can be minimized, closed, re-sized, dragged and re-positioned. If your workbench looks different than the ones in our tutorials, this is only because we re-arranged our workbench in a way that we felt was more intuitive for the flow of the tutorial. Feel free to organize and arrange your workbench in a way that works best for you.


The Tree View says "MOOSE app...", but there is nothing in the drop-down menu to choose from and/or nothing happens

This means that you don't have the correct `.yaml` and `.syntax` files in your MOOSE directory. Make sure you've followed the instructions for correctly creating these files on your local system.


I selected a block in the Tree View, but can't find the parameters associated to it

Block parameters are always displayed as a table in our Property View. It's possible you may have minimized or closed your Property View tab accidentally.

If it's been minimized, look for a small table-like icon on the right-hand side of your ICE workbench and click it.

ICE PropertyIcon.png

If you can't find such an icon, then the Property View has probably been closed. To re-open it, use the toolbar at the top of the ICE workbench:

  1. Navigate to Window > Show View > Other... > General > Properties
  2. Click OK and the Property View tab should now appear. You can re-size or drag the window to a spot in the workbench that best suits your needs.

How can I view the file generated by the MOOSE Model Builder?

In the toolbar at the top of the NiCE workbench, navigate to File > Open File..., and select the file in your ICE workspace that you'd like to view. If the file type (*.i) is already associated to another program in your operating system, then the file will launch externally in that application. Otherwise, the file should open directly in ICE's native text editor.

If for any reason the file extension is associated to another application (for example, Xcode on a Mac) and you'd prefer for the file to open within the ICE workbench, assign the file extension in ICE using the following steps:

  1. Window > Preferences > General > Editors > File Associations
  2. In the top box, click Add... and define a file type called *.i (including the wild character). Click OK.
  3. Select the new *.i file type entry. In the Associated editors box below, click Add..., and from the list of internal editors, find Text Editor. Click OK.
  4. Close the Preferences window by clicking OK.

Using the File > Open File... function should now force any *.i files to open within ICE's native text editor.

Note that this method only overrides your file type association within NiCE, and doesn't impact the file association set on your operating system.

Back to the top