Skip to main content
Jump to: navigation, search

Apogy/Installation

Overview

Apogy is based on Eclipse platform https://www.eclipse.org. It makes use of 3D so it is important to install latest & stable version of graphics card 3D drivers.

Supported Platforms

32-bit Windows | 64-bit Windows | 32-bit Linux (GTK) | 64-bit Linux (GTK)

Update Sites

  1. Stable: [TBD] OR
  2. Latest: [TBD]

Java Virtual Machine

  1. Ensure a proper Java Runtime Environment (JRE) is installed on your system (1.8 or higher). You can download JRE from http://www.oracle.com/technetwork/java/javase/downloads/index.html.
  2. The virtual machine must be accessible in the PATH. Type the following commands in a system shell to verify the installed java version.
    java -version
    java version "1.8.0_60"
    Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
    Java(TM) SE Runtime Environment (build 1.8.0_60-b27)

Eclipse Project Package

  1. Get the Eclipse Project Package from http://download.eclipse.org/eclipse/downloads/ (Latest Release).
  2. Extract the archive under <ECLIPSE_INSTALLER_HOME>.
  3. Copy <JRE_HOME> directory into <ECLIPSE_INSTALLER_HOME> directory. You may also use a symbolic link.
    eclipse
      configuration
      eclipse
      eclipse.ini
      features
      plugins
      jre      <<<< must include /bin/java
      ...
  4. Edit <ECLIPSE_HOME>/eclipse.ini and change the following lines that set VM memory parameters (see below).
    -Xms256m                              <<<< Replace by -Xms2048m 
    -Xmx1024m                             <<<< Replace by -Xmx2048m
  5. Save your changes.
  6. Launch the <ECLIPSE_HOME>/eclipse.
  7. The Workspace Launcher dialog will prompt. Select the location of a new or an existing workspace. The workspace will contain the information related to your Apogy session.

Apogy

  1. Select Help->Install New Software...
  2. On the Install Dialog, Click on Add...
  3. Set the name to Apogy
  4. Set the Location to one of the following update site.
    1. Stable: [TBD] OR
    2. Latest: [TBD]
  5. Click on OK
  6. Select Apogy package
  7. Click on Next>
  8. On Install Details page, click on Next>
  9. On Review Licenses page, select Accept then click on Finish

Known Issues

  1. On Linux, add the following to your .bashrc :
    export SWT_GTK3=0

Back to the top