Jump to: navigation, search

Difference between revisions of "FAQ My runtime workbench runs, but my plug-in does not show. Why?"

(Fixing all the wiki markup.)
m
 
Line 7: Line 7:
 
Various configuration-related things could be wrong.
 
Various configuration-related things could be wrong.
  
* The plug-in may not be selected in the launch configuration. See [[FAQ How do I run my plug-in in another instance of Eclipse?]]
+
* The plug-in may not be selected in the launch configuration. See [[FAQ How do I run my plug-in in another instance of Eclipse?]] for instructions on how to select plug-ins.
for instructions on how to select plug-ins.
+
 
* Your plug-in may rely on other plug-ins not enabled in your current launch configuration. Check the error log. See [[FAQ Where can I find that elusive .log file?]] for messages referring to your plug-in.
 
* Your plug-in may rely on other plug-ins not enabled in your current launch configuration. Check the error log. See [[FAQ Where can I find that elusive .log file?]] for messages referring to your plug-in.
 
* If your plug-in contributes an action to the toolbar and it does not show or if a menu option does not appear, your plug-in may still be activated. The workbench does not automatically add toolbar and menu items to every perspective. Run '''Window > Customize Perspective''' and verify whether your contribution is enabled for the current perspective.
 
* If your plug-in contributes an action to the toolbar and it does not show or if a menu option does not appear, your plug-in may still be activated. The workbench does not automatically add toolbar and menu items to every perspective. Run '''Window > Customize Perspective''' and verify whether your contribution is enabled for the current perspective.

Latest revision as of 20:58, 27 December 2012

Despite all these instructions, in some cases, your plug-in builds fine and the runtime workbench launches but your plug-in still does not show. Various configuration-related things could be wrong.

  • The plug-in may not be selected in the launch configuration. See FAQ How do I run my plug-in in another instance of Eclipse? for instructions on how to select plug-ins.
  • Your plug-in may rely on other plug-ins not enabled in your current launch configuration. Check the error log. See FAQ Where can I find that elusive .log file? for messages referring to your plug-in.
  • If your plug-in contributes an action to the toolbar and it does not show or if a menu option does not appear, your plug-in may still be activated. The workbench does not automatically add toolbar and menu items to every perspective. Run Window > Customize Perspective and verify whether your contribution is enabled for the current perspective.
  • Your plug-in may not show because it is not yet needed. If all your plug-in does is contribute a view, you may need to show it explicitly by using Window > Show View > Other.... If your plug-in contributes an editor for a particular type, you may need to configure the file association; see Window > Preferences > Workbench > File Associations.
  • Your plug-in may throw an exception in its static initializer or in its plug-in class instance initializer. Again, consult the log file for error messages involving your plug-in.

See Also:

FAQ What causes my plug-in to build but not to load in a runtime workbench?


This FAQ was originally published in Official Eclipse 3.0 FAQs. Copyright 2004, Pearson Education, Inc. All rights reserved. This text is made available here under the terms of the Eclipse Public License v1.0.