FAQ Where can I find that elusive .log file?

From Eclipsepedia

Jump to: navigation, search

Whenever it encounters a problem that does not warrant launching a dialog, Eclipse saves a report in the workspace log file. The log file can be looked at in four alternative ways.

  • Window > Show View > PDE Runtime > Error Log. This gives you a view with the contents of the .log file.
  • Help > About Eclipse Platform > Configuration Details. This prints out a great number of details about the environment and also concatenates the .log file. Great for including in a bug report.
  • Locate the file yourself, see workspace/.metadata/.log.
  • Start Eclipse using -consoleLog. This will print the messages that normally go to the .log file in the enclosing shell/command window.

See Also:


This FAQ was originally published in Official Eclipse 3.0 FAQs. Copyright 2004, Pearson Education, Inc. All rights reserved. This text is made available here under the terms of the Eclipse Public License v1.0.