Jump to: navigation, search

Working with the DTP 0.7 Source

Back

CVS Location of DTP 0.9 Plug-ins

(Looking for information about DTP 0.9? Here you go.)

DTP 0.7 is housed in three CVS modules at eclipse.org:

  • org.eclipse.datatools.modelbase
  • org.eclipse.datatools.connectivity
  • org.eclipse.datatools.sqldevtools

You can access these modules via anonymous pserver at:

  • Server: dev.eclipse.org
  • Path: /home/datatools

Note: You will need to check out the R07 branch of DTP, or else you will get the 0.9 code line (CVS HEAD). You might have to click on Refresh Tags in the Eclipse CVS importer for this branch to appear.

Environment Settings

  • You should set you default Java compliance level to "1.4" for both source and class files, or else you will get errors, since some DTP components use the "assert" method.
  • You will also need to get a copy of the third party libraray lpg.jar in order to compile the org.eclipse.datatools.sqldevtools.parsers.* plug-ins. Instructions for obtaining and installing this jar can be found here.

Plug-in List

The following plug-ins comprise the DTP 0.7 code line:

  • org.eclipse.datatools.connectivity.db.derby
  • org.eclipse.datatools.connectivity.db.generic.ui
  • org.eclipse.datatools.connectivity.db.generic
  • org.eclipse.datatools.connectivity.dbdefinition.db2.luw
  • org.eclipse.datatools.connectivity.dbdefinition.derby
  • org.eclipse.datatools.connectivity.dbdefinition.genericJDBC
  • org.eclipse.datatools.connectivity.dbdefinition.oracle
  • org.eclipse.datatools.connectivity.dbdefinition.sybase
  • org.eclipse.datatools.connectivity.derby
  • org.eclipse.datatools.connectivity.oda.design.ui
  • org.eclipse.datatools.connectivity.oda.design
  • org.eclipse.datatools.connectivity.oda.flatfile.ui
  • org.eclipse.datatools.connectivity.oda.flatfile
  • org.eclipse.datatools.connectivity.oda.profile
  • org.eclipse.datatools.connectivity.oda
  • org.eclipse.datatools.connectivity.sqm.core.ui
  • org.eclipse.datatools.connectivity.sqm.core
  • org.eclipse.datatools.connectivity.sqm.server.ui
  • org.eclipse.datatools.connectivity.ui.dse
  • org.eclipse.datatools.connectivity.ui
  • org.eclipse.datatools.connectivity
  • org.eclipse.datatools.modelbase.dbdefinition
  • org.eclipse.datatools.modelbase.derby
  • org.eclipse.datatools.modelbase.edit
  • org.eclipse.datatools.modelbase.sql.query
  • org.eclipse.datatools.modelbase.sql.xml.query
  • org.eclipse.datatools.modelbase.sql
  • org.eclipse.datatools.sqltools.common.ui
  • org.eclipse.datatools.sqltools.db.derby
  • org.eclipse.datatools.sqltools.db.generic
  • org.eclipse.datatools.sqltools.debugger.core
  • org.eclipse.datatools.sqltools.editor.core
  • org.eclipse.datatools.sqltools.parsers.sql.lexer
  • org.eclipse.datatools.sqltools.parsers.sql.query
  • org.eclipse.datatools.sqltools.parsers.sql.xml.query
  • org.eclipse.datatools.sqltools.parsers.sql
  • org.eclipse.datatools.sqltools.plan
  • org.eclipse.datatools.sqltools.result
  • org.eclipse.datatools.sqltools.routineeditor
  • org.eclipse.datatools.sqltools.sql
  • org.eclipse.datatools.sqltools.sqleditor
  • org.eclipse.datatools.sqltools.sqlscrapbook

Compatibility Layer

DTP 0.7 was developed for use on Eclipse 3.1 and 3.2. To reuse the main code line between these two platform versions, a compatibility layer was created for Eclipse 3.1. the compatibility layer (available on the DTP download site) has three plug-ins:

  • org.eclipse.datatools.connectivity.compatibility
  • com.ibm.icu
  • org.eclipse.ui.navigator

The latter two were snapshots taken from the Eclipse 3.2M5 stream, and the first contains code ports from the same stream. We do not recommend that you keep these in your development environment -- just install binary in your plugins folder.