TigerstripeDevEnvironment

From Eclipsepedia

Jump to: navigation, search

Contents

< To: Tigerstripe

Minimum Requirements

The current development stream requires the following:

  • Eclipse 3.4.x (as of 07/10/08) - The "Eclipse Classic" bundle from Eclipse Downloads
  • Java5 minimum

Setting up your workspace

We provide Buckminster CQueries for easy set up. Please visit http://www.eclipse.org/tigerstripe/queries.

To set up a regular "workbench" development environment, use the following query (hit "resolve and materialize"):

http://www.eclipse.org/tigerstripe/queries/tigerstripe-workbench.cquery

Setting up the Run/Debug Configuration

  • Create a new Debug Configuration, using all the default settings.
  • On the "Arguments" tab, set the VM arguments to read
-Xmx256m -XX:MaxPermSize=128m