Jump to: navigation, search

Sirius/3.1.7

Sirius 3.1.7 is a service release with only bugfixes.

Availability

Sirius 3.1.7 was released on 2016-11-04 (tag v3.1.7, commit 3003c5b7b7ea0628ce2a01f94a63f28f49ab0962). It is available from the following update sites:

It is recommended you use the update-site matching the version of Eclipse you use to avoid potential issues at runtime.

IMPORTANT: To enable the support for AQL expressions in VSMs (which is now the recommended query language to use), you will need the latest version of AQL, available from http://download.eclipse.org/acceleo/updates/releases/3.6/.

This version includes the complete JUnit and SWTBot test suites used to validate Sirius. They are published along with all their dependencies in separate update-sites from the core, available at:

If you want to install the org.eclipse.sirius.tests.support feature, which provides APIs to help create automated tests of Sirius-based modelers, you will need to add the following update-site:

If you want to install and run the test suites themselves, you will also need the following additional update-site:

It is needed to run the tests which use an old query language (which is now superseded by AQL, the core feature:/var:/service: interpreters, and Acceleo 3/MTL).

Juno users: Sirius depends on more recent versions of some components that what is available by default from a Juno install. You need to add the following update-sites if you want to install Sirius 3.1.7 on Juno:

Compatibility

Sirius 3.1.7 is compatible with the following versions of Eclipse:

  • Eclipse 3.8/4.2 (Juno)
  • Eclipse 4.3 (Kepler)
  • Eclipse 4.4 (Luna)
  • Eclipse 4.5 (Mars)

Eclipse 4.5 (Mars) is the reference platform.

New & Noteworthy

The complete list of (3) tickets fixed in Sirius 3.1.7 can be found here on the Bugzilla.