Sirius/1.0.0M5

From Eclipsepedia

Jump to: navigation, search

Sirius 1.0.0M5 is a milestone release which has been included in Luna M5. The project is still in incubation at this time.

See also the announce on the mailing list.

Availability

Sirius 1.0.0M5 was released on 2014-01-27 (tag v1.0.0M5, commit 08cef0cf45e5af83f3fdc353f03cb52a0e602eeb). It is available from the following update sites:

It is recommended you use the update-site matching the version of Eclipse you use to avoid potential issues at runtime.

Juno users: Sirius depends on more recent versions of some components that what is available by default from a Juno install. You need to add the following update-sites if you want to install Sirius 1.0.0M5 on Juno:

Compatibility

Sirius 1.0.0M5 is compatible with the following versions of Eclipse:

  • Eclipse 3.8/4.2 (Juno)
  • Eclipse 4.3 (Kepler)
  • Eclipse 4.4M5 (Luna)

New & Noteworthy

Apart from a few bug fixes related to tables, most of the changes in this release only impact the internal structure of the code.

  • #423037 is the first phase of a larger-scale work to separate the code implementing the "diagrams" dialect from the Sirius core. It involved moving diagram-related types from the metamodel into their own Ecore packages. Existing models will be transparently migrated when loaded and continue to work as before. If you have Java code which referenced the corresponding types, you will need to make some adjustments; see the release notes for details.
  • #423051 moved some generic code out of the main Sirius plug-ins and into library extensions, which are separate plug-ins. If you had Java code which used the corresponding types, you will need to update it by possibly adding new dependencies (to the library extensions) and changing the import declarations in your code; see the release notes for details.

The complete list of bugs fixed in this version can be seen on Bugzilla.