Scout/HowTo/3.7/Install Scout SDK

From Eclipsepedia

< Scout‎ | HowTo‎ | 3.7
Jump to: navigation, search


Scout
Wiki Home
Website
DownloadGit
Community
ForumsBlogTwitter
Bugzilla
Bugzilla

Installing Scout SDK is really easy.

Install Eclipse with Scout SDK

Visit the Eclipse Download-page to get Eclipse bundled with the Scout SDK.

InstallScout devDownloads.png

Note.png
JRE 1.6 required
Eclipse Scout SDK requires Java 6 or greater. If there is no Scout perspective you probably need to install an appropriate JRE.
If you have multiple JREs installed and want to be sure the right one is used start Eclipse Scout using the -vm command line argument and specifying the path to the executable: eclipse -vm c:\path_to_the_jre\bin\java.exe


Add the Scout SDK to your Eclipse installation

Note.png
Eclipse
These instructions assume that you have Eclipse installed already.

To add Scout SDK to your existing Eclipse installation, you need to open eclipse and select Help|Install New Software...

UpdateSite step1.PNG

Use http://download.eclipse.org/scout/releases/3.7 in the dialog that shows up and expand Scout Application Development.
Tick all checkboxes:

Select Scout Application Development drill down

Hit next twice and restart Eclipse. You are ready to use the Scout Perspective.