STP/GettingStarted

From Eclipsepedia

< STP
Jump to: navigation, search

Prerequisites for STP 1.0

These are the Java and Eclipse project requirements that you will need for STP 1.0. When the Ganymede release appears, you should be able to just select the STP project you need in the update tool and it should automatically resolve the dependencies for you. This will make life a little easier. There will be more instructions once we get to the date!

* JDK 1.5 or 1.6 to run Eclipse
* WTP 3.0
* EMF 2.4, comprising EMF-XSD, EMF-Query, EMF-Transaction, EMF-Validation
* OCL 1.2
* JET 0.9
* GMF 2.1
* GEF 3.4