Jump to: navigation, search

PTP/environment setup 30

< PTP

Setup for development of PTP 3.0

Note: as of Dec '09, HEAD is now development for Helios/PTP 4.0 Note that these instructions show you how to check out the ptp_3_0 branch

PTP 3.0 needs Eclipse 3.5.x, CDT 6.0.2, and RSE 3.1

  • We suggest increasing heap size (e.g. in eclipse.ini file) from -Xmx256m to -Xmx512m

For offline installation of pre-reqs, download the following archived update sites:

  1. RSE 3.1.1 update site archive
  2. CDT 6.0.2

Install RSE 3.1.1 End-User Runtime, and CDT 6.0.2, in your eclipse installation

  • Help > Install New Software.. .and add both the above downloaded archives
  • To see just the local archives and install all at once, select, under "Work with:", "--Only Local Sites--"
  • For RSE: Under TM and RSE 3.1.1, install the "Remote System Explorer End-Use Runtime"
  • For CDT: Install all "CDT Main Features" and under "CDT Optional Features" install everything *except* "Eclipse CDT Testing Feature"
  • Next, Next, accept license terms, Finish


See http://wiki.eclipse.org/PTP/environment_setup_21 for background information and instructions on setup for the previous release; may be useful.

To check out PTP projects:

  • In CVS, check out org.eclipse.ptp/releng/ptp_project_sets
    • Window > Open Perspective > Other..., CVS Repository Exploring
    • Rightmouse in CVS Repositories view, New > Repository Location
      • Host: dev.eclipse.org, Repository path: /cvsroot/tools, User: anonymous
        • If you have a committer id on dev.eclipse.org, use that, enter the password, and change the Connection type to extssh
    • Expand that repository and expand HEAD. Scroll down to org.eclipse.ptp and expand it
    • Under releng, check out ptp_project_sets
  • Return to the Plug-in development Perspective
  • Note: if you have firewall problems, and need to use a proxy, you may need to put the proxy info into the project sets file.
    • replace 'dev.eclipse.org:' with 'proxy.eclipse.org:80' -- see [1] for further tips on firewall/proxy issues.
  • In the ptp_project_sets project in your workspace, rightMouse on anonymous/ptp-3.0-all-anonymous.psf and select "Import project set"
  • It should check out everything you need.

Building runtime binary

To e.g. run with a resource manager, you may have to build some platform-specific binary/proxy code. For example, to run with OpenMPI locally on MACOSX, cd to the org.eclipse.ptp.macosx.x86 project in a terminal window, and execute

  • sh BUILD

This should build the executable 'sdm' in the bin/ directory. Do not be alarmed if you see "LoadLeveler not installed, skipping..." etc - if you do not have these IBM components installed on your system, there is no need for it to build those binaries.

Launching a runtime workbench running the code you checked out into your workspace

  1. Run > Debug Configurations ...
  2. Double-click on 'Eclipse Application' - or click and click on the 'new' icon
  3. Defaults are probably ok to run with all the plugin projects in your workspace; hit 'Debug' in lower right corner
  4. Eclipse comes up. Switch to C/C++ perspective if needed
  5. For details on creating an MPI or OpenMP project, see Help > Help Contents ...