Jump to: navigation, search



Quick guide

Following is a two-step guide to get and build PDT source code:

1. Get PDT source code:

 git clone http://git.eclipse.org/gitroot/pdt/org.eclipse.pdt.git
 # or if you're eclipse user and/or PDT committer: git clone ssh://committerid@git.eclipse.org:29418/pdt/org.eclipse.pdt.git 

2. Build PDT using Maven:

 cd org.eclipse.pdt                            // project root dir
 mvn clean install                             // build and run all tests
 mvn clean install -DskipTests                 // build and ignore all tests
 mvn clean install -DskipPdtPerformanceTests   // build and skip performance tests only (recommend)

3. Build PDT release:

 cd org.elipse.pdt                             // project root dir
 mvn clean install -Prelease                   // this will produce normalized, signed and packed release, inside eclipse.org infrastructure
 mvn clean install -Prelease -DskipSign        // this will produce normalized and packed release

Working with PDT source code in Eclipse

  1. To comfortably edit PDT source code you will need Eclipse JDT and PDE. Ideally Eclipse Classic package from Eclipse downloads page is what you need. Great addition can be m2eclipse.
  2. Check out PDT plugins to Eclipse workspace. Select the XML text below and save it to file projectSet.psf
  3. In Eclipse, choose File->Import, select Team->Team Project Set and choose projectSet.psf file created in step 2. After finishing the import wizard, you should see all PDT source code in your workspace. Source code might not be compiling yet
  4. Find file org.eclipse.php.core/Resources/parserTools/build.xml and launch it as Ant Build. This will generate PHP language parser classes.
  5. Install missing dependencies:
    1. Dynamic Languages Toolkit - Core Frameworks
    2. Dynamic Languages Toolkit - Core H2 Index Frameworks (uncheck "Group items by category" to see this one)
    3. Eclipse Web Developer Tools
    4. Eclipse XML Editors and Tools
  6. In preferences (Window->Preferences->Plug-in Development->API Baselines), switch "Missing API baseline" to "Warning" or "Ignore".
  7. You can now run PDT in Eclipse self-hosting mode. Click on any of PDT projects and choose Run As->Eclipse Application
  8. If your developer environment have PDT already installed, you might want disable debugger daemons via: -Dorg.eclipse.php.debug.disableDaemonStartup in eclipse.ini

Preparing and sending patches

When you decide to send us your new amazing patch, please read this articles how to do it:

  1. Make sure you are signed Eclipse Foundation Contributor License Agreement
  2. Configure Gerrit with git
  3. Prepare patch and send it to Gerrit

Patch naming conventions

Each patch message, at first line have to follow one of these patterns:

1. If you fixed bugzilla bug (for example #1234)

  Bug 1234 - Bug / patch description

2. Other patches:

  No bug - Your patch description

If your patch is still in progress, to avoid confusion add "[WIP] " prefix.

   [WIP] Bug 1234 - Bug description


Sonar is used in order to track Code Quality:

  1. Sonar dashboard: https://dev.eclipse.org/sonar/project/index/org.eclipse.php:org.eclipse.pdt.releng
  2. Reports are ganerated based on dedicated build: https://hudson.eclipse.org/pdt/job/pdt-sonar/#https://hudson.eclipse.org/pdt/job/pdt-sonar

PDT Team Project Set

You can quickly set up your Eclipse workspace using the following Team Project Set. Save the following text into a file named "pdt.psf"; use "File > Import > Team Project Set" to import that file.

 <?xml version="1.0" encoding="UTF-8"?>
 <psf version="2.0">
 <provider id="org.eclipse.egit.core.GitProvider">
 <project reference="1.0,http://git.eclipse.org/gitroot/pdt/org.eclipse.pdt.git,master,plugins/org.eclipse.php.core"/>
 <project reference="1.0,http://git.eclipse.org/gitroot/pdt/org.eclipse.pdt.git,master,plugins/org.eclipse.php.core.parser"/>
 <project reference="1.0,http://git.eclipse.org/gitroot/pdt/org.eclipse.pdt.git,master,plugins/org.eclipse.php.debug.core"/>
 <project reference="1.0,http://git.eclipse.org/gitroot/pdt/org.eclipse.pdt.git,master,plugins/org.eclipse.php.debug.daemon"/>
 <project reference="1.0,http://git.eclipse.org/gitroot/pdt/org.eclipse.pdt.git,master,plugins/org.eclipse.php.debug.ui"/>
 <project reference="1.0,http://git.eclipse.org/gitroot/pdt/org.eclipse.pdt.git,master,plugins/org.eclipse.php.help"/>
 <project reference="1.0,http://git.eclipse.org/gitroot/pdt/org.eclipse.pdt.git,master,plugins/org.eclipse.php.mylyn.ui"/>
 <project reference="1.0,http://git.eclipse.org/gitroot/pdt/org.eclipse.pdt.git,master,plugins/org.eclipse.php.server.core"/>
 <project reference="1.0,http://git.eclipse.org/gitroot/pdt/org.eclipse.pdt.git,master,plugins/org.eclipse.php.server.ui"/>
 <project reference="1.0,http://git.eclipse.org/gitroot/pdt/org.eclipse.pdt.git,master,plugins/org.eclipse.php.ui"/>
 <project reference="1.0,http://git.eclipse.org/gitroot/pdt/org.eclipse.pdt.git,master,plugins/org.eclipse.php.formatter.core"/>
 <project reference="1.0,http://git.eclipse.org/gitroot/pdt/org.eclipse.pdt.git,master,plugins/org.eclipse.php.formatter.ui"/>
 <project reference="1.0,http://git.eclipse.org/gitroot/pdt/org.eclipse.pdt.git,master,plugins/org.eclipse.php.refactoring.core"/>
 <project reference="1.0,http://git.eclipse.org/gitroot/pdt/org.eclipse.pdt.git,master,plugins/org.eclipse.php.refactoring.ui"/>

Developer Resources

After setting up PDT source code please have a look at a set of docs we have for our developers on PDT#Developer_Resources page.

Update help pages

All help pages sitting under plugins/org.eclipse.php.help/docs/source/ in *.md format.

While make install, our build system converting it to *.html files in exactly same structure and also:

  1. Remove ###- part from each *.md file, and fix all internal links.
  2. Regenerate IPHPHelpContextIds interface
  3. Build helpContexts.xml file
  4. Build toc.xml file

Which editor should I use?

You can work with any markdown editor, but because our build system use Mylyn Wikitext, you should install wikitext editor from https://eclipse.org/mylyn/downloads/ to be sure that everything is ok.

Howto register new help context id?

Add this code to markdown file: