Skip to main content
Jump to: navigation, search

Installation steps of Papyrus for Requirements

This guide provides instructions on how to install Papyrus for Requirements.

1. Download Papyrus RCP (Neon version) from https://eclipse.org/papyrus/download.html

2. Unzip the downloaded file.

3. Open Papyrus by clicking on the file "papyrus.exe".

4. Select your workspace

5. Install SysML14

5.1. Click on "Help" > "Install new software"

5.2. Enter the following update site location in the "Work with" field and press "Enter":

http://download.eclipse.org/modeling/mdt/papyrus/components/sysml14

5.3. Select "Papyrus SysML 1.4 Feature (Incubation)"

5.4. Finish the installation and restart Eclipse.

6. Install Papyrus for Requirements

6.1. Click on "Help" > "Install new software"

6.2. Enter the following update site location in the "Work with" field and press "Enter":

https://hudson.eclipse.org/papyrus/view/Requirements/job/Requirements-Neon/lastSuccessfulBuild/artifact/releng/org.eclipse.papyrus.requirements.p2/target/repository/

6.3. If you want to work with SysML 1.4, select all the features except "Papyrus for Requirements based on SysML11 (Incubation)".

6.4. Finish the installation and restart Eclipse.

Back to the top