Equinox/p2/Meetings/20090126

From Eclipsepedia

< Equinox‎ | p2‎ | Meetings
Jump to: navigation, search

Agenda / Minutes

  • Remember to focus on M5
  • Discussion about the supporting the update from 3.4 to 3.5
    • Eclipse has never been able to support such a scenario. UM even had problems updating to a point release.
    • The consensus was that we would not be able to update from 3.4 to 3.5
    • Reaons invoked:
      • Because the update from 3.4 to 3.5 is running the 3.4.2 code
      • bundles.info and other files have moved form URL to URI
      • the rollback would be problematic because it is unclear if 3.5 can be writing 3.4 format.
      • Transport having reliability issues
      • Overall it seemed that there would be very little benefit for a lot more work, when in the end all the majority of plug-ins are changing
    • Approaches have been discussed
      • Create a 3.4++ all of p2 from 3.5 and then do the update
      • Change the readers and writers from 3.5
    • This issue will be revisited for 3.6
  • Discussion about the categories
    • tagging
    • tool side supposrt
    • what do we show in the flat 256044
    • follow up on the 261104
  • Update on the explanation work 200380
    • Daniel and Jed have made progress. Pascal to look some more.

Attendees

  • Darin
  • Curtis
  • John
  • Simon
  • DJ
  • Matt
  • Pascal
  • Doug
  • Tom
  • Scott
  • Jeff
  • Henrik L.
  • Susan
  • Ian
  • Thomas H
  • Dave S