Jump to: navigation, search

Dali 3.3 M7 Release

Dali 3.3

Dali 3.3 M7 Release Manual Testing

Manual Testing for 3.3 M7 Release
Bug No. Description Test Steps Test Step Results
380021 Extra invalid validation error against default primary key join column of entity Create a JPA project JPA Project is created successfully
... ... Create a JPA Entity with an attribute that is set as the primary key but is not the same name as a name in the database so it will not be resolved Verify JPA entity is created and only 1 error appears in problems pane stating Column "id" cannot be resolved on table "TableName"
391578 EclipseLink OXM Mapping File creation wizard Create JAXB Project JAXB project is created successfully
... ... R-Click on project and select New > package Verify New Java Package dialog appears
... ... Enter a name, check the Create package-info.java checkbox and click on finish button Verify the package is created successfully and the package-info.java file is created within the package and appears in the editor
... ... Right Click on the package and Select New > EclispeLink MOXy OXM File Verify New EclipseLink MOXy OXM File dialog appears
... ... Click on Cancel button Verify dialog closes and EclipseLink MOXy OXM mapping file was not created.
... ... Highlight JAXB Project and select File > New > Other Verify New dialog appears
... ... Select JAXB > EclipseLink > EclipseLink MOXy OXM File and click on Next Verify Specify OXM file name and location page appears
... ... Select the src folder, leave default File name (oxm.xml) and click on next button Verify Specify OXM file options page appears
... ... Enter the package name you created and click on the Finish button Verify the EclipseLink MOXy OXM mapping file is created successfully without error
392222 Remove "Create mapping file (orm.xml)" option from new project wizard Select File > New > JPA Project New JPA Project dialog appears
... ... Enter a name and click on next button twice JPA Facet page appears and verify Create Mapping File (orm.xml) checkbox does not appear for selection.
397391 NPE: 1-m/m-m switch joining strategy from JoinTable to JoinColumns or MappedBy Create JPA Project and JPA Entities with at least 2 or more attributes Project and entities with attarbutes are created successfully
... ... Select an attribute from an entity in the JPA Structure pane and then change the mapping to One-To-Many and expand Joining Stratagy in JPA Details pane Verify attribute is mapped as One-To-Many, Verify Joining Stratagy has Join Table radio button selected as default
... ... Click on Join Columns radio button Verify no NPE error appears in the Error Log
... ... Click back on Join Table radio button Verify no errors appear in the Error log
... ... Click on Mapped By radio button Verify JPA Details is updated and no errors appear in the Error Log
... ... Change the mapping from Ont-To-Many to Many-To-Many Verify mapping is changed successfully with no errors in Error Log
... ... Expand Joining Stratagy in JPA Details pane Verify Join Table is selected by default
... ... Select Mapped By radio button Verify JPA Details is updated and no errors appear in Error Log
... ... Select Join Table radio button Verify JPA Details is updated and no errors appear in Error Log
403131 Remove ORM XML generation code in JPA facet install delegate and data model Select New > JPA Project Verify New JPA Project dialog appears
... ... Enter a project name and click on Next button twice Verify Create mapping file (orm.xml) checkbox selection was removed from the JPA Facet page
... ... Finish the project Verify Project is finished and orm.xml does not appear for the project
... ... R-Click on the project and select JPA ORM mapping file Verify New Mapping File dialog appears and orm.xml is defaulted for file name and Next and Finish buttons are enabled
... ... Click on finish button Verify orm.xml mapping file is created and appears in editor
403387 [EclipseLink] Need EclipseLink 2.5 platform for JAXB 2.2 projects Select File > New > Other New dialog appears
... ... Select JAXB > JAXB Project, click on Next button Configure JAXB project settings page appears
... ... Enter a Project Name, selet 2.2 from the JAXB version drop down and click on Next button twice Verify EclipseLink 2.5.x appears in the Platform drop down
... ... Click on Finish button Verify JAXB 2.2 project is created successfuly
... ... Create a new JAXB 2.1 project Verify JAXB 2.1 project is created successfully
... ... R-Click on the JAXB 2.1 project Properties for JAXB2.1 dialog appears
... ... Select Project Facets, change JAXB from 2.1 to 2.2 Verify Further configuration required message appears
... ... Click on Further configuration required link Verify Modify Faceted Project dialog appears, and EclipseLink 2.5.x appears in the Platform drop down
... ... Select EclipseLink 2.5.x from Platform drop down and check correct library checkbox and click on OK twice Verify dialog closes and JAXB project is updated with EclipseLink 2.5 platform
403400 [entity gen] When generating entities and implementing Serializable an unused import warning is encountered Create JPA 2.0 Generic 2.0 project that has DB connection JPA project is created successfully
... ... R-click on JPA project, select JPA Tools > Generate Entities from Tables Generate Custom Entities dialog appears
... ... Select a few tables (Address, Employee, Phone), and Finish Verify entities are created
... ... Open an entity in the editor Verify java.io.Serializable interface is not fully qualified in the class def (Ex. public class Address implements Serializable)
... ... R-click on the JPA project and select New > JPA Entity New JPA Entity dialog appears
... ... Enter package name, class name, click on Next Entity Properties page appears
... ... Enter 2 or three fields and Finish the entity Verify java.io.Serializable interface is not fully qualified in the class def (Ex. public class Foo implements Serializable)
404673 Confusion exists with EclipseLink 2.4.x/2.5.x platform and EclipseLink 2.5 mapping file Create a JPA 2.0 project with EclipseLink 2.4.x/2.5.x platform and EclipseLink 2.5.0 library Project is created successfully without error
... ... R-click on the project and select New > EclipseLink ORM Mapping File New EclipseLink Mapping File dialog appears
... ... Click on the finish button Verify eclipselink-orm.xml is created successfully and opened in the editor and the version shows 2.4 on the Details tab (even though you selected EL 2.5 library it will default to 2.4 for JPA 2.0) and no errors appear in Problems tab
... ... Change version in Details tab from 2.4 to 2.5 and in source tab from 2.4 to 2.5 in both places and save the project Verify the following error appears in the Problems pane Mapping file eclipselink-orm.xml does not have supported content for this JPA Platform
405200 [API] new public query-related interfaces are misplaced Download latest build and open eclipse\plugins\org.eclipse.jpt.jpa.core .jar file Verify the following class files are in this .jar file JavaNamedStoredProcedureQuery2_1, JavaQueryContainer2_1, JavaStoredProcedureParameter2_1, OrmNamedStoredProcedureQuery2_1, OrmQueryContainer2_1, OrmStoredProcedureParameter2_1
406572 Remove jaxb binding schema from jaxb.core Download latest build and open eclipse\plugins\jst.standard.schema jar file Verify bindingschema xsd file appears
... ... Open eclipse\plugins\jaxbcore jar file Verify bindingschema xsd file does not appear in this file