Dali 3.3 M6 Release

From Eclipsepedia

Jump to: navigation, search

Dali 3.3

Dali 3.3 M6 Release Manual Testing

Manual Testing for 3.3 M6 Release
Bug No. Description Test Steps Test Step Results
392222 Remove "Create mapping file (orm.xml)" option from new project wizard Select File > New > JPA Project New JPA Project dialog appears
... ... Enter a project name and click on next button twice JPA Facet page appears and verify Create mapping file(orm.xml) checkbox does not exist
... ... Finish the project creation and then R-Click on the Project and select New > JPA ORM Mapping File Verify New Mapping File dialog appears.
393196 [JPA 2.1] new persistence.xml properties for ddl scripts Create a new JPA Generic 2.1 project Project is created successfully
... ... Open persistence.xml in editor Verify Schema Generation tab exists
... ... Click on Schema Generation tab Verify there are two sections - Schema Generation and Data Loading
... ... Look in the Schema Generation section and click on Database Action drop down Verify the following appear in the drop down: Default(None), Create, Drop, Drop and Create, None
... ... Click on Scripts generation drop down Verify the following appear in the drop down: Default(None), Create, Drop, Drop and Create, None
... ... Click on Metadata and script creation drop down Verify the following appear in the drop down: Metadata, Metadata then Script, Script, Script then Metadata
... ... Click on Metadata and script dropping drop down Verify the following appear in the drop down: Metadata, Metadata then Script, Script, Script then Metadata
... ... Check the database schema checkbox Verify the default is (False)
... ... Look at the remaining text fields in the Schema Generation section Verify the following text fields appear: Scripts create target:, Scripts drop target:, Database product name:, Database major version:, Database minor version:, Create script source:, Drop script source:, Connection
... ... Look in the Data Loading section Verify SQL load script source text field appear
... ... Update the project platform from Generic 2.1 to EL 2.5 platform Project is updated successfully
... ... Go back to persistence.xml editor on the Schema Generation Tab and click on the DDL generation type: drop down in the EclipseLink Schema Generation Verify the following items appear in the drop down: Default(None), Create Tables, Drop and Create Tables, None
... ... Click on the Output mode drop down Verify the following items appear in the drop down: Both, Database, Sql-script
... ... Click on the DDL generation location drop down Verify only Default(.) appears and Browse... button is enabled
... ... Click on Browse button Verify Generation Location dialog appears
... ... Select a location and click on OK button Verify the selected location appear in the DDL generation location
... ... Click on the Create DDL file name drop down Verify Default(createDDL.sql) appears in the drop down
... ... Click on Create drop DDL file name drop down Verify Default(dropDDL.sql) appears in the drop down
396880 jpt.doc is missing .qualifier? Download latest M6 build and expand the plugins directory Verify that org.eclipse.jpt.doc.user_3.2.0.jar now contains the version 4 qualifier and has the date on the end for example org.eclipse.jpt.doc.user_3.2.0.v201303120344.jar
397924 Synchronize Class List menu missing from persistence.xml node under JPA Content Create a new JPA 2.0 Generic 2.0 project JPA Project is created successfully
... ... Expand the JPA project, expand JPA Content and R-Click on persistence.xml Verify Open, a divider line and Open Diagram and Synchronize Class List appears in menu
... ... Expand the src, expand META-INF, R-Click on persistence.xml, and select JPA Tools Verify Synchronize Class List appears within JPA Tools and does not appear anywhere else in the list.
400841 update persistence_2_1.xsd and orm_2_1.xsd from namespace change Create a Generic 2.0 project JPA Project is created successfully
... ... R-Click on the project and Select Properties Verify Properties dialog appears
... ... R-Click on the project and add an orm.xml mapping file Verify mapping file is added successfully
... ... Select Project Facets and Update the JPA from 2.0 to 2.1 and Click on Further configuration link Modified Faceted Project dialog appears
... ... Select the Generic 2.1 platform and click on OK button, then Click on OK button for properties dialog and R-click on the orm.xml mapping file Verify Upgrade JPA Document Version appears
... ... Click on Upgrade JPA Document Version Verify orm.xml is updated to 2.1
... ... R-Click on the project and R-Click on the persistence.xml and select JPA Tools Verify Upgrade JPA Document Version appears
... ... Click on Upgrade JPA Document Version Verify persistence.xml is updated to 2.1
... ... R-Click on the orm.xml Verify that JPA Tools does not appear now since the Upgrade was already completed
... ... R-Click on the persistence.xml Verify that JPA Tools does not contain Upgrade JPA Document Version since it was completed
402697 Adding Java named stored procedure query failed if a name native query is defined ahead Create JPA Project and JPA Entity with two attributes JPA project and Entity are created successfully
... ... Select Add button in JPA Details for JPA Entityh Add Query dialog appears
... ... Enter a name and select Named Native Query and click on ok button Named Native Query is created successfully
... ... In the JPA Editor enter @NamedStoredProcedureQuery(name = "NSPQ", procedureName = "Testing") after the Named Native Query annotation and Save project Verify no errors appear in error log
402698 NullPointerException when opening metadata conversion wizard without valid mapping file existing in the project Create New JPA EclipseLink project with no xml mapping file Project is created successfully
... ... Create JPA entity with two or more attributes JPA Entity is created successfully
... ... Define some queries, converters and generators for the entity and save the project Queries, Converters and Generators are created successfully
... ... R-Click on the JPA project and select JPA Tools > Move to XML > Java Converters JPA Global Metadata Conversion dialog appears and verify no errors appear in the Error Log
... ... Click on Cancel JPA Global Metadata Conversion dialog closes and no errors appear in Error Log
... ... R-Click on the JPA project and select JPA Tools > Move to XML > Java Queries JPA Global Metadata Conversion dialog closes and no errors appear in the Error Log
... ... Click on Cancel JPA Global Metadata Conversion dialog closes and no errors appear in the Error Log
... ... R-Click on the JPA project and select JPA Tools > Move to XML > Java Generators JPA Global Metadata Conversion dialog closes and no errors appear in the Error Log