Jump to: navigation, search

Dali 3.3 M4 Release

Dali 3.3

Dali 3.3 M4 Release Manual Testing

Manual Testing for 3.3 M4 Release
Bug No. Description Test Steps Test Step Results
239011 Convert to JPA Project unavailable after cancel Create a Java project Java project is created successfully
... ... R-click on the Java project, Select Configure > Convert to JPA project Modify Faceted Project dialog appears
... ... Click on the cancel button Verify the project did not get converted and remains an unfaceted Java project (R-click on the project and verify Convert to JPA project... and Convert to Faceted Form... both still appear for Configure
... ... R-click on the Java Project, Select Configure > Convert to Faceted Form... Properties for java project dialog appears.
... ... Click on finish button Verify when you R-Click on the project Convert to JPA Project... appears for Configure
... ... Select Configure > Convert to JPA project Verify Modify Faceted Project dialog appears
... ... Click on the Cancel button Verify the project still remains faceted but did not get converted to JPA project
... ... R-click and select Configure > Convert to JPA Project..., click on Next button Verify JPA Facet page appears
... ... Select Platform and Library, and click on Finish button Verify project was converted to JPA and Convert to JPA Project... does not appear within Configure when you r-click
... ... Create just a General Project, R-Click on the created General Project Verify Convert to JPA project does not appear within Configure
315445 persistence.xml editor add/remove list layout issues Create JPA project with some entities JPA project and entities are created successfully
... ... Open persistence.xml in editor and select General Tab Verify entities appear in the Managed classes list to the right of the pane, Verify XML filed and Jar files lists appear on the left of the pane.
... ... Add about 20 entities to the project so that they all appear in the managed classes list in the persistence.xml general tab Verify that a scroll appears to the right of the managed classes list so you can scroll up and down to view all the classes
... ... Add about 6 different orm.xml files to the project so they appear in the XML Mapping files list in the persistence.xml general tab Verify that a scroll appears to the right of the XML Mapping files list so you can scroll up and down to view all the mapping files
... ... Add about 6 different .jar files to the project and then add them to the JAR files list in the persistence.xml general tab Verify that a scroll appears to the right of the JAR files list so you can scroll up and down to view all the jar files
... ... Click on the Customization tab and add about 6 classes to the Session Customizers list Verify that a scroll appears to the right of the Session Customizers list so you can scroll up and down to view all the classes
... ... Click on the Options tab and add about 6 classes to the Validate Pre-Persist group list Verify that a scroll appears to the right of the Validate Pre-Persist group list so you can scroll up and down to view all the classes
... ... Click on the Options tab and add about 6 classes to the Validate Pre-Update group list Verify that a scroll appears to the right of the Validate Pre-Update group list so you can scroll up and down to view all the classes
... ... Click on the Options tab and add about 6 classes to the Validate Pre-Remove group list Verify that a scroll appears to the right of the Validate Pre-Remove group list so you can scroll up and down to view all the classes
... ... Click on the Properties tab and add enough properties to the table list for the scroll to appear Verify that a scroll appears for the pane and you can scroll up and down to view all the properties in the table list
... ... Select one of the entites to view in the JPA Details pane, expand Queries section, Add about 6 queries to the list Verify that a scroll appears for the list and you can scroll up and down to view all the queries in the list
... ... Expand the Attribute Overrides section, and add about 6 attribute overrides via editor Verify that a scroll appears for the list and you can scroll up and down to view all the attribute overrides
... ... Expand the Secondary Tables section, add about 6 secondary tables to the list Verify that a scroll appears for the list and you can scroll up and down to view all the secondary tables in the list
316034 Interface listed in persistence.xml leads to "Class cannot be resolved" validation error Create JPA project JPA Project is created successfully
... ... R-Click on project, select New > Enum New Enum Type dialog appears
... ... Enter a Model and a Name 'FooEnum' and click on Finish button Enum is created successfully
... ... R-Click on the project, select New > Interface New Java Interface dialog appears
... ... Enter a Model and a Name 'FooInterface' and click on Finish button Interface is created successfully
... ... Open persistence.xml in the editor and go to the Source Tab and add the Enum into the source <class>model.FooEnum</class> Verify the following validation error appears in the problems pane 'Listed class "FooEnum" must not be an enum'
... ... Add the Interface into the source of the persistence.xml <class>model.FooInterface</class> Verify the following validation error appears in the problems pane 'Listed class "FooInterface" must not be an interface'
387630 Convert java plural queries or converters to xml and the plural annotation is left behind Create JPA project JPA project is created successfully
... ... Create a JPA entity just like in the bug Entity is created successfully
... ...
389934 Regression - Changing a Java attribute type such that the attribute should be unmapped does not work Create a JPA Project and the following JPA Entity
     @Entity
      public class Bar {

private int foo;

      }
Verify JPA Project and JPA Entity are created successfully
... ... Change the attribute type from int to int[] in the editor Verify that the JPA Details shows Attribute 'foo' is not mapped, click here to change the mapping type, Verify that JPA Structure pane shows an unmapped icon
... ... Change the attribute type from int[] to int in the editor Verify the JPA Details is updated to show Basic mapping and the JPA Structure is updated with the Basic mapping icon.
... ... Execute the test steps for Bug 362234 under the Dali 3.3 M2 release Verify those test steps pass
393086 [JPA 2.1] Add JPA 2.1 facet version and generic 2.1 platform Select File > New > JPA Project New JPA Project dialog appears
... ... Enter a test name, click on the JPA Version drop down Verify 2.1 appears in the drop down
... ... Select 2.1 from the JPA Version and click on the Next button twice Verify Generic 2.1 appears in the Platform drop down
... ... Select Generic 2.1, select EclipseLink 2.5.x library and click on the Finish button Verify project is created successfully
... ... R-Click on project, Select New > JPA ORM Mapping File New Mapping File dialog appears
... ... Click on the Finish button Verify orm.xml file is created successfully and opened in the editor and the entity-mappings version equals "2.1"
393090 Add new JPA platform for EclipseLink 2.5.x Select File > New > JPA Project New JPA Project dialog appears
... ... Enter a test name, select 2.0 for the JPA Version, click on Next button twice Verify EclipseLink 2.5.x does not appear in the Platform drop down
... ... Click on Back button twice, select 2.1 for JPA Version, click on Next button twice Verify EclipseLink 2.5.x appears in the Platform drop down
... ... Add the EclipseLink 2.5.x library and then select that library and click on Finish Verify project is created successfully
... ... R-Click on project, Select New > EclipseLink ORM Mapping File New EclipseLink Mapping File dialog appears
... ... Click on the Finish button Verify eclipselink-orm.xml file is created successfully and opened in the editor and the entity-mappings version equals "2.5"
393592 JPA commands are appearing in Quick Access when not appropriate Launch Eclipse Dali that has no project in the workspace, but JPA perspective is active, Type (Ctrl+3) Verify cursor appears in Quick Access
... ... Enter Upgrade Verify nothing appears
... ... Create JPA 1.0 Generic project and create an orm.xml mapping file Project and mapping file are created successfully
... ... Select persistence.xml, Enter Upgrade in Quick Access field Verify nothing appears
... ... Create JPA 2.0 EclipseLink project, copy the persistence.xml and the orm.xml file from the JPA 1.0 Generic project and copy them to the JPA 2.0 project. Select the orm.xml file, Enter Upgrade in Quick Access field Verify Upgrade to JPA Document Version and Upgrade to EclipseLink Mapping File appear.
... ... Select persistence.xml, enter Upgrade in Quick Access field Verify Upgrade to JPA Document Version appears.
... ... Keep persistence.xml still selected and Enter Java Queries in the Quick Access field Verify nothing appears
... ... Select the JPA 1.0 generic project and Enter Java Queries in Quick Access field Verify Move Java Queries to XML... appears
... ... Keep JPA 1.0 generic project selected and enter Java Generators in Quick Access field Verify Move Java Generators to XML... appears
... ... Keep JPA 1.0 generic project selected and enter Java Converters in Quick Access field Verify nothing appears
... ... Select JPA 2.0 EL project and enter Java Converters in Quick Access field Verify Move Java Converters to XML... appears
... ... Select any item within either JPA project and enter Dynamic entities from tables Verify Dynamic Entities from Tables and New (Dynamic Entities from Tables) appear
... ... Select any item/folder within either JPA project and enter EclipseLink Dynamic Entity Verify EclipseLink Dynamic entity and New (EclipseLink Dynamic Entity) appear