Jump to: navigation, search

Dali 3.0 M3

Dali QA Testing

Dali 3.0 M3 Manual Testing

Manual Testing for 3.0 M3 Release
Bug No. Description Test Steps Test Step Results
182849 Add multi-select to Java Class selection to make an Entity Create JPA project with Generic 2.0 Platform, Create a New Class for this project R-Click on the newly created class and verify Make Persistent is enabled for JPA Tools
... ... Select Make Persistent Make Persistent dialog appears with Annotate in Java radio button selected and the created class appearing in the list
... ... Click on the drop down for the Mapping Type for the Class. Verify the following Mapping types appear - Embeddable, Entity & Mapped Superclass
... ... Click on Cancel Dialog closes and you return to the project
... ... Create two more classes, Right click on the package and select JPA Tools > Make Persistent The Make Persistent dialog appears with the three classes appearing
... ... Select one of each mapping type for each of the classes, leave List in persistence.xml checkbox checked and click on the Finish button Verify each of the classes are now persistent and each one shows the selected type (embeddable, Entity, Mapped Superclass). Verify the 3 classes appear in the persistence.xml file.
... ... R-Click on the src folder and select JPA Tools > Make Persistent Verify the Make Persistent dialog appears with an error message showing All selected types are already persistent and no classes appear since they are already persistent.
... ... Click on Cancel for the Make Persistent dialog Dialog closes and you return to the project.
... ... Create a new class and then R-Click on the Class and select JPA Tools > Make Persistent Verify the Make Persistent dialog appears and the newly created class appears in the list.
... ... Click on Cancel Verify Make Persistent dialog closes and the class is not made persistent
... ... Create a new annotation within the same package, R-Click on the package and select JPA Tools > Make Persistent Verify the Make Persistent dialog appears with the annotation and class appearing in the list.
265087 Package-level annotations support ... ...
313750 Provide link to facets page on JPA properties page Create JPA 1.0 Generic project using all the defaults Project is created successfully
... ... R-Click on the project and select Properties, go to Java Persistence Verify Change JPA version link appears in the Platform selection area
... ... Click on the Change JPA version link Verify Properties dialog now shows the Project facets page
... ... Select 2.0 for the JPA version Verify Further configuration required link appears at the bottom
... ... Click on the Further configuration required link Verify Modify Faceted Project dialog appears
... ... Select Generic 2.0 from the project drop down, select EclipseLink 2.1.0 for the Library, Click on ok button, Click on Apply button, Select Java Persistence Verify the Platform shows Generic 2.0 for the selection.
... ... Click on OK button. Verify the project is upgraded from JPA 1.0 to JPA 2.0 successfully without error
320036 JAXB 2.2 Facet Select File>New>Other, Select JAXB>JAXB Project, Click on Next button New JAXB Project appears in Dialog Title
... ... Enter a Project Name and leave all other defaults, Click Next, Click Next again Verify JAXB Facet page appears
... ... Click on Platform drop down Verify only Generic JAXB 2.2 appears
... ... Click on the Finish button Verify the JAXB project is created successfully
... ... R-Click, select properties, Select Project Facets Verify 2.2 appears for the JAXB Project Facet
320041 New JAXB Project Wizard Select New>Other New dialog appears for selecting a wizard
... ... Select JAXB>JAXB Project and Click on Next New JAXB Dialog appears for creating a JAXB Project
... ... Click on Next two times JAXB Facet page appears
... ... Click on Download Library icon Download Library dialog appears and verify you can download any and all needed libraries
... ... Download the library, Check the library and click on Finish Verify the JAXB project is created successfully
320392 Remove descriptor customizer UI from EclipseLink persistence.xml editor Create a JPA Project with EL 2.1 platform Project is created successfully
... ... Open the persistence.xml editor and click on the Customization Tab Verify Descriptor customizers section does not appear in the UI
... ... Go to the Source tab and enter the following in the Source between the persistence-unit xml - <properties><property name="eclipselink.descriptor.customizer.Foo" value="com.sun.xml.internal.bind.v2.schemagen.FoolProofResolver"/></properties> Save the project. Verify the following warning validation appears - "eclipselink.descriptor.customizer.Foo" is a legacy descriptor customizer property. Consider migration to the EclipseLink customizer setting via annotation or XML maping file.
323491 Remove New JPA EE Project in favor of one JPA Project Wizard Select File > New > Other New Dialog appears
... ... Expand JPA Verify only 1 JPA Project appears and no JPA EE Project appears.
... ... Select JPA Project and click on Next button, Click on the Configuration drop down Verify the you can create a JPA Project or JPA EE Project. Verify EAR membership and Work Sets sections appear on the JPA Configuration page and are unchecked.
... ... Click on the Configuration drop down Verify the following items appear: custom, Default Configuration, JavaServer Faces v1.1 Project, JavaServer Faces v1.2 Project, JavaServer Faces v2.0 Project, Minimal Configuration
... ... Create JPA EE Project, Enter a name, Check Add project to EAR checkbox, Check Add project to working set checkbox, Click on Next button 2 times, Select a library and click on Finish button. JPA EE Project is created successfully
... ... Create a JPA Project, Enter a name, Select a configuration, click on Next 2 times, Select a library and click on the Finish button. JPA Project is created successfully.
324955 Generate JAXB Classes - Dialog does not contain Title Create JPA Project, R-click on the project and add a file (anything .xsd) Project and file are created successfully
... ... R-Click on the added .xsd file, Select Generate>JAXB Classes Verify dialog appears with the following Title - New JAXB Classes from schema
326691 Add new JAXB components to WTP build Download the latest wtp build and go to the eclipse>plugins directory Verify the following .jar files exist - org.eclipse.jpt.jaxb.core.schmeagen.source_(build).jar, org.eclipse.jpt.jaxb.core.schemagan_(build).jar, org.eclipse.jpt.jaxb.core.source_(build).jar, org.eclipse.jpt.jsxb.core_(build).jar
... ... Go to the eclipse>features directory Verify the following files exist - org.eclipse.jpt.jaxb.feature.source_(build), org.eclipse.jpt.jaxb.eclipselink_sdk.feature_(build), org.eclipse.jpt.jaxb.feature_(build), org.eclipse.jpt.jaxb_sdk.feature_(build), org.eclipse.jpt.jaxb_eclipselink.feature(build), org.eclipse.jpt.jaxb.eclipselink.feature.source(build)
326705 Resource model for core JAXB annotations ... ...
326960 Remove temporary library provider fixes Select New > JPA project, Select custom from Configuration drop down, but do not make changes, and click on Next button twice Verify the Include libraries with this application checkbox is disabled
... ... Click back twice, Click on Modify button, Check the EJB Module facet Click OK, and click on the Next button twice Verify the Include libraries with this application checkbox is enabled and checked
... ... Click back twice, Select default configuration from Configuration drop down and click on Next button twice Verify the Include libraries with this application checkbox is disabled
... ... Click back twice, Select JavaServer Faces v1.2 Project from Configuration drop down and click on Next button twice Verify the Include libraries with this application checkbox is enabled and checked
... ... Click back twice, Select JavaServer Faces v2.0 Project from Configuration drop down and click on Next button twice Verify the Include libraries with this application checkbox is enabled and checked
... ... Click back twice, Select Minimal Configurationfrom Configuration drop down and click on Next button twice Verify the Include libraries with this application checkbox is disabled
326972 Add ability to create an ORM mapping file from the 'Make Persistent' and 'New JPA Entity' wizards Create JPA project using Oracle 11 db and create 3 non-persistent classes Project and classes are created successfully
... ... R-Click on package and select JPA Tools > Make Persistent Make Persistent dialog appears
... ... Select Add to XML mapping file radio button Verify mapping file link is enabled
... ... Click on mapping file link New Mapping File dialog appears with orm.xml listed for the File Name
... ... Click on the finish button. The orm.xml file is created and the Finish button is enabled for the Make Persistent dialog.
... ... Click on the Finish button for the Make Persistent dialog. Verify orm.xml is created and the class(es) appear in the file.
... ... Select File > New > JPA Entity New JPA Dialog appears
... ... Select a package, Enter a Class Name (Test), Check the Add to entity mappings in XML checkbox Verify the Browse button is enabled
... ... Click on the Browse button Verify Mapping File dialog appears with a New button
... ... Click on the New button Verify New Mapping File dialog appears.
327151 Schema gen doesn't handle multiple namespaces/packages/schemas Download project from bug Import the existing project into Eclipse workspace
... ... Open the imported project and expand the src folder Verify two packages exist - example.address & example.customer
... ... Select File New>Other>JAXB>Schema from Classes and click on Next button JAXB Schema File page appears and CustomerFromJava project appears
... ... Select CustomerFromJava project, leave the File Name default, click on Next Verify the two packages appear for the Classes
... ... Select both the packages by checking the checkboxes and Click on Finish Verify 2 .xsd schema files appear - example.address.xsd & example.customer.xsd
... ... Delete the .xsd files just created, Remove the namespace for the two packages (bring up package-info.java in the editor and remove the namespace so it appears as namespace = ""), Save the project, Create the Schema from Classes again. Verify the .xsd file is created for the classes and all information exists for both packages
327609 Refactor provisional API o.e.jpt.core.utility.jdt.Member hierarchy to include AnnotatedElement ... ...
327903 Generic JAXB 2.2 platform Launch Eclipse, Select New > Other > JAXB > JAXB Project, Click on Next button New JAXB Project Wizard appears
... ... Enter a name, leave all other defaults, click Next twice Verify Generic JAXB 2.2 appears for the Platform drop down.
... ... Create a JPA project using all defaults, then R-click on the project and select Properties Properties dialog appears
... ... Click on Project Facets, Check the JAXB checkbox, Click on the Further Configuration Required.. Link Verify Modify Faceted Project dialog apepars and Generic JAXB 2.2 appears in the Platform drop down.
327912 Resource model support for JAXB 2.2. package annotations Create a New JAXB Project using all the defaults JAVB Project is created successfully
... ... Create a New Package (jaxb_example_package) Package is created successfully under the src folder
... ... Select New>File, select the newly created package, enter package-info.java for the File name and click on Finish package-info.java file is created successfully with an error stating - The declared package " does not match the expected package
... ... Go to the package-info.java editor and enter - package jaxb_example_package; then save the project Verify the error is removed for the JAXB Project
... ... Enter
327914 Resource model support for JAXB 2.2. type annotations and enums ... ...
327915 Resource model support for JAXB 2.2. field/method annotations ... ...
328509 Add EclipseLink 2.2 platform Select New>JPA Project New JPA Project wizard dialog appears
... ... Enter project name (EL22Project", leave all defaults and click on next button twice Verify EclipseLink 2.2.x version appears is the Platform drop down list
... ... Select EclipseLink 2.2.x, Select a valid Library (ex. EclipseLink 2.1.0-Helios), Click on finish button Verify project is created successfully
... ... R-Click on the EL22Project, Select New > EclipseLink ORM Mapping File New EclipseLink Mapping File dialog appears
... ... Leave all the defaults and click on finish button Verify on the design tab 2.2 appears for the version and on the source tab eclipselink_orm_2_2.xsd appears.
328905 ExceptionInInitializerError when loading JptJsxbCorePlugin Create JPA project using Oracle 11 db and create 3 classes Project and classes are created successfully
... ... Select New > Other > JAXB > Schema from JAXB Classes JAXB Schema File page appears with NewXMLSchema.xml for the File Name
... ... Click on the Next button JPA Project appears in the select classes to include in schema
... ... Check the JPA checkbox Verify all other checkboxes under this are checked by default
... ... Click on Finish button Verify NewXMLSchema.xml file is created successfully