Jump to: navigation, search

Dali 3.0 M1

Dali 3.0

Dali 3.0 M1 Manual Testing

Manual Testing for 3.0 M1 Release
Bug No. Description Test Steps Test Step Results
149451 Create persistence.xml in good location Create a Java Project (using all defaults) Java Project is created successfully
... ... Select the Java Project, go to the Properties, Select Project Facets, Check the JPA checkbox Warning at bottom of dialog appears with Further configuration available
... ... Click on the Further configuration required available Modify Faceted Project dialog appears
... ... Select a library, leave other defaults, click on OK, click on OK on Properties dialog Verify persistence.xml appears under project_name\src\META-INF directory structure
209489 Participate in Java type level refactoring Create a JPA Project, Create JPA Entity, Add Entity to managed class in persistence.xml Entity is created and appears in persistence.xml source
... ... R-Click on Entity in Project Explorer and select Refactor>Rename Rename Compilation Unit dialog appears, with check mark in Update references checkbox by default
... ... Change the name and click on Next button Changes to be performed page appears, click on the items in the list and verify the preview is correct when available
... ... If preview is correct click on the Finish button Verify entity is renamed and persistence.xml source is updated correctly
... ... Create a new package (ex. test_move) New package is created
... ... R-Click on Entity in Project Explorer and Select Refactor>Move Move dialog appears with current package it resides in is highlighted
... ... Select the newly created package (ex. test_move) and click on the Preview button Changes to be performed page appears, click on the items in the list and verify the preview is correct when available
... ... Click on OK button Verify the entity was moved to the selected package and the perisistence.xml source was updated
... ... R-Click on Entity in Project Explorer and Select Delete Confirm Delete dialog appears.
... ... Click on the Preview button Changes to be performed page appears, click on the items in the list and verify the preview is correct when available
... ... Click on OK button Verify the entity is removed from the package and the persistence.xml source was updated
... ... R-Click on package and create a New JPA Entity, Add Entity to managed class in persistence.xml Entity is created and appears in persistence.xml source
... ... R-Click on package that contains entity, Select Refactor>Rename Rename package dialog appears
... ... Change the name and click on the Next Preview button Changes to be performed page appears, click on the items in the list and verify the preview is correct when available
... ... Click on OK button Verify the package name was updated and the persistence.xml source was updated
... ... R-Click on the renamed package, Select Refactor>Move
... ...
209820 Persistence.xml not recognized in non-src directory ... ...
234383 Remove dependence on Utility Module facet ... ...
294670 More helpful UI for validation group persistence.xml properties Create JPA Project using all the defaults Project is created successfully
... ... Open the persistence.xml editor and select the Options Tab Verify Validate per-persist, pre-update & pre-remove group all have Add/Remove options
... ... Click on Add for Validate pre-persist group, Select a class (org.omg.CORBA.PERSIST_STORE) Verify it appears in the list box for Validate pre-persist group
... ... Click on the Source Tab Verify the property appears <property name="javax.persistence.validation.group.pre-persist" value="org.omg.CORBA.PERSIST_STORE"/>
... ... Add the following the the value in the source <...value="org.omg.CORBA.PERSIST_STORE,javax.swing.border.AbstractBorder"/> Then go back to the options tab Verify javax.swing.border.AbstractBorder appears in the list for Validate pre-persist group
... ... Add two more classes to the list Verify they appear in the list for Validate pre-persist group as well as in the Source for the property
... ... Go back to the options Tab, Select org.omg.CORBA.PERSIST_STORE and click on Remove button Verify it is removed from the Validate pre-persist group list and from the source tab.
... ... Repeat the steps for the Validate pre-update group Verify the results for the Validate pre-update group are the same as the pre-persist group
... ... Repeat the steps for the Validate pre-remove group Verify the results for the Validate pre-remove group are the same as the pre-persist group
310854 Remove eclipselink default caching properties if shared-cache-mode set to None Create JPA Project using all the defaults Project is created successfully
... ... Open persistence.xml editor, Click on the Caching Tab and select shared cache mode drop down Verify the following items appear: Default(Disable Selective), All, None, Enable Selective, Disable Selective, Unspecified
... ... Select All for Shared cache mode, Select Full for Default cache type, Enter 200 for Default cache size, select Drop for Flush clear cache; Click on Source tab Verify the following appear in the Source - <shared-cache-mode>ALL</shared-cache-mode> <property name="eclipselink.cache.size.default" value="200"/> <property name="eclipselink.cache.type.default" value="Full"/> <property name="eclipselink.flush-clear.cache" value="Drop"/>
... ... Remove the <property name="eclipselink.flush-clear.cache" value="Drop"/> from the source Verify Flush clear cache returned to Default(Drop Invalidate) on the Caching Tab
... ... Go back to the Source Tab and change All to None for the shared-cache-mode Verify the property values for size and type still appear in the source tab, however verify the size, type & flush clear options are grayed out (disabled) in the Caching tab.
... ... Select Enable Selective from the shared cache mode drop down. Verify the other fields are now enabled and show: Full, 200 & Default(Drop Invalidate). Also verify that the source tab shows <shared-cache-mode>ENABLE_SELECTIVE</shared-cache-mode>
... ... Change 200 to 500 for the cache size value on the source tab, change Full to Weak for the cache type on the source tab & change ENABLE_SELECTIVE to UNSPECIFIED for the shared-cache-mode Verify the Caching tab shows the fields were updated to the updated values
... ... Select None for the Shared cache mode on the Caching tab Verify the other fields are grayed out (disabled) and that they were removed from the source since you selected none on the Caching tab.
... ... Add <properties><property name="eclipselink.cache.size.default" value="600"/></properties> to the Source in the properties section. Save project. Verify the cache size is updated to 600 in the caching tab but still remains grayed out (disabled) on the Caching tab and a warning appears stating Property will be ignored as shared cache mode is set to None
... ... Change NONE to ALL for shared-cache-mode in the Source. Save project Verify the cache.size remains on the source tab and Verify the caching tab has all the fields enabled.
310866 JAXB Class Gen wizard: Bindings file chooser dialog should allow multi-select Create JPA Project using default (Verify you have the JAXB_Library selected for the project), Add File (ox-employee.xsd) to project, R-click on .xsd file and Select Generate JAXB Classes JAXB Class Generation dialog appears
... ... Click on Add button for bindings files External Bindings File Selection dialog appears
... ... Browse to location where .xml files exist, Select 3 files Verify you can select more than one file and all 3 files appear in the File Name field and the Open button is enabled.
... ... Click on the open button Verify the 3 selected files appear in the Bindings files list
... ... Select one file and click on the remove button. Verify the selected file is removed
... ... Repeat for .xjb and .xbd files Verify you can select more then one .xjb and/or .xbd files and they appear in the bindings files list.
310893 JAXB Class Gen wizard: Add warning that files will be overwritten Create JPA Project using default, Add File (ox-employee.xsd) to project, R-click on .xsd file and Select Generate JAXB Classes JAXB Class Generation dialog appears
... ... Click on Add button for bindings files External Bindings File Selection dialog appears
... ... Browse to location where .xml files exist, Select a .xml file and click on Open Verify the selected file appears in the Bindings Files list.
... ... Click on the Next button. The Classes Generator Options page appears in the JAXB Class Generation dialog, with No Proxy radio button selected by default and Use strict validation is the only check box checked by default.
... ... Leave defaults and click on the Next button. Classes Generator Extension Configuration page appears with everything blank by default
... ... Click on the finish button Verify Generating JAXB Classes Warning dialog appears stating: Warning: Generating classes will overwrite existing files in your project. Are you sure you want to continue?
312510 JAXB Schema Generation Wizard does not populate if you change the project Create two or more JPA Projects using the defaults, do not select either of the created JPA project, Select File>New>Other New dialog appears
... ... Select JAXB>Schema from JAXB Classes, Click on the Next button JAXB Schema Generation - Java Project Selection page apperas
... ... Select one of the created projects from the drop down list and click on the next button Generate Schema from Classes page appears with the project name.xsd appearing in the Schema file text field.
... ... Click on the Browse button and browse to an xsd file that contains classes, click on Open button Verify the file appears in the list to the left with checkboxes
... ... Select some files, click on the Back button, select the other project and click on the Next button Verify the Generate Schema from Classes - Schema file and list boxes are not blank
315814 JAXB Class Generation Wizard: bindings files support for XBD and XML File extensions Create JPA Project using default, Add File (ox-employee.xsd) to project, R-click on .xsd file and Select Generate JAXB Classes JAXB Class Generation dialog appears
... ... Click on Add button for bindings files External Bindings File Selection dialog appears. Verify .xbd appears with .xjb and .xml for the Files of Type
... ... Browse to location where .xbd files exist Verify all available .xbd files appear for selection.
... ... Select .xbd file and click on Open Verify the selected .xbd file appears in the Bindings Files list.
316342 JAXB Class Gen Wizard - Add checkboxes Create JPA Project using default, Add File (ox-employee.xsd) to project, R-click on .xsd file and Select Generate JAXB Classes JAXB Class Generation dialog appears
... ... Click on the Add button for Bindings files, Select a .xml file (xmlconfig.xml) and Open Verify the selected .xml file appears in the Bindings files list.
... ... Click on the Next button Verify the following options appear: Proxy radio button group (No proxy, Proxy, Proxy file); The following checkboxes: Use Strict validation, Generate read-only files, Suppress package-info generation, Suppress generation of file header, Target XJC 2.0, Verbose, Suppress compiler output, Treat input as XML schema, Treat input as RELAX NG, Treat input as RELAX NG compact syntax, Treat input as XML DTD, Treat input as WSDL and compile schema inside it, Show version, Show help
... ... Check Show Version checkbox and click on Next button & then Finish button Generating JAXB Classes dialog appears asking Are you sure you want to continue?
... ... Click on Yes button. How can I verify it was created successfully
317900 Provide extension point for locating non-java resources ... ...
318028 Participate in mapping file refactoring ... ...
[| 319726] Support persistence.xml in other locations other then Java source folder ... ...
319726 Support persistence.xml in other locations than Java Source folder ... ...
320509 Change PersistenceUnit.addSpecifiedClassRef to take a string name Create JPA Project using defaults, with DB conection, add some entities added via DB Tables, add an orm mapping file, and add .jar file to the project Project is created successfully
... ... Go to the persistence.xml editor and add the mapping file via the General Tab Verify the persistence.xml source is updated correctly
... ... Go to the persistence.xml editor and add the .jar file via the General Tab Verify the persistence.xml source is updated correctly.
322419 NPE creating new orm.xml mapping file Do not select any project, click on the New drop down menu arrow, Select JPA ORM mapping File Verify New Mapping File dialog appears with no errors
... ... Cancel the dialog, select a project, click on the New drop down menu arrow, Select JPA ORM Mapping File Verify New Mapping File dialog appears with no errors
... ... Cancel the dialog, repeat selecting JPA ORM Mapping File using other methods of selection (ex. File>New>JPA ORM Mapping File, File>New>Other>JPA>JPA ORM Mapping File) Verify New Mapping File dialog appears with no error
... ... Repeat the above steps however this time create the orm.xml mapping file Verify the mapping file is created successfully.
322442 Validation not occuring on Save Create a project with some classes Project is created successfully
... ... Open up a .java class file editor and change something that will cause an error, Save Verify the Problems Tab is updated with the error/warning
... ... Fix the .java class file and Save Verify the error/warning is removed in the Problems Tab
... ... Open the persistence.xml file editor and change something that will cause an error, Save. Verify the Problems Tab is updated with the error/warning
... ... Fix the .xml file and Save Verify the error/warning is removed in the Problems Tab