ATF/BuildingJSDT

From Eclipsepedia

< ATF
Jump to: navigation, search

JSDT is moving into WTP 3.0. The latest version of JSDT is not longer compatible with WTP 2.0. The following JSDT plugins are no longer compatible with WTP 2.0:

  • org.eclipse.wst.jsdt.web.support.jsp
  • org.eclipse.wst.jsdt.web.ui

The following changes are needed to keep compatibility with WTP 2.0 for ATF in the short term:

in plugin: org.eclipse.wst.jsdt.web.support.jsp

  • The plugin org.eclipse.wst.jsdt.web.support.jsp is no longer used in WTP 3.0. the plugins have been reverted back to run against WTP 2.0.


in plugin: org.eclipse.wst.jsdt.web.ui

  • The changes in org.eclipse.wst.jsdt.web.ui that were removed/changed have ben moved into org.eclipse.atf.compatibility.jsdt.

The original plan was to use a previous version of for the plugin.xml file. This is no longer possible because of class renaming done in JSDT. Specific additional plugin.xml markup needed by ATF that has been moved to the plugin.xml of org.eclipse.atf.compatibility.jsdt can be found by making a diff between version 1.3 and 1.4 of that file.


  • There is one outstanding issue is that the plugins.xml in org.eclipse.wst.jsdt.web.ui has one element that doesn't exist in WTP 2.0. The manifest compiler has been set to ignore the error on the build.

As I remember this was used in the previous release because of a number of undefined extension points in earlier versions of JSDT.

Map file tags and plugins that are used.

  • The code in ATF for JSDT has been updated to build against the M5 version of JSDT. The following tags should be in the map file (copied from the JSDT map file)
    • plugin@org.eclipse.wst.jsdt.doc=v200802062329
    • plugin@org.eclipse.wst.jsdt.core=v200802132239
    • plugin@org.eclipse.wst.jsdt.manipulation=v200712072133
    • plugin@org.eclipse.wst.jsdt.support.firefox=v200802062329
    • plugin@org.eclipse.wst.jsdt.support.ie=v200802062329
    • plugin@org.eclipse.wst.jsdt.ui=v200802132239
    • plugin@org.eclipse.wst.jsdt.web.core=v200802062329
    • plugin@org.eclipse.wst.jsdt.web.support.jsp=v200712171755
    • plugin@org.eclipse.wst.jsdt.web.ui=v200802062329
    • feature@org.eclipse.wst.jsdt.feature=v200712072133
  • There is two plugins and two features used by ATF which are not in the JSDT mapfile and have been taged with the following tags.
    • feature@org.eclipse.wst.jsdt.jsp.feature=v200802132239
    • feature@org.eclipse.wst.jsdt.web.feature=v200802132239
    • plugin@org.eclipse.wst.jsdt.atfdebug=v200802132239
    • plugin@org.eclipse.wst.jsdt.web.support.jsp=v200802132239

The ATF map has been updated accordingly