Skip to main content
Jump to: navigation, search

VIATRA/Releases/MigrationTo0.8

VIATRA 0.8 is backwards compatible with VIATRA 0.7 - every transformation written in the previous version should work without any changes after upgrade.

Known installation issue

If the VIATRA update site does not display the newly released version, it is possible that Oomph cached the previous site (see similar bug 470900 for the Mars repository. The solution is to clear to Oomph caches found in ~/.eclipse/org.eclipse.oomph.p2/ ; specifically, look for files that have viatra in their name and remove them.

Incorrect Maven dependency plug-in

The viatra-emf-runtime Maven dependency incorrectly refers to emf-incquery 1.1.0-snapshots, making it unusable. For a workaround, this dependency has to be overridden, see https://gist.github.com/ujhelyiz/3c6061d6e553981cd0c5

Copyright © Eclipse Foundation, Inc. All Rights Reserved.