Skip to main content
Jump to: navigation, search

Difference between revisions of "Talk:CBI/aggregator/manual"

(Question on "cli" naming while refactoring)
Line 16: Line 16:
 
::- re "works?": yes
 
::- re "works?": yes
 
::- re wiki: change done.
 
::- re wiki: change done.
 +
 +
::- [dw]
 +
::- Thanks for checking and changing wiki.
 +
::- FWIW, I am doing a large refactoring now, to change to the cbi namespace ({{bug|506726}})
 +
::- If you think it is a good idea, I could change org.eclipse.b3.product to org.eclipse.cbi.p2repo.cli.product instead of org.eclipse.cbi.p2repo.product (That is, add the "cli" back in)
 +
::- Comment here, or in bug {{bug|506726}}. Thanks,

Revision as of 16:21, 16 November 2016

Headless installation

From the manual:

  • "-i org.eclipse.b3.cli.product is the name of the headless CBI Aggregator"

This didn't work for me. Looking into recent children of http://download.eclipse.org/cbi/updates/aggregator/headless/4.5/ I only see org.eclipse.b3.product (without "cli"). Is that the product that should be installed also for cli usage?

- [dw] Yes, org.eclipse.b3.product is the name of the "product". I am not sure what you mean by "cli usage", but I run the headless version using the (newly named) executable with
 ${product_dir}/cbiAggr aggregate --action VALIDATE --logLevel DEBUG --buildModel org.eclipse.simrel.build/simrel.b3aggr 2>&1 | tee -a ${test_ouput}
- Does that work for you? Or did you mean something else?
- If works for you I will update the wiki (or, you are welcome to).
- This was just an overlooked naming on my conversion to Tycho/Maven build.
- [stephan]
- re "cli usage": I just wan't to double check, that this is not an IDE product (e.g., for the aggregation editor)
- re "works?": yes
- re wiki: change done.
- [dw]
- Thanks for checking and changing wiki.
- FWIW, I am doing a large refactoring now, to change to the cbi namespace (bug 506726)
- If you think it is a good idea, I could change org.eclipse.b3.product to org.eclipse.cbi.p2repo.cli.product instead of org.eclipse.cbi.p2repo.product (That is, add the "cli" back in)
- Comment here, or in bug bug 506726. Thanks,

Back to the top