Skip to main content
Jump to: navigation, search

Sirius/4.0.1

< Sirius
Revision as of 10:57, 6 September 2016 by Pierre-charles.david.obeo.fr (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Sirius 4.0.1 is a maintenance release containing only bugfixes.

Availability

Sirius 4.0.1 was released on 2016-09-06 (tag v4.0.1, commit b72fdf6376e1e3970b1b95106ae68aeabf06a964). It is available from the following update sites:

It is recommended you use the update-site matching the version of Eclipse you use to avoid potential issues at runtime.

The complete JUnit and SWTBot test suites used to validate Sirius are published along with all their dependencies in separate update-sites from the core, available at:

If you want to install the org.eclipse.sirius.tests.support feature, which provides APIs to help create automated tests of Sirius-based modelers, you will need to add the following update-site:

Compatibility

Sirius 4.0.1 is compatible with the following versions of Eclipse:

  • Eclipse 4.5 (Mars)
  • Eclipse 4.6 (Neon)

Eclipse 4.6 (Neon) is the reference platform.

New & Noteworthy

The complete list of (13) tickets fixed in Sirius 4.0.1 can be found here on the Bugzilla.

The release notes with highlights for the corresponding major version can be found here, with more details in the release notes.

Back to the top