Skip to main content
Jump to: navigation, search

Sirius/2.0.0

< Sirius
Revision as of 09:55, 23 September 2014 by Pierre-charles.david.obeo.fr (Talk | contribs) (Compatibility)

THIS IS A DRAFT. Sirius 2.0.0 is not released yet.

Sirius 2.0.0 is a major release which focuses on better usability of diagrams, performance improvements, and better modularity. It also includes extensive automated test suites.

See also [TBD the announce on the mailing list].

Availability

Sirius 2.0.0 was released on 2014-10-24 (tag v2.0.0, commit TBD). It is available from the following update sites:

It is recommended you use the update-site matching the version of Eclipse you use to avoid potential issues at runtime.

If you want to install the new org.eclipse.sirius.tests feature, which provides APIs to help create automated tests of Sirius-based modelers, you will need to add the following update-site:

Juno users: Sirius depends on more recent versions of some components that what is available by default from a Juno install. You need to add the following update-sites if you want to install Sirius 1.0.0M7 on Juno:

Compatibility

Sirius 2.0.0 is compatible with the following versions of Eclipse:

  • Eclipse 3.8/4.2 (Juno)
  • Eclipse 4.3 (Kepler)
  • Eclipse 4.4 (Luna)

New & Noteworthy

TBD

Known Issues

The following important issues are present in the 2.0.0 release. They were identified after the code freeze and could not be fixed in time. If possible (i.e. no API break needed), they will be fixed in 2.0.x maintenance releases.

TBD

Back to the top