Skip to main content
Jump to: navigation, search

Recommenders/Attic/Release/ThirdPartyDependencies


Name Version Location IP Check Required for Release Notes
ch.qos.logback.*
Orbit PB needed
X
com.google.gson
1.6.0
3rd-git
CQ???
X
Used for (de-)serialization in JSON format; We should upgrade to 2.0 for performance reasons.
com.google.guava
10.0.1
3rd-git
PB needed; CQ5804
X
Common utils & EventBus
com.google.inject
3.0.0
3rd-git
CQ5058
X
Dependency Injection Framework
com.google.inject.assistedinject
3.0.0
3rd-git
CQ5059
X
Support for assisted injection
com.google.inject.multibindings
3.0.0
3rd-git
CQ5060
X

com.google.protobuf
Orbit


com.ibm.wala.core
1.3.1
3rd-git
CQ???
Used for static analysis; Update to 1.3.2 is planned
com.ibm.wala.shrike
1.3.1
3rd-git
CQ???
Used for static analysis; Update to 1.3.2 is planned
com.ibm.wala.util
1.3.1
3rd-git
CQ???

Used for static analysis; Update to 1.3.2 is planned
com.sun.jersey.client
1.6.0
3rd-git
PB5511 (CQ5509)
X

com.sun.jersey.core
1.8.0
3rd-git
PB5511 (CQ5509)
X
com.sun.jersey.server
1.8.0
3rd-git
PB5512 (CQ5221)

javax.activation
Orbit


javax.annotation
Orbit


javax.annotations.jsr305

3rd-git
None
X
Required by com.google.guava
javax.ejb
3.1.0
3rd-git
None

Required by com.sun.jersey.server
javax.inject
Orbit
X Required by com.google.inject
javax.transaction
Orbit


javax.xml.rpc
Orbit


javax.xml.soap
Orbit


javax.enterprise.jsr299
1.0.0
3rd-git
None

Required by com.sun.jersey.server
javax.servlet
3.0.1
3rd-git
None

Should be removed; Orbit contains 3.0.0
net.sf.cglib
2.2.0
3rd-git
None
X
Required by com.google.inject
org.aopalliance
Orbit


org.apache.ant
Orbit


org.apache.commons.cli
Orbit


org.apache.commons.collections
Orbit


org.apache.commons.io
Orbit


org.apache.commons.lang
Orbit


org.apache.commons.lang3
3.0.0
3rd-git
None
X
Common utils
org.apache.commons.logging
Orbit


org.apache.commons.math
2.1.0
3rd-git
None
X
Should be removed; Orbit contains 2.1.0
org.apache.commons.pool
Orbit


org.apache.commons.primitives
1.0.0
3rd-git
CQ4761
X
Common utils
org.apache.log4j
Orbit


org.apache.lucene
3.0.1
3rd-git
None

Update to 3.5 planned
org.kohsuke.args4j
Orbit


org.objectweb.asm
Orbit


org.sl4fj.*
Orbit


org.mockito
1.8.5
3rd-git
None

Should be removed; Orbit contains 1.8.4

Back to the top