Skip to main content
Jump to: navigation, search

Difference between revisions of "Recommenders/Attic/Release/ThirdPartyDependencies"

m (Removing all content from page)
 
(36 intermediate revisions by 3 users not shown)
Line 1: Line 1:
= <br> Direct Dependencies  =
 
  
{| width="100%" cellspacing="1" cellpadding="1" border="0" align="left"
 
|-
 
| '''Name'''
 
| '''Version'''
 
| '''Location'''
 
| '''IP Check'''
 
| '''Required for Release'''
 
| '''Notes'''
 
|-
 
| ch.qos.logback.*
 
| <br>
 
| Orbit
 
| PB needed<br>
 
| X
 
| <br>
 
|-
 
| com.google.gson<br>
 
| 1.6.0<br>
 
| 3rd-git<br>
 
| PB4753 (CQ4730)<br>
 
| X<br>
 
| Used for (de-)serialization in JSON format; We should upgrade to 2.0 for performance reasons.<br>
 
|-
 
| com.google.guava<br>
 
| 10.0.1<br>
 
| 3rd-git<br>
 
| PB needed; CQ5804<br>
 
| X<br>
 
| Common utils &amp; EventBus<br>
 
|-
 
| com.google.inject<br>
 
| 3.0.0<br>
 
| 3rd-git<br>
 
| CQ5058<br>
 
| X<br>
 
| Dependency Injection Framework<br>
 
|-
 
| com.google.inject.assistedinject<br>
 
| 3.0.0<br>
 
| 3rd-git<br>
 
| CQ5059<br>
 
| X<br>
 
| Support for assisted injection<br>
 
|-
 
| com.google.inject.multibindings<br>
 
| 3.0.0<br>
 
| 3rd-git<br>
 
| CQ5060<br>
 
| X<br>
 
| <br>
 
|-
 
| com.ibm.wala.core<br>
 
| 1.3.1<br>
 
| 3rd-git<br>
 
| CQ4757
 
| <br>
 
| Used for static analysis; Update to 1.3.2 is planned<br>
 
|-
 
| com.ibm.wala.shrike<br>
 
| 1.3.1<br>
 
| 3rd-git<br>
 
| CQ4758
 
| <br>
 
| Used for static analysis; Update to 1.3.2 is planned<br>
 
|-
 
| com.sun.jersey.client<br>
 
| 1.8.0<br>
 
| 3rd-git<br>
 
| PB5511 (CQ5509) <br>
 
| X<br>
 
| <br>
 
|-
 
| com.sun.jersey.core<br>
 
| 1.8.0<br>
 
| 3rd-git<br>
 
| PB5511 (CQ5509)<br>
 
| X<br>
 
| <br>
 
|-
 
| com.sun.jersey.server<br>
 
| 1.8.0<br>
 
| 3rd-git<br>
 
| PB5512 (CQ5221)<br>
 
| <br>
 
| <br>
 
|-
 
| org.apache.commons.cli
 
| 1.2.0<br>
 
| Orbit
 
| PB needed (CQ4580)<br>
 
| <br>
 
| <br>
 
|-
 
| org.apache.commons.collections
 
| 3.2.0<br>
 
| Orbit
 
| PB needed (CQ1909)<br>
 
| <br>
 
| <br>
 
|-
 
| org.apache.commons.io
 
| 2.0.1<br>
 
| Orbit
 
| CQ4790
 
| <br>
 
| <br>
 
|-
 
| org.apache.commons.lang
 
| 2.4.0<br>
 
| Orbit
 
| PB needed (CQ2735)<br>
 
| <br>
 
| <br>
 
|-
 
| org.apache.commons.lang3<br>
 
| 3.0.0<br>
 
| 3rd-git<br>
 
| CQ needed<br>
 
| X<br>
 
| Common utils<br>
 
|-
 
| org.apache.commons.logging
 
| 1.1.1<br>
 
| Orbit
 
| PB needed (CQ1907)<br>
 
| <br>
 
| <br>
 
|-
 
| org.apache.commons.math<br>
 
| 2.1.0<br>
 
| 3rd-git<br>
 
| CQ4759<br>
 
| X<br>
 
| Should be removed; Orbit contains 2.1.0<br>
 
|-
 
| org.apache.commons.pool
 
| 1.4.0<br>
 
| Orbit
 
| PB needed (CQ2736)<br>
 
| <br>
 
| <br>
 
|-
 
| org.apache.commons.primitives<br>
 
| 1.0.0<br>
 
| 3rd-git<br>
 
| CQ4761<br>
 
| X<br>
 
| Common utils<br>
 
|-
 
| org.apache.log4j
 
| 1.2.15<br>
 
| Orbit
 
| PB4755 (CQ3560)<br>
 
| <br>
 
| <br>
 
|-
 
| org.apache.lucene<br>
 
| 2.9.1<br>
 
| Orbit<br>
 
| PB needed (CQ3964)<br>
 
| <br>
 
| Update to 3.5 planned<br>
 
|-
 
| org.kohsuke.args4j
 
| 2.0.12<br>
 
| Orbit
 
| PB needed (CQ3545)<br>
 
| <br>
 
| <br>
 
|-
 
| org.sl4fj.*
 
| 1.6.1<br>
 
| Orbit
 
| PB needed<br>
 
| <br>
 
| <br>
 
|}
 
 
<br>
 
 
<br>
 
 
= Transitive Dependencies  =
 
 
Bundles required to build direct dependencies and bundles required at runtime dependencies for direct dependencies.
 
 
{| width="100%" cellspacing="1" cellpadding="1" border="0" align="left"
 
|-
 
| '''Name'''
 
| '''Version'''
 
| '''Location'''
 
| '''IP Check'''
 
| '''Notes'''
 
|-
 
| javax.activation
 
| 1.1.1<br>
 
| Orbit
 
| PB needed (CQ4135)<br>
 
| Required by sun.jersey.server<br>
 
|-
 
| javax.annotation
 
| 1.1.0<br>
 
| Orbit
 
| PB needed (CQ5014)<br>
 
| Required by sun.jersey.server<br>
 
|-
 
| javax.ejb<br>
 
| 3.1.0<br>
 
| 3rd-git<br>
 
| needed?
 
| Required by com.sun.jersey.server<br>
 
|-
 
| javax.inject
 
| <br>
 
| Orbit
 
| PB needed (CQ3555)<br>
 
| Required by com.google.inject
 
|-
 
| javax.transaction
 
| <br>
 
| Orbit
 
| PB needed (CQ3903)<br>
 
| <br>
 
|-
 
| javax.xml.rpc
 
| <br>
 
| Orbit
 
| <br>
 
| <br>
 
|-
 
| javax.xml.soap
 
| <br>
 
| Orbit
 
| <br>
 
| <br>
 
|-
 
| javax.enterprise.jsr299<br>
 
| 1.0.0<br>
 
| 3rd-git<br>
 
| None<br>
 
| Required by com.sun.jersey.server<br>
 
|-
 
| javax.servlet<br>
 
| 3.0.1<br>
 
| 3rd-git<br>
 
| None<br>
 
| Should be removed; Orbit contains 3.0.0<br>
 
|-
 
| net.sf.cglib<br>
 
| 2.2.0<br>
 
| 3rd-git<br>
 
| None<br>
 
| Required by com.google.inject<br>
 
|}
 
 
= Test Dependencies  =
 
 
{| width="100%" cellspacing="1" cellpadding="1" border="0" align="left"
 
|-
 
| '''Name'''
 
| '''Version'''
 
| '''Location'''
 
| '''IP Check'''
 
| '''Required for Release'''
 
| '''Notes'''
 
|-
 
| org.aopalliance
 
| <br>
 
| Orbit
 
| <br>
 
| <br>
 
| <br>
 
|-
 
| org.objectweb.asm
 
| 3.3.1<br>
 
| Orbit
 
| PB needed (CQ4721)<br>
 
| <br>
 
| <br>
 
|-
 
| org.mockito<br>
 
| 1.8.4<br>
 
| Orbit<br>
 
| PB needed (CQ3930)<br>
 
| <br>
 
| <br>
 
|}
 
 
[[Category:Recommenders|ThirdPartyDependencies]]
 

Latest revision as of 02:31, 26 September 2013

Back to the top