Skip to main content
Jump to: navigation, search

Difference between revisions of "Recommenders/Attic/Release/ThirdPartyDependencies"

Line 15: Line 15:
 
| <br>
 
| <br>
 
|-
 
|-
| ch.qos.logback.core<br>
+
| ch.qos.logback.core<br>  
 
| 0.9.27  
 
| 0.9.27  
 
| Orbit  
 
| Orbit  
Line 22: Line 22:
 
|-
 
|-
 
| com.google.gson<br>  
 
| com.google.gson<br>  
| 1.6.0<br>  
+
| 2.0.0<br>  
 
| 3rd-git<br>  
 
| 3rd-git<br>  
| PB4753 (CQ4730)<br>  
+
| CQ5900<br>  
| Used for (de-)serialization in JSON format; We should upgrade to 2.0 for performance reasons.<br>
+
| Used for (de-)serialization in JSON format<br>
 
|-
 
|-
 
| '''com.google.guava<br>'''  
 
| '''com.google.guava<br>'''  
Line 132: Line 132:
 
<br>  
 
<br>  
  
<br>
+
<br>  
  
 
== Transitive Dependencies  ==
 
== Transitive Dependencies  ==

Revision as of 12:53, 19 December 2011

Direct Dependencies

Name Version Location IP Check Notes
ch.qos.logback.classic 0.9.27
Orbit PB5895 (CQ4827)

ch.qos.logback.core
0.9.27 Orbit PB5896 (CQ4826)
com.google.gson
2.0.0
3rd-git
CQ5900
Used for (de-)serialization in JSON format
com.google.guava
10.0.1
3rd-git
PB needed; CQ5804
Common utils & EventBus
com.google.inject
3.0.0
3rd-git
CQ5058
Dependency Injection Framework
com.google.inject.assistedinject
3.0.0
3rd-git
CQ5059
Support for assisted injection
com.google.inject.multibindings
3.0.0
3rd-git
CQ5060

com.ibm.wala.core
1.3.1
3rd-git
CQ4757 Used for static analysis; Update to 1.3.2 is planned
com.ibm.wala.shrike
1.3.1
3rd-git
CQ4758 Used for static analysis; Update to 1.3.2 is planned
com.sun.jersey.client
1.8.0
3rd-git
PB5511 (CQ5509)

com.sun.jersey.core
1.8.0
3rd-git
PB5511 (CQ5509)

com.sun.jersey.server
1.8.0
3rd-git
PB5512 (CQ5221)

org.apache.commons.io 2.0.1
Orbit CQ4790
org.apache.commons.lang3
3.0.0
3rd-git
CQ needed
Common utils
org.apache.commons.math
2.1.0
3rd-git
CQ4759
Should be removed; Orbit contains 2.1.0
org.apache.commons.pool 1.4.0
Orbit PB needed (CQ2736)

org.apache.commons.primitives
1.0.0
3rd-git
CQ4761
Common utils
org.apache.lucene
2.9.1
Orbit
PB needed (CQ3964)
Update to 3.5 planned
org.kohsuke.args4j 2.0.12
Orbit PB needed (CQ3545)

org.sl4fj.* 1.6.1
Orbit PB needed



Transitive Dependencies

Bundles required to build direct dependencies and bundles required at runtime dependencies for direct dependencies.

Name Version Location IP Check Notes
javax.activation 1.1.1
Orbit PB needed (CQ4135)
Required by sun.jersey.server
javax.annotation 1.1.0
Orbit PB needed (CQ5014)
Required by sun.jersey.server
javax.ejb
3.1.0
3rd-git
needed? Required by com.sun.jersey.server
javax.inject
Orbit PB needed (CQ3555)
Required by com.google.inject
javax.transaction
Orbit PB needed (CQ3903)

javax.xml.rpc
Orbit

javax.xml.soap
Orbit

javax.enterprise.jsr299
1.0.0
3rd-git
None
Required by com.sun.jersey.server
javax.servlet
3.0.1
3rd-git
None
Should be removed; Orbit contains 3.0.0
net.sf.cglib
2.2.0
3rd-git
None
Required by com.google.inject

Test Dependencies

Name Version Location IP Check Notes
org.aopalliance 1.0.0
Orbit PB needed (CQ3087)

org.objectweb.asm 3.3.1
Orbit PB needed (CQ4721)

org.mockito
1.8.4
Orbit
PB needed (CQ3930)

Back to the top