Skip to main content
Jump to: navigation, search

Difference between revisions of "Recommenders/Attic/Release/ThirdPartyDependencies"

Line 11: Line 11:
 
|-
 
|-
 
| ch.qos.logback.*  
 
| ch.qos.logback.*  
| <br>
+
| <br>  
 
| Orbit  
 
| Orbit  
| PB needed<br>
+
| PB needed<br>  
 
| X  
 
| X  
 
| <br>
 
| <br>
Line 20: Line 20:
 
| 1.6.0<br>  
 
| 1.6.0<br>  
 
| 3rd-git<br>  
 
| 3rd-git<br>  
| CQ???<br>  
+
| PB4753 (CQ4730)<br>
 
| X<br>  
 
| X<br>  
 
| Used for (de-)serialization in JSON format; We should upgrade to 2.0 for performance reasons.<br>
 
| Used for (de-)serialization in JSON format; We should upgrade to 2.0 for performance reasons.<br>
Line 50: Line 50:
 
| CQ5060<br>  
 
| CQ5060<br>  
 
| X<br>  
 
| X<br>  
| <br>
 
|-
 
| com.google.protobuf
 
| <br>
 
| Orbit
 
| <br>
 
| <br>
 
 
| <br>
 
| <br>
 
|-
 
|-
Line 62: Line 55:
 
| 1.3.1<br>  
 
| 1.3.1<br>  
 
| 3rd-git<br>  
 
| 3rd-git<br>  
| CQ???
+
| CQ4757
 
| <br>  
 
| <br>  
 
| Used for static analysis; Update to 1.3.2 is planned<br>
 
| Used for static analysis; Update to 1.3.2 is planned<br>
Line 69: Line 62:
 
| 1.3.1<br>  
 
| 1.3.1<br>  
 
| 3rd-git<br>  
 
| 3rd-git<br>  
| CQ???
+
| CQ4758
| <br>
+
| Used for static analysis; Update to 1.3.2 is planned<br>
+
|-
+
| com.ibm.wala.util<br>
+
| 1.3.1<br>
+
| 3rd-git<br>
+
| CQ???<br>
+
 
| <br>  
 
| <br>  
 
| Used for static analysis; Update to 1.3.2 is planned<br>
 
| Used for static analysis; Update to 1.3.2 is planned<br>
 
|-
 
|-
 
| com.sun.jersey.client<br>  
 
| com.sun.jersey.client<br>  
| 1.6.0<br>  
+
| 1.8.0<br>  
 
| 3rd-git<br>  
 
| 3rd-git<br>  
 
| PB5511 (CQ5509) <br>  
 
| PB5511 (CQ5509) <br>  
Line 92: Line 78:
 
| PB5511 (CQ5509)<br>  
 
| PB5511 (CQ5509)<br>  
 
| X<br>  
 
| X<br>  
|  
+
| <br>
 
|-
 
|-
 
| com.sun.jersey.server<br>  
 
| com.sun.jersey.server<br>  
Line 99: Line 85:
 
| PB5512 (CQ5221)<br>  
 
| PB5512 (CQ5221)<br>  
 
| <br>  
 
| <br>  
|  
+
| <br>
 
|-
 
|-
 
| javax.activation  
 
| javax.activation  
| <br>
+
| 1.1.1<br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| PB needed (CQ4135)<br>  
| <br>
+
| <br>  
| <br>
+
| Required by sun.jersey.server<br>
 
|-
 
|-
 
| javax.annotation  
 
| javax.annotation  
| <br>
+
| 1.1.0<br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| PB needed (CQ5014)<br>  
| <br>
+
| <br>
+
|-
+
| javax.annotations.jsr305<br>  
+
 
| <br>  
 
| <br>  
| 3rd-git<br>
+
| Required by sun.jersey.server<br>
| None<br>
+
| X<br>
+
| Required by com.google.guava<br>
+
 
|-
 
|-
 
| javax.ejb<br>  
 
| javax.ejb<br>  
 
| 3.1.0<br>  
 
| 3.1.0<br>  
 
| 3rd-git<br>  
 
| 3rd-git<br>  
| None<br>
+
| needed?
 
| <br>  
 
| <br>  
 
| Required by com.sun.jersey.server<br>
 
| Required by com.sun.jersey.server<br>
 
|-
 
|-
 
| javax.inject  
 
| javax.inject  
| <br>
+
| <br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| PB needed (CQ3555)<br>  
 
| X  
 
| X  
 
| Required by com.google.inject
 
| Required by com.google.inject
 
|-
 
|-
 
| javax.transaction  
 
| javax.transaction  
| <br>
+
| <br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| PB needed (CQ3903)<br>  
| <br>
+
| <br>  
 
| <br>
 
| <br>
 
|-
 
|-
 
| javax.xml.rpc  
 
| javax.xml.rpc  
| <br>
+
| <br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| <br>  
| <br>
+
| <br>  
 
| <br>
 
| <br>
 
|-
 
|-
 
| javax.xml.soap  
 
| javax.xml.soap  
| <br>
+
| <br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| <br>  
| <br>
+
| <br>  
 
| <br>
 
| <br>
 
|-
 
|-
Line 179: Line 158:
 
|-
 
|-
 
| org.aopalliance  
 
| org.aopalliance  
| <br>
+
| <br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| <br>  
| <br>
+
| <br>  
 
| <br>
 
| <br>
 
|-
 
|-
 
| org.apache.ant  
 
| org.apache.ant  
| <br>
+
| <br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| <br>  
| <br>
+
| <br>  
 
| <br>
 
| <br>
 
|-
 
|-
 
| org.apache.commons.cli  
 
| org.apache.commons.cli  
| <br>
+
| 1.2.0<br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| PB needed (CQ4580)<br>  
| <br>
+
| <br>  
 
| <br>
 
| <br>
 
|-
 
|-
 
| org.apache.commons.collections  
 
| org.apache.commons.collections  
| <br>
+
| 3.2.0<br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| PB needed (CQ1909)<br>  
| <br>
+
| <br>  
 
| <br>
 
| <br>
 
|-
 
|-
 
| org.apache.commons.io  
 
| org.apache.commons.io  
| <br>
+
| 2.0.1<br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| CQ4790
| <br>
+
| <br>  
 
| <br>
 
| <br>
 
|-
 
|-
 
| org.apache.commons.lang  
 
| org.apache.commons.lang  
| <br>
+
| 2.4.0<br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| PB needed (CQ2735)<br>  
| <br>
+
| <br>  
 
| <br>
 
| <br>
 
|-
 
|-
Line 223: Line 202:
 
| 3.0.0<br>  
 
| 3.0.0<br>  
 
| 3rd-git<br>  
 
| 3rd-git<br>  
| None<br>  
+
| CQ needed<br>
 
| X<br>  
 
| X<br>  
 
| Common utils<br>
 
| Common utils<br>
 
|-
 
|-
 
| org.apache.commons.logging  
 
| org.apache.commons.logging  
| <br>
+
| 1.1.1<br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| PB needed (CQ1907)<br>  
| <br>
+
| <br>  
 
| <br>
 
| <br>
 
|-
 
|-
Line 237: Line 216:
 
| 2.1.0<br>  
 
| 2.1.0<br>  
 
| 3rd-git<br>  
 
| 3rd-git<br>  
| None<br>  
+
| CQ4759<br>  
 
| X<br>  
 
| X<br>  
 
| Should be removed; Orbit contains 2.1.0<br>
 
| Should be removed; Orbit contains 2.1.0<br>
 
|-
 
|-
 
| org.apache.commons.pool  
 
| org.apache.commons.pool  
| <br>
+
| 1.4.0<br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| PB needed (CQ2736)<br>  
| <br>
+
| <br>  
 
| <br>
 
| <br>
 
|-
 
|-
Line 256: Line 235:
 
|-
 
|-
 
| org.apache.log4j  
 
| org.apache.log4j  
| <br>
+
| 1.2.15<br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| PB4755 (CQ3560)<br>  
| <br>
+
| <br>  
 
| <br>
 
| <br>
 
|-
 
|-
 
| org.apache.lucene<br>  
 
| org.apache.lucene<br>  
| 3.0.1<br>  
+
| 2.9.1<br>  
| 3rd-git<br>  
+
| Orbit<br>  
| None<br>  
+
| PB needed (CQ3964)<br>  
 
| <br>  
 
| <br>  
 
| Update to 3.5 planned<br>
 
| Update to 3.5 planned<br>
 
|-
 
|-
 
| org.kohsuke.args4j  
 
| org.kohsuke.args4j  
| <br>
+
| 2.0.12<br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| PB needed (CQ3545)<br>  
| <br>
+
| <br>  
 
| <br>
 
| <br>
 
|-
 
|-
 
| org.objectweb.asm  
 
| org.objectweb.asm  
| <br>
+
| 3.3.1<br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| PB needed (CQ4721)<br>  
| <br>
+
| <br>  
 
| <br>
 
| <br>
 
|-
 
|-
 
| org.sl4fj.*  
 
| org.sl4fj.*  
| <br>
+
| 1.6.1<br>  
 
| Orbit  
 
| Orbit  
| <br>
+
| PB needed<br>  
| <br>
+
| <br>  
 
| <br>
 
| <br>
 
|-
 
|-
 
| org.mockito<br>  
 
| org.mockito<br>  
| 1.8.5<br>  
+
| 1.8.4<br>  
| 3rd-git<br>  
+
| Orbit<br>  
| None<br>  
+
| PB needed (CQ3930)<br>  
 
| <br>  
 
| <br>  
| Should be removed; Orbit contains 1.8.4<br>
+
| <br>
 
|}
 
|}
  
 
[[Category:Recommenders|ThirdPartyDependencies]]
 
[[Category:Recommenders|ThirdPartyDependencies]]

Revision as of 05:33, 13 December 2011


Name Version Location IP Check Required for Release Notes
ch.qos.logback.*
Orbit PB needed
X
com.google.gson
1.6.0
3rd-git
PB4753 (CQ4730)
X
Used for (de-)serialization in JSON format; We should upgrade to 2.0 for performance reasons.
com.google.guava
10.0.1
3rd-git
PB needed; CQ5804
X
Common utils & EventBus
com.google.inject
3.0.0
3rd-git
CQ5058
X
Dependency Injection Framework
com.google.inject.assistedinject
3.0.0
3rd-git
CQ5059
X
Support for assisted injection
com.google.inject.multibindings
3.0.0
3rd-git
CQ5060
X

com.ibm.wala.core
1.3.1
3rd-git
CQ4757
Used for static analysis; Update to 1.3.2 is planned
com.ibm.wala.shrike
1.3.1
3rd-git
CQ4758
Used for static analysis; Update to 1.3.2 is planned
com.sun.jersey.client
1.8.0
3rd-git
PB5511 (CQ5509)
X

com.sun.jersey.core
1.8.0
3rd-git
PB5511 (CQ5509)
X

com.sun.jersey.server
1.8.0
3rd-git
PB5512 (CQ5221)


javax.activation 1.1.1
Orbit PB needed (CQ4135)

Required by sun.jersey.server
javax.annotation 1.1.0
Orbit PB needed (CQ5014)

Required by sun.jersey.server
javax.ejb
3.1.0
3rd-git
needed?
Required by com.sun.jersey.server
javax.inject
Orbit PB needed (CQ3555)
X Required by com.google.inject
javax.transaction
Orbit PB needed (CQ3903)


javax.xml.rpc
Orbit


javax.xml.soap
Orbit


javax.enterprise.jsr299
1.0.0
3rd-git
None

Required by com.sun.jersey.server
javax.servlet
3.0.1
3rd-git
None

Should be removed; Orbit contains 3.0.0
net.sf.cglib
2.2.0
3rd-git
None
X
Required by com.google.inject
org.aopalliance
Orbit


org.apache.ant
Orbit


org.apache.commons.cli 1.2.0
Orbit PB needed (CQ4580)


org.apache.commons.collections 3.2.0
Orbit PB needed (CQ1909)


org.apache.commons.io 2.0.1
Orbit CQ4790

org.apache.commons.lang 2.4.0
Orbit PB needed (CQ2735)


org.apache.commons.lang3
3.0.0
3rd-git
CQ needed
X
Common utils
org.apache.commons.logging 1.1.1
Orbit PB needed (CQ1907)


org.apache.commons.math
2.1.0
3rd-git
CQ4759
X
Should be removed; Orbit contains 2.1.0
org.apache.commons.pool 1.4.0
Orbit PB needed (CQ2736)


org.apache.commons.primitives
1.0.0
3rd-git
CQ4761
X
Common utils
org.apache.log4j 1.2.15
Orbit PB4755 (CQ3560)


org.apache.lucene
2.9.1
Orbit
PB needed (CQ3964)

Update to 3.5 planned
org.kohsuke.args4j 2.0.12
Orbit PB needed (CQ3545)


org.objectweb.asm 3.3.1
Orbit PB needed (CQ4721)


org.sl4fj.* 1.6.1
Orbit PB needed


org.mockito
1.8.4
Orbit
PB needed (CQ3930)


Back to the top