Skip to main content
Jump to: navigation, search

Difference between revisions of "Plug-in Development Environment"

(Core Tools)
(Core Tools)
Line 8: Line 8:
 
  Using the core tools you can see exactly what causes each bundle to be started,
 
  Using the core tools you can see exactly what causes each bundle to be started,
 
  you can find out what causes each class to be loaded, etc etc.
 
  you can find out what causes each class to be loaded, etc etc.
 +
 +
[http://www.eclipse.org/eclipse/platform-core/downloads/tools/readme.html Core Tools Readme]
  
 
Consists of three .jar files,  
 
Consists of three .jar files,  
Line 15: Line 17:
  
 
To enable need to run eclipse with -debug <option file path>
 
To enable need to run eclipse with -debug <option file path>
 +
The Nov 2006 .options file [[CoreToolsOptionsExampleFile]]
  
Here is the Nov 2006 .options file [[CoreToolsOptionsExampleFile]]
+
After enable you have new views under Window->ShowView:
 +
[[Image:ShowViewRuntimeTools.png]]
  
 
===Adding 3rd Party Jar files===
 
===Adding 3rd Party Jar files===

Revision as of 13:08, 30 November 2006

Plug-in Development Environment (PDE) provides the tools on top of the JDT to develop plugins. It is a part of Eclipse SDK Project.

Core Tools

Jeff McAffer, https://bugs.eclipse.org/bugs/show_bug.cgi?id=166011:

There are tools and facilities
available to better understand the startup sequence.  See 
  Download Core Tools
Using the core tools you can see exactly what causes each bundle to be started,
you can find out what causes each class to be loaded, etc etc.

Core Tools Readme

Consists of three .jar files,

  1. org.eclipse.core.resources.spysupport
  2. org.eclipse.core.tools.resources
  3. org.eclipse.core.tools

To enable need to run eclipse with -debug <option file path> The Nov 2006 .options file CoreToolsOptionsExampleFile

After enable you have new views under Window->ShowView: File:ShowViewRuntimeTools.png

Adding 3rd Party Jar files

Option 1: turn the jars into plugins

Use New>Project>Plug-in Development>Plug-in from existing JAR archive. That will turn one or more jar files into a single jar plugin. For something like log4j you can then set up Buddy-Classloading, etc.

Before 3.2.1, you need to add to the build.properties. See Bug 146042 RCP export has problems with required plug-ins

Option 2: include the jars in a plugin

  1. Use Import>File System to import the jar files into your plugin project, say in the <project>/lib directory.
  2. Use "Add..." to add the jars to the classpath section of the PDE Editor>Runtime tab.
  3. Use "New..." to add "." library back (with no quotes, of course).
  4. Make sure your binary build exports the new jar files on the PDE Editor>Build tab.
  5. Save
  6. On the project, use the popup menu>PDE Tools>Update Classpath to correctly add the jars to the eclipse project classpath.
  7. Export any packages that you need to using the PDE Editor>Runtime tab
  8. Save

Check out https://bugs.eclipse.org/bugs/show_bug.cgi?id=108781

It talks about how adding a 3rd party jar removes the default "." classpath, and the need to add it back.

Also, eclipse can handle jars within jars. It expands them into a temporary location during runtime.

Back to the top