Skip to main content
Jump to: navigation, search

Difference between revisions of "Papyrus Required External Plugins"

(New page: Papyrus requires some external plugins in order to compile. <br> You usually need the common environment, plus some external plugins required to compile Papyrus. The versions of these lat...)
 
m
Line 4: Line 4:
 
<br>These page try to maintain the list of external plugins required to compile Papyrus.
 
<br>These page try to maintain the list of external plugins required to compile Papyrus.
  
=== Eclipse Indigo M4 ===
+
== Eclipse Indigo M4 ==
 
*Can be used with the Papyrus Head.
 
*Can be used with the Papyrus Head.
 
*[http://www.eclipse.org/downloads/packages/release/indigo/] The latest Eclipse Indigo Modeling release.
 
*[http://www.eclipse.org/downloads/packages/release/indigo/] The latest Eclipse Indigo Modeling release.
Line 12: Line 12:
 
*http://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.papyrus/trunk/releng/TargetPlatform/Indigo_developers.target
 
*http://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.papyrus/trunk/releng/TargetPlatform/Indigo_developers.target
  
=== Eclipse Helios ===
+
== Eclipse Helios ==
 
*Can be used with Papyrus 7.x branch.
 
*Can be used with Papyrus 7.x branch.
 
*[http://www.eclipse.org/downloads/packages/eclipse-modeling-tools-includes-incubating-components/heliossr1] Eclipse Modeling 3.6. GMF needs to be install on top of this release.  
 
*[http://www.eclipse.org/downloads/packages/eclipse-modeling-tools-includes-incubating-components/heliossr1] Eclipse Modeling 3.6. GMF needs to be install on top of this release.  
 
*[http://download.eclipse.org/tools/orbit/downloads/drops/S20100120144102/bundles/org.antlr.runtime_3.0.0.v200803061811.jar] ANTLR 3.0.0. Download this plug-in and put it into the dropins folder.
 
*[http://download.eclipse.org/tools/orbit/downloads/drops/S20100120144102/bundles/org.antlr.runtime_3.0.0.v200803061811.jar] ANTLR 3.0.0. Download this plug-in and put it into the dropins folder.

Revision as of 06:50, 15 March 2011

Papyrus requires some external plugins in order to compile.
You usually need the common environment, plus some external plugins required to compile Papyrus. The versions of these laters vary according to the Eclipse and Papyrus release.
These page try to maintain the list of external plugins required to compile Papyrus.

Eclipse Indigo M4

You can also use the target platform defined here:

Eclipse Helios

  • Can be used with Papyrus 7.x branch.
  • [2] Eclipse Modeling 3.6. GMF needs to be install on top of this release.
  • [3] ANTLR 3.0.0. Download this plug-in and put it into the dropins folder.

Back to the top