Skip to main content
Jump to: navigation, search

Difference between revisions of "Papyrus Required External Plugins"

m
m (Compilation Troubleshooting)
Line 27: Line 27:
  
 
== Compilation Troubleshooting ==
 
== Compilation Troubleshooting ==
* '''an api baseline has not been set for the current workspace'''
+
* ''' ''an api baseline has not been set for the current workspace'' '''
** Goto "Preferences -> Plug-in Development -> API Baselines" and change option Missing API baseline
+
** Goto '' "Preferences -> Plug-in Development -> API Baselines" '' and change option '' "Missing API baseline" ''
** See https://teambruegge.in.tum.de/groups/unicase/wiki/5b324/Remove_API_baseline_warning.html
+
** Or see https://teambruegge.in.tum.de/groups/unicase/wiki/5b324/Remove_API_baseline_warning.html

Revision as of 09:58, 15 March 2011

Papyrus requires some external plugins in order to compile.
You usually need the common environment, plus some external plugins required to compile Papyrus. The versions of these laters vary according to the Eclipse and Papyrus release.
These page try to maintain the list of external plugins required to compile Papyrus.

Eclipse Indigo M5

Eclipse Indigo M4

You can also use the target platform defined here:

Eclipse Helios

  • Can be used with Papyrus 7.x branch.
  • [3] Eclipse Modeling 3.6. GMF needs to be install on top of this release.
  • [4] ANTLR 3.0.0. Download this plug-in and put it into the dropins folder.


Compilation Troubleshooting

Back to the top