Skip to main content
Jump to: navigation, search

Difference between revisions of "Papyrus/Papyrus Developer Guide"

(Papyrus Discovery)
 
(162 intermediate revisions by 18 users not shown)
Line 1: Line 1:
 
== Development Environment  ==
 
== Development Environment  ==
  
To ease the development on Papyrus, each member of the team works with basically the same configuration. <br>
+
To ease the development of Papyrus, each member of the team works with basically the same configuration.
 +
There are two ways to get your development environment:
 +
* downloading and installing Eclipse
 +
* using the [[Eclipse Installer]] (by Oomph) to manage your Papyrus development workbench.
  
=== Common Environment  ===
+
=== Java Version ===
 +
OpenJDK 11 (or higher) is recommended.
  
Following is a description of the basic configuration:  
+
=== Downloading Eclipse ===
 +
You can download a fresh Eclipse Package release on this [https://www.eclipse.org/downloads/packages/ page].
 +
We advise you to download the Eclipse Committer version.
  
*The latest Eclipse Modeling release.
+
=== Papyrus Oomph Setup Model ===
*[http://www.eclipse.org/projects/project_summary.php?projectid=technology.subversive] SVN Subversive (or Subclipse, update site: http://subclipse.tigris.org/update_1.6.x)
+
*[http://eclipse-cs.sourceforge.net/downloads.html] CheckStyle
+
*[http://jautodoc.sourceforge.net/] JAutoDoc
+
**Configure the header template according to your company: Eclipse Preferences -&gt; Java -&gt; JAutodoc
+
*Java 1.5:
+
**Eclipse Preferences -&gt; Java -&gt; Compiler
+
**Eclipse Preferences -&gt; Java -&gt; Installed JREs
+
*Set the API Baseline to Ignore
+
**Eclipse Preferences -&gt; Plug-In Developpement -&gt; API Baselines-&gt; Missing API Baseline should be setted to Ignore
+
**VM Arguments for debug mode:
+
<pre>-Dosgi.requiredJavaVersion=1.5 -Xms768m -Xmx1024m -XX:PermSize=256m -XX:MaxPermSize=256m -XX:+CMSClassUnloadingEnabled
+
</pre>
+
  
=== Required External Plugins ===
+
The [[Eclipse Installer]] provides a set-up model for Papyrus, making it easier than ever to get a complete Eclipse workbench up and running for development on the Papyrus source code. Just download the Oomph Installer from the linked wiki page and follow the simple wizard to create your IDE and import the Papyrus source projects that you want to work on.
  
Papyrus requires some external plugins in order to compile. <br> The following page maintain a list of [[Papyrus Required External Plugins|Papyrus Required External Plugins]]
+
Pick any product you like on the first page, but be sure it's the latest release of that product for the Papyrus stream you're working on. For example, if you're working on the Luna service stream of Papyrus, you need the Luna release of Eclipse.  On the second page, expand '''Eclipse.org''' / '''Papyrus''' to see the various components that you can import to work on.  Pick any combination of the leaf-level sub-(sub-)projects, even all of them if you like.  In the third page where you specify variables such as install location, workspace location, git clone, etc. be sure to choose "Luna" for the Target Platform.  This ensures that you will be set up to work on Papyrus Luna (SR1), which is the only development stream currently supported by the setup model (until Mars development gets under way).
  
== Development Plan  ==
+
Contributing your changes is easy because Oomph will clone the Papyrus Git repository for you and configure Gerrit push.
  
=== Specifications  ===
+
Amongst possibly other details, the setup model configures:
  
The specifications are available here: http://wiki.eclipse.org/Papyrus_Developer_Guide/Specifications
+
* your IDE with all of the tools needed to edit and build the source projects you choose
 +
* your workspace with a Git clone and the source projects imported from it that you choose
 +
* a PDE target that includes all of the dependencies required by Papyrus plus the latest nightly build of Papyrus, itself, so that you can import only a subset of the (many) source projects but still run the complete Papyrus toolset in a run-time workbench
 +
* Mylyn queries for current open bugs and enhancements in the Papyrus bugzilla database
 +
* Mylyn queries for the status of the latest Papyrus automated builds, including tests
 +
* Mylyn queries for open Gerrit reviews
 +
* preferences enforcing the Papyrus standard compiler and code formatter/template settings
  
== Getting the code  ==
+
Please report bugs if you see any problems in the setup configuration.
  
=== Connecting to the svn  ===
+
Follow the following link for a step by step installation guide: [[Papyrus_Developer_Guide/Papyrus_With_Oomph | Oomph setup guide]]
  
The code is available under svn at this location http://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.papyrus/
+
=== Installation Details ===
  
=== Retrieve code  ===
+
Following is a description of the basic configuration:
  
The following [[PSF]] files will allow you to import all Papyrus plugins used during build phase: PSF files are now automatically generated using the SVN repository. They do not necessarily correspond to what is built. The script used to generate them is available in this project http://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.papyrus/trunk/readme/ The following psf files are automatically update several time by day.
+
*The latest Eclipse release pertinent to your use-cases (Modeling, Committer, java, etc)
 +
*the Papyrus release (matching your Eclipse version), installed from the relevant [https://www.eclipse.org/papyrus/download.html#main Papyrus update site]
 +
** Papyrus SDK
 +
** Papyrus Toolsmiths
 +
** Papyrus Releng Tools
 +
** Papyrus User Examples
  
These PSF are builded using the SVN contents and NOT using the build process. So some downloaded plugins should be deprecated, not maintained, and not provided in the Papyrus installation.
+
===Additional Useful Tools===
 +
*[http://jautodoc.sourceforge.net/ JAutoDoc]
 +
* install the source version of the Papyrus dependencies (EMF, GMF, MWE2, XTEND, XTEXT, UML2, UML2 Extender SDK) (relevant to your usecases)
  
To know if a downloaded plugin should compile, you can have a look to a Papyrus installation. If the plugin comes with the installation, it should compile!
+
==Configuration==
 +
*Configure the header template according to your company: Eclipse Preferences -&gt; Java -&gt; JAutodoc
 +
*Configure your Eclipse.ini file adding this line in the ''vmargs'':
 +
<pre>-Duser.name=FirstName LastName (Company) <user@email></pre>
 +
*Java 11:
 +
**Eclipse Preferences -&gt; Java -&gt; Compiler
 +
**Eclipse Preferences -&gt; Java -&gt; Installed JREs
 +
**VM Arguments for debug mode:
 +
<pre>-Dosgi.requiredJavaVersion=11 -Xms768m -Xmx1024m -XX:+CMSClassUnloadingEnabled
 +
</pre>
  
Some downloaded plugins should have dependencies on plugins stored in the incoming folder. In this case you should download them manually.
+
=== Gerrit Configuration  ===
 +
*[[Papyrus_Developer_Guide/How_to_Contribute_to_Papyrus_with_Gerrit | How to configure Gerrit]]
  
*'''Trunk 0.10.X (Kepler)'''
+
=== API Management Configuration ===
**last versions of the psf files for Papyrus/trunk using http for non-commiters:  
+
There are two way to manage your code version:
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/build_http.psf build_http.psf] release engineering projects
+
*define yourself the API baseline for Papyrus using [https://help.eclipse.org/2020-06/index.jsp?nav=%2F4_2_3 Eclipse Preference API Baseline]  
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/extraplugins_http.psf extraplugins_http.psf] all papyrus extraplugins
+
*Oomph includes a way to manage the version changes between two releases as illustrated [[Papyrus_Developer_Guide/Oomph_Version_Management |here]]
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/full_papyrus_http.psf full_papyrus_http.psf] all papyrus plugins available on the SVN
+
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/plugins_http.psf plugins_http.psf] all papyrus plugins
+
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/tests_http.psf tests_http.psf] Junit and other test plugins (mandatory for developers)
+
**last versions of the psf files for Papyrus/trunk using svn+ssh for commiters:
+
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/build_svn_ssh.psf build_svn_ssh.psf] release engineering projects
+
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/extraplugins_svn_ssh.psf extraplugins_svn_ssh.psf] all papyrus extraplugins
+
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/full_papyrus_svn_ssh.psf full_papyrus_svn_ssh.psf] all papyrus plugins available on the SVN
+
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/plugins_svn_ssh.psf plugins_svn_ssh.psf] all papyrus plugins
+
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/tests_svn_ssh.psf tests_svn_ssh.psf] Junit and other test plugins (mandatory for developers)
+
**Details
+
***psf for plugins (updated the 2nd January 2013). The following plugins are not distributed and could be closed (deprecated, not yet provided in the Papyrus distribution or for developpers only):
+
<pre>oep.customization
+
oep.customization.properties
+
oep.customization.properties.generation
+
all plugins of the layer 'developer', excepted if you need to generate diagrams (in this case you should install the GMF Tooling too)
+
oep.editor.perspectiveconfiguration
+
oep.infra.emf.editor
+
oep.infra.emf.embeddededitor
+
oep.infra.emf.newchild
+
all plugins oep.infra.gmfdiag.css if you don't use the css excepted oep.infra.gmfdiag.css.model
+
org.eclipse.papyrus.infra.xtext.widgets
+
oep.sysml.diagram.parametric
+
oep.team.svn
+
oep.uml.documentation
+
oep.uml.standard
+
oep.uml.standard.edit
+
oep.uml.ui.perspectiveconfiguration
+
oep.uml.properties.tabbedproperties.comments
+
oep.uml.textedit.state.xtext.generator
+
all plugins oep.views.documentation
+
</pre>
+
*psf for extraplugins (updated the 2nd January 2013) . Only the follwing projects are currently provided by the Papyrus extra-plugins update site. The others projects can be closed.(They are deprecated, not yet provided in the Papyrus distribution or for developpers only):
+
<pre>
+
org.eclipse.papyrus.compare.report.ui
+
org.eclipse.papyrus.compare.report
+
org.eclipse.papyrus.diagramtemplate.edit
+
org.eclipse.papyrus.diagramtemplate.editor
+
org.eclipse.papyrus.diagramtemplate
+
org.eclipse.papyrus.eclipse.project.editors
+
org.eclipse.papyrus.infra.gmfdiag.css.configuration
+
org.eclipse.papyrus.infra.gmfdiag.css.properties
+
org.eclipse.papyrus.infra.gmfdiag.css.theme
+
org.eclipse.papyrus.infra.gmfdiag.css.xtext.ui
+
org.eclipse.papyrus.infra.gmfdiag.css.xtext
+
org.eclipse.papyrus.infra.gmfdiag.css
+
org.eclipse.papyrus.layout.algorithms.gridAlgorithm
+
org.eclipse.papyrus.layout.algorithms.horizontalAlgorithm
+
org.eclipse.papyrus.layout.algorithms.horizontalSymmetryAlgorithm
+
org.eclipse.papyrus.layout.algorithms.horizontalTreeAlgorithm
+
org.eclipse.papyrus.layout.algorithms.radialAlgorithm
+
org.eclipse.papyrus.layout.algorithms.springAlgorithm
+
org.eclipse.papyrus.layout.algorithms.treeAlgorithm
+
org.eclipse.papyrus.layout.algorithms.verticalAlgorithm
+
org.eclipse.papyrus.layout.algorithms.verticalSymmetryAlgorithm
+
org.eclipse.papyrus.layout.subeditor.gmf
+
org.eclipse.papyrus.layout
+
org.eclipse.papyrus.marte.properties
+
org.eclipse.papyrus.marte.static.profile
+
org.eclipse.papyrus.marte.vsl
+
org.eclipse.papyrus.migration.properties.model
+
org.eclipse.papyrus.uml.export
+
</pre>
+
*psf for tests (updated the 2nd January 2013) . Only the follwing projects are used for tests. The others projects can be closed.
+
<pre>
+
org.eclipse.papyrus.sysml.tests
+
org.eclipse.papyrus.bundles.tests
+
org.eclipse.papyrus.core.resourceloading.tests
+
org.eclipse.papyrus.customization.properties.tests
+
org.eclipse.papyrus.diagram.clazz.test
+
org.eclipse.papyrus.diagram.common.tests
+
org.eclipse.papyrus.diagram.stereotypeproperty
+
org.eclipse.papyrus.infra.services.edit.tests
+
org.eclipse.papyrus.infra.services.labelprovider.tests
+
org.eclipse.papyrus.sysml.diagram.blockdefinition.tests
+
org.eclipse.papyrus.sysml.diagram.internalblock.tests
+
org.eclipse.papyrus.sysml.service.types.tests
+
org.eclipse.papyrus.tests
+
org.eclipse.papyrus.uml.diagram.dnd.tests
+
org.eclipse.papyrus.uml.diagram.usecase.tests
+
org.eclipse.papyrus.uml.modelexplorer.tests
+
org.eclipse.papyrus.uml.service.types.tests
+
org.eclipse.papyrus.uml.tools.tests
+
org.eclipse.papyrus.views.modelexplorer.tests
+
org.eclipse.papyrus.tests.extra
+
org.eclipse.papyrus.infra.gmfdiag.css.tests.tests
+
</pre>
+
  
 +
*API Rules:
 +
**[[Evolving_Java-based_APIs]]
 +
**[[Evolving_Java-based_APIs_2]]
 +
**[[Evolving_Java-based_APIs_3]]
  
*'''Branch 0.9.X (Juno)'''
+
=== Apply Papyrus Configuration Files  ===
**last versions of the psf files for Papyrus/branch using http for non-commiters:
+
Papyrus provides configuration files for Template, CleanUp, and Format for java code.
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/build_0.9.X_http.psf build_0.9.X_http.psf] release engineering projects
+
Register these files into your Eclipse Preferences.
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/extraplugins_0.9.X_http.psf extraplugins_0.9.X_http.psf] all papyrus extraplugins
+
The Papyrus [http://git.eclipse.org/c/papyrus/org.eclipse.papyrus.git/tree/releng/templates/Papyrus%20Code%20templates.xml Code Templates], [http://git.eclipse.org/c/papyrus/org.eclipse.papyrus.git/tree/releng/templates/papyrus_cleanup.xml Java Cleanup] and [http://git.eclipse.org/c/papyrus/org.eclipse.papyrus.git/tree/releng/templates/papyrus_formatter.xml Java Formatter] files are available under the Papyrus repository in the folder '''releng/templates/''' and should be used for all your development on Papyrus.
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/full_papyrus_0.9.X_http.psf full_papyrus_0.9.X_http.psf] all papyrus plugins available on the SVN
+
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/plugins_0.9.X_http.psf plugins_0.9.X_http.psf] all papyrus plugins
+
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/tests_0.9.X_http.psf tests_0.9.X_http.psf] Junit and other test plugins (mandatory for developers)
+
**last versions of the psf files for Papyrus/branch using svn+ssh for commiters:
+
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/build_0.9.X_svn_ssh.psf build_0.9.X_svn_ssh.psf] release engineering projects
+
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/extraplugins_0.9.X_svn_ssh.psf extraplugins_0.9.X_svn_ssh.psf] all papyrus extraplugins
+
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/full_papyrus_0.9.X_svn_ssh.psf full_papyrus_0.9.X_svn_ssh.psf] all papyrus plugins available on the SVN
+
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/plugins_0.9.X_svn_ssh.psf plugins_0.9.X_svn_ssh.psf] all papyrus plugins
+
***[http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/tests_0.9.X_svn_ssh.psf tests_0.9.X_svn_ssh.psf] Junit and other test plugins (mandatory for developers)
+
  
===How to update the script generating the psf files.===
+
[[FAQ How do I control the Java formatter?|FAQ How do I control the Java formatter]]
The script is located on build.eclipse.org in /opt/public/modeling/mdt/papyrus/create_psf_files.sh.
+
*To modify it :
+
**download this project with Eclipse http://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.papyrus/trunk/readme/
+
**modify it and commit it on the SVN
+
**log you on hudson
+
**execute the script /opt/public/modeling/mdt/papyrus/update_psf_files_script.sh. This script allows to download and "install" the last version of the scripts located in trunk/readme/script (so it updates itself too)
+
  
 +
[[FAQ How can templates make me the fastest coder ever?|FAQ How can templates make me the fastest coder ever]]
  
=== Retrieve configuration files  ===
+
[https://git.eclipse.org/c/papyrus/org.eclipse.papyrus.git/tree/releng/templates/HowToUseTemplates.txt The note] explains how to install the templates in your environment.
 
+
The Papyrus [http://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.papyrus/trunk/doc/DevelopperDocuments/templates/Papyrus%20Code%20templates.xml Code Templates] and [http://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.papyrus/trunk/doc/DevelopperDocuments/templates/Papyrus%20Code%20templates.xml Java Formatter] files are available under the Papyrus repository in the plugin org.eclipse.papyrus.doc under the folder "templates"<br> [[FAQ How do I control the Java formatter?|FAQ How do I control the Java formatter]]<br> [[FAQ How can templates make me the fastest coder ever?|FAQ How can templates make me the fastest coder ever]]<br> Checkstyle: available soon <br>
+
 
+
[http://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.papyrus/trunk/doc/DevelopperDocuments/templates/HowToUseTemplates.txt The note] explains how to install the templates in your environment.  
+
 
+
== Papyrus Architecture==
+
 
+
*Papyrus architecture is explained here: [[MDT/Papyrus/Developer Guide/Architecture| Papyrus Architecture ]]
+
 
+
== Papyrus Generation  ==
+
 
+
*Papyrus generation mechanism is explained here: [[Papyrus Developer Guide/Papyrus diagram generation]]
+
 
+
== Papyrus Code Standards  ==
+
 
+
*Java Doc - every class, method and field including private ones should be documented with Java Doc
+
*No abbreviations - the class, methods and variables should have meaningful names
+
*Formatting - the code should be formatted in accordance with format templates
+
*Compile - the modified code and other plugins should be compilable. Be sure to use '''Java 1.5 code compatibility'''. Check other plugins that could be influenced before commiting!
+
*Standard Java Rules coding - Unless specified differently, the Java Standard Coding rules should be applied: no abbreviations, variables starting with lower case; class and types with upper case; Composed name separated with upper case; no underscore in names; ...
+
*In case of doubt - check existing code from those following the rules&nbsp;:-)
+
 
+
=== Papyrus Plug-ins and Features ===
+
 
+
See [[Papyrus/Code Standards|Papyrus code standards for plug-ins and features]]
+
 
+
== Papyrus Coding guidelines  ==
+
 
+
A few points may be a little tricky when coding for Papyrus. Among them:
+
 
+
=== Papyrus Plugin Naming Scheme and Folders Structure<br>  ===
+
 
+
*Papyrus plugins naming scheme and folder structure used to locate and name plugins is described here: [[Papyrus Plugin Naming Scheme|Papyrus_Plugin_Naming_Scheme]]
+
 
+
=== Structure and behavior of papyrus  ===
+
 
+
*Presentation of the papyrus stucture and the behavior of some parts [[Papyrus Developer Guide/Papyrus Structure Behavior]]
+
 
+
=== Papyrus Command Execution, History, Undo/Redo  ===
+
 
+
*This first document describes the usage of editing domains and gmf/gef/emf commands. See this detailed article [[Papyrus Developer Guide/Editing Domains and Commands]].
+
 
+
*This second document tries to explain how the differents Eclipse Command frameworks work and how they are related. It also explains how commands should be executed in Papyrus, in order to have correct undo/redo.
+
**http://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.papyrus/trunk/doc/DevelopperDocuments/architecture/commandExecution.doc
+
**Following UML model with code reverse can also be useful:
+
***http://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.papyrus/trunk/doc/DevelopperDocuments//architecture/CommandStackFramework.di
+
***http://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.papyrus/trunk/doc/DevelopperDocuments//architecture/CommandStackFramework.notation
+
***http://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.papyrus/trunk/doc/DevelopperDocuments//architecture/CommandStackFramework.uml
+
 
+
=== Papyrus ServiceRegistry<br>  ===
+
The ServiceRegistry is one of the main Papyrus component. The idea is that each Papyrus feature should be a service registered to the ServiceRegistry.
+
 
+
The ServiceRegistry should be accessible from any code. It allows to retrieve the components you need to perform your task.
+
<br>
+
A new implementation of the ServiceRegistry is submitted.
+
The new ServiceRegistry is discused here [[Papyrus Developer Guide/Service Registry]]
+
  
 
== How To ...  ==
 
== How To ...  ==
  
=== Commit, Report Bugs, patchs (Code Contributing)  ===
+
Each developer must follow the following rule in addition to the aforementioned [[MDT/Papyrus/Developer Guide/Charter | Developer Charter]].
 
+
*How To - related to reporting bugs, patching, commit, ... [[Papyrus Developer Guide/How To- Code Contributing]]
+
 
+
=== Papyrus Code Examples  ===
+
  
*How to - Related to Papyrus code,[[Papyrus Developer Guide/How To Code Examples]]<br>
+
=== Clone Papyrus Git Repository ===
  
=== Papyrus Log  ===
+
The Papyrus code and its documentations are located in a Git repository. In the website [http://git.eclipse.org/c/papyrus/org.eclipse.papyrus.git http://git.eclipse.org/c/papyrus/org.eclipse.papyrus.git] you will find the most recent activity information of the repository and, at the bottom of the page, you will find the URIs of the Git repository (e.g., http://git.eclipse.org/gitroot/papyrus/org.eclipse.papyrus.git).
  
*Papyrus Log is explained here [[Papyrus Developer Guide/Papyrus Log]]
+
Follow this [[Papyrus_Developer_Guide/Papyrus_Git_Tutorial | quick tutorial]] if you never used Git before and want to know how to import the source files of one or more Papyrus plugins in your Eclipse workspace.
  
=== Papyrus Editors ===
+
=== Code Contributions and Reviews ===
Currently Papyrus provides 2 editors kinds : Diagrams and Table. How to add your own editor kind is explained here [[Papyrus Developper Guide/How to - Add your own editor in Papyrus]]
+
  
=== Papyrus Discovery  ===
+
*[[Papyrus Developer Guide/How To- Code Contributing | Guidelines for a new contribution to papyrus]]
  
==== Papyrus additional components ====
+
=== Papyrus Plug-ins and Features ===
  
To add extra features to the Papyrus Discover, you should edit the files located here:<strike>/cvsroot/org.eclipse/HEAD/www/modeling/mdt/papyrus/downloazds/discovery/juno/</strike> now it is on git: ssh://USER_ID@git.eclipse.org/gitroot/www.eclipse.org/modeling/mdt.git
+
* [[Papyrus/Code Standards|Papyrus code standards for plug-ins and features]]
  
<br>
+
== Release Engineering ==
  
==== Papyrus as a Modeling component ====
+
=== Contributing To The Plan For The Release ===
  
Papyrus is available from the Modeling Package, using the discovery UI pf this package. This contribution is made by the project located here:&nbsp;git://git.eclipse.org/gitroot/www.eclipse.org/modeling/amalgam.git,
+
* [[Papyrus Developer Guide/Contribution Questionaire | Create a Contribution Questionaire]]
  
the file is located in the folders discovery/downloads/RELEASE_NAME
+
=== Release Process ===
  
== Papyrus Build Process ==
+
*[[Papyrus Developer Guide/Release Process: How To | How to release Papyrus]].
  
*Papyrus build process on Athena is explained here [[Papyrus Developer Guide/Build Process]].
+
=== API Evolution ===
  
== New plugin Submition Process  ==
+
*Papyrus API Evolution Reports: [[Papyrus Developer Guide/API Evolution Reports]]
  
New plugin should follow the submition process describe here: [[Papyrus New Plugin Submition Process|Papyrus New Plugin Submission Process]]
+
[[Category:Papyrus]]

Latest revision as of 11:09, 19 November 2020

Development Environment

To ease the development of Papyrus, each member of the team works with basically the same configuration. There are two ways to get your development environment:

  • downloading and installing Eclipse
  • using the Eclipse Installer (by Oomph) to manage your Papyrus development workbench.

Java Version

OpenJDK 11 (or higher) is recommended.

Downloading Eclipse

You can download a fresh Eclipse Package release on this page. We advise you to download the Eclipse Committer version.

Papyrus Oomph Setup Model

The Eclipse Installer provides a set-up model for Papyrus, making it easier than ever to get a complete Eclipse workbench up and running for development on the Papyrus source code. Just download the Oomph Installer from the linked wiki page and follow the simple wizard to create your IDE and import the Papyrus source projects that you want to work on.

Pick any product you like on the first page, but be sure it's the latest release of that product for the Papyrus stream you're working on. For example, if you're working on the Luna service stream of Papyrus, you need the Luna release of Eclipse. On the second page, expand Eclipse.org / Papyrus to see the various components that you can import to work on. Pick any combination of the leaf-level sub-(sub-)projects, even all of them if you like. In the third page where you specify variables such as install location, workspace location, git clone, etc. be sure to choose "Luna" for the Target Platform. This ensures that you will be set up to work on Papyrus Luna (SR1), which is the only development stream currently supported by the setup model (until Mars development gets under way).

Contributing your changes is easy because Oomph will clone the Papyrus Git repository for you and configure Gerrit push.

Amongst possibly other details, the setup model configures:

  • your IDE with all of the tools needed to edit and build the source projects you choose
  • your workspace with a Git clone and the source projects imported from it that you choose
  • a PDE target that includes all of the dependencies required by Papyrus plus the latest nightly build of Papyrus, itself, so that you can import only a subset of the (many) source projects but still run the complete Papyrus toolset in a run-time workbench
  • Mylyn queries for current open bugs and enhancements in the Papyrus bugzilla database
  • Mylyn queries for the status of the latest Papyrus automated builds, including tests
  • Mylyn queries for open Gerrit reviews
  • preferences enforcing the Papyrus standard compiler and code formatter/template settings

Please report bugs if you see any problems in the setup configuration.

Follow the following link for a step by step installation guide: Oomph setup guide

Installation Details

Following is a description of the basic configuration:

  • The latest Eclipse release pertinent to your use-cases (Modeling, Committer, java, etc)
  • the Papyrus release (matching your Eclipse version), installed from the relevant Papyrus update site
    • Papyrus SDK
    • Papyrus Toolsmiths
    • Papyrus Releng Tools
    • Papyrus User Examples

Additional Useful Tools

  • JAutoDoc
  • install the source version of the Papyrus dependencies (EMF, GMF, MWE2, XTEND, XTEXT, UML2, UML2 Extender SDK) (relevant to your usecases)

Configuration

  • Configure the header template according to your company: Eclipse Preferences -> Java -> JAutodoc
  • Configure your Eclipse.ini file adding this line in the vmargs:
-Duser.name=FirstName LastName (Company) <user@email>
  • Java 11:
    • Eclipse Preferences -> Java -> Compiler
    • Eclipse Preferences -> Java -> Installed JREs
    • VM Arguments for debug mode:
-Dosgi.requiredJavaVersion=11 -Xms768m -Xmx1024m -XX:+CMSClassUnloadingEnabled

Gerrit Configuration

API Management Configuration

There are two way to manage your code version:

Apply Papyrus Configuration Files

Papyrus provides configuration files for Template, CleanUp, and Format for java code. Register these files into your Eclipse Preferences. The Papyrus Code Templates, Java Cleanup and Java Formatter files are available under the Papyrus repository in the folder releng/templates/ and should be used for all your development on Papyrus.

FAQ How do I control the Java formatter

FAQ How can templates make me the fastest coder ever

The note explains how to install the templates in your environment.

How To ...

Each developer must follow the following rule in addition to the aforementioned Developer Charter.

Clone Papyrus Git Repository

The Papyrus code and its documentations are located in a Git repository. In the website http://git.eclipse.org/c/papyrus/org.eclipse.papyrus.git you will find the most recent activity information of the repository and, at the bottom of the page, you will find the URIs of the Git repository (e.g., http://git.eclipse.org/gitroot/papyrus/org.eclipse.papyrus.git).

Follow this quick tutorial if you never used Git before and want to know how to import the source files of one or more Papyrus plugins in your Eclipse workspace.

Code Contributions and Reviews

Papyrus Plug-ins and Features

Release Engineering

Contributing To The Plan For The Release

Release Process

API Evolution

Back to the top