Skip to main content
Jump to: navigation, search

Difference between revisions of "PTP/installjava"

< PTP
(Installing Java for use with Eclipse)
(Installing Java for use with Eclipse)
 
(4 intermediate revisions by 2 users not shown)
Line 2: Line 2:
 
* Eclipse needs at least a Java Runtime Engine (JRE) to function.
 
* Eclipse needs at least a Java Runtime Engine (JRE) to function.
 
** You need the Sun or IBM versions of Java (not Linux's GCJ)
 
** You need the Sun or IBM versions of Java (not Linux's GCJ)
** Java 1.5 or higher is needed.  (Note that "Java 1.5" is the same as "JRE 5.0")
+
** As of Eclipse Luna and PTP 8.0, Java 1.7 or higher is needed.  (Note that "Java 1.7" is the same as "JRE Version 7")
 
** See [http://wiki.eclipse.org/FAQ_Where_do_I_get_and_install_Eclipse%3F Eclipse installation FAQ] under "Installing Java" for more information.   
 
** See [http://wiki.eclipse.org/FAQ_Where_do_I_get_and_install_Eclipse%3F Eclipse installation FAQ] under "Installing Java" for more information.   
** Quick link: [http://www.oracle.com/technetwork/java/javase/downloads/index-jdk5-jsp-142662.html JRE 5.0] will probably work fine.
+
** Quick link: [http://java.com java.com from Oracle]
  
  
  
Ensure that a Java Runtime Environment (JRE) version 1.5 or higher is installed. This can be done with the command:
+
Ensure that a Java Runtime Environment (JRE) version 1.7 or higher is installed. This can be done with the command:
  
 
     java -version
 
     java -version
Line 15: Line 15:
  
 
OpenJDK has not been tested extensively but it ''should'' work.
 
OpenJDK has not been tested extensively but it ''should'' work.
 +
* We have at least one report that Eclipse 3.7 (the previous 2011 version of Eclipse, a.k.a. Indigo) works with OpenJDK 1.6.0_22 successfully

Latest revision as of 11:48, 11 July 2014

Installing Java for use with Eclipse

  • Eclipse needs at least a Java Runtime Engine (JRE) to function.
    • You need the Sun or IBM versions of Java (not Linux's GCJ)
    • As of Eclipse Luna and PTP 8.0, Java 1.7 or higher is needed. (Note that "Java 1.7" is the same as "JRE Version 7")
    • See Eclipse installation FAQ under "Installing Java" for more information.
    • Quick link: java.com from Oracle


Ensure that a Java Runtime Environment (JRE) version 1.7 or higher is installed. This can be done with the command:

   java -version

An IBM, Sun, or equivalent JRE is required; The gcj-based Java shipped with most Linux distributions does not work with Eclipse. If in doubt, run the above command and check if there is a reference to gcj. If you are using the Linux operating system, download and install either the Sun Java Runtime Environment or the IBM Java Runtime Environment.

OpenJDK has not been tested extensively but it should work.

  • We have at least one report that Eclipse 3.7 (the previous 2011 version of Eclipse, a.k.a. Indigo) works with OpenJDK 1.6.0_22 successfully

Back to the top