Skip to main content
Jump to: navigation, search

OM2M/Download

In this tutorial, you can download already built OM2M binaries or learn how to build OM2M from source code by yourself using command line or Eclipse.

Prerequisites

  • JAVA 1.7 or later is required to run OM2M.
  • Apache Maven 3 or later is required to build OM2M.

Download already built OM2M binaries

  • Download OM2M binaries from this link: OM2M.zip.
  • Extract the archive. You will find the NSCL and GSCL products.
  • Use start.bat for windows or start.sh for linux to start NSCL and GSCL. (JAVA 1.7 is required to run OM2M)

Clone and build OM2M using Command line

Clone OM2M using command line

  • Clone the OM2M project using git with the following command:
git clone http://git.eclipse.org/gitroot/om2m/org.eclipse.om2m.git

Add required libraries

(This step will be removed when all third libraries are validated by Eclipse)

  • To help you take advantage of the OM2M platform, we decided to provide the source code and ask you to manually add libraries currently being validated by Eclipse:
  • Download required libraries from this link: OM2M-libs.rar
  • Extract OM2M-libs and copy the following libraries to "org.eclipse.om2m" repository as follows:
    • "db4o-core-java5-8.1-SNAPSHOT.jar" library under "org.eclipse.om2m.core\libs"
    • "obix.jar" library under "org.eclipse.om2m.commons\libs"
    • "xsd" folder under "org.eclipse.om2m.commons\src\main\resources"

build OM2M using command line

  • Apache Maven 3 is required to build OM2M.
  • Got to the "org.eclipse.om2m" directory.
  • Build OM2M using the following command: (An internet connection is required to download dependencies)
mvn clean install
  • Two Eclipse products will be generated after a successful built:
    • The NSCL product can be found on this directory: "om2m/org.eclipse.om2m/org.eclipse.om2m.site.nscl/target/products/nscl/<os>/<ws>/<arch>"
    • The GSCL product can be found on this directory: "om2m/org.eclipse.om2m/org.eclipse.om2m.site.gscl/target/products/gscl/<os>/<ws>/<arch>"
  • You can also import the "org.eclipse.om2m" project as maven project in the Eclipse RPC IDE, and use Eclipse maven tools to build the OM2M platform.

Clone and build OM2M using Eclipse IDE

Install Eclipse IDE

Configure Maven Proxy (Only if requried)

If you are required to use a proxy server to access the Internet, then you have to configure maven proxy settings as follows:

  • Select Window -> Preferences -> Maven -> User settings
  • You will find the warning message "settings.xml file doesn't exist" .
  • Move to the .m2 directory location and create the settings.xml file and put this snippet.
<settings>
  <proxies>
   <proxy>
      <active>true</active>
      <protocol>http</protocol>
      <host>proxy-host</host>
      <port>proxy-port</port>
    </proxy>
  </proxies>
</settings>

Install Tycho plugin

Tycho quick install using Eclipse Maven Marketplace

  • Click Window -> Preferences -> maven -> discovery -> open catalog and type Tycho. Check the “Tycho Configurator” checkbox.
Eclipse Maven marketplace

Tycho Manual install using the Eclipse Update repository (Only if requried)

It happens that the Tycho plugin do not appears in the Eclipse Maven marketplace, then you have to install it manually using the following steps

  • Select Help -> Install New Software.
  • Click on the Add button.
Tycho install
Tycho install
  • Select the "Tycho Project Configurators" and click on Next.
Tycho install
  • Accept the terms of use and click on Finish.
  • Update your project: Select the package "org.eclipse.om2m" -> right click -> maven -> update Project.

Clone OM2M using Eclipse

  • Select Windiow->Show View -> Other .
  • In the dialog box, select the Git view.
  • Click on “Clone a Git repository”.
Git clone
  • In the second page, keep the “master” branch checkbox selected and click Next.
Git clone
  • In the third page, check the “import all existing projects after clone finishes” and click “Finish”.
Git clone
  • The OM2M project is now cloned and is visible on the Git repositories’ and Package’ explorers.

Add required libraries

(This step will be removed when all third libraries are validated by Eclipse)

  • To help you take advantage of the OM2M platform, we decided to provide the source code and ask you to manually add libraries currently being validated by Eclipse:
  • Download required libraries from this link: OM2M-libs.rar
  • Extract OM2M-libs and copy the following libraries to "org.eclipse.om2m" repository as follows:
    • "db4o-core-java5-8.1-SNAPSHOT.jar" library under "org.eclipse.om2m.core\libs"
    • "obix.jar" library under "org.eclipse.om2m.commons\libs"
    • "xsd" folder under "org.eclipse.om2m.commons\src\main\resources"
  • After adding the required librairies, update the org.eclipse.om2m package. To do so, select the package "org.eclipse.om2m" -> right click -> maven -> update Project.

Build OM2M using Eclipse

  • Select “org.eclipse.om2m” package and right click. Select “Run as -> maven install”.
  • Two Eclipse products will be generated after a successful built:
    • The NSCL product can be found on this directory: "om2m/org.eclipse.om2m/org.eclipse.om2m.site.nscl/target/products/nscl/<os>/<ws>/<arch>"
    • The GSCL product can be found on this directory: "om2m/org.eclipse.om2m/org.eclipse.om2m.site.gscl/target/products/gscl/<os>/<ws>/<arch>"

Test OM2M

  • JAVA 1.7 is required to run OM2M.
  • Go to the NSCL product directory: "om2m/org.eclipse.om2m/org.eclipse.om2m.site.nscl/target/products/nscl/<os>/<ws>/<arch>".
  • Start the NSCL directly by executing the nscl native launcher. The executable file is called "nscl.exe" on windows, and is called "nscl" on Linux and Mac OS.
  • You can also start the NSCL by invoking the JVM manually as follows:
java -jar -ea -Declipse.ignoreApp=true -Dosgi.clean=true -Ddebug=true plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar -console -noExit 
  • Once the NSCL is started, you will see an OSGi console. You can type “ss” to report a summary status of all installed bundles. Type "exit" to shutdown.
NSCL OSGi console
  • Open your browser and connect to the address "127.0.0.1:8080" to access the NSCL web interface.
  • Enter username "admin" and password "admin" then click on login button to display the NSCL resource tree.
NSCL web interface: authentication
  • After a successful authentication, the NSCL resource will be displayed. You can see the "nscl" SclBase sub-resources and attributes.
NSCL web interface: nscl sclBase resource
  • Congratulation !! You built and started OM2M successfully.

Back to the top