Skip to main content
Jump to: navigation, search

OM2M/Download

< OM2M
Revision as of 06:21, 9 February 2015 by Benalaya.sensinov.com (Talk | contribs) (Configure Maven Proxy (If requried))

In this tutorial, you can download already built OM2M binaries or learn how to build OM2M from source code by yourself using command line or Eclipse.

Download already built OM2M binaries

  • Download OM2M binaries from this link: OM2M.zip.
  • Extract the archive. You will find the NSCL and GSCL products.
  • Use start.bat for windows or start.sh for linux to start NSCL and GSCL. (JAVA 1.7 is required to run OM2M)

Build OM2M from source code using Command line

Clone OM2M project

  • Clone the OM2M project using git with the following command:
git clone http://git.eclipse.org/gitroot/om2m/org.eclipse.om2m.git

Add required libraries

(This step will be removed when all third libraries are validated by Eclipse)

  • To help you take advantage of the OM2M platform, we decided to provide the source code and ask you to manually add libraries currently being validated by Eclipse:
  • Download required libraries from this link: OM2M-libs.rar
  • Extract OM2M-libs and copy the following libraries to "org.eclipse.om2m" repository as follows:
    • "db4o-core-java5-8.1-SNAPSHOT.jar" library under "org.eclipse.om2m.core\libs"
    • "obix.jar" library under "org.eclipse.om2m.commons\libs"
    • "xsd" folder under "org.eclipse.om2m.commons\src\main\resources"

Build OM2M using maven command line

  • Apache Maven 3 is required to build OM2M.
  • Got to the "org.eclipse.om2m" directory.
  • Build OM2M using the following command: (An internet connection is required to download dependencies)
mvn clean install
  • Two Eclipse products will be generated after a successful built:
    • The NSCL product can be found on this directory: "om2m/org.eclipse.om2m/org.eclipse.om2m.site.nscl/target/products/nscl/<os>/<ws>/<arch>"
    • The GSCL product can be found on this directory: "om2m/org.eclipse.om2m/org.eclipse.om2m.site.gscl/target/products/gscl/<os>/<ws>/<arch>"
  • You can also import the "org.eclipse.om2m" project as maven project in the Eclipse RPC IDE, and use Eclipse maven tools to build the OM2M platform.

Build OM2M using Eclipse IDE

Install Eclipse IDE

  • Eclipse kepler (for RCP and RAP Developers).

Configure Maven Proxy (If requried)

If you are required to use a proxy server to access the Internet, then you have to configure maven proxy settings as follows:

  • Select Window -> Preferences -> Maven -> User settings
  • You will find the warning message "settings.xml file doesn't exist" .
  • Move to the .m2 directory location and create the settings.xml file and put this snippet.
<settings>
  <proxies>
   <proxy>
      <active>true</active>
      <protocol>http</protocol>
      <host>proxy-host</host>
      <port>proxy-port</port>
    </proxy>
  </proxies>
</settings>

Install Tycho plugin

  • Click Window -> Preferences -> maven -> discovery -> open catalog and type Tycho. Check the “Tycho Configurator” checkbox.
Maven marketplace

If the tycho plugin wasn't available on the Maven marketplace, you can install it manually. To do this, follow these steps:

  • Select Help -> Install New Software.
  • Click on the Add button.
Tycho install
Tycho install
  • Select the "Tycho Project Configurators" and click on Next.
Tycho install
  • Accept the terms of use and click on Finish.
  • Update your project: Select the package "org.eclipse.om2m" -> right click -> maven -> update Project.

Clone the OM2M project

  • Select Windiow->Show View -> Other .
  • In the dialog box, select the Git view.
  • Click on “Clone a Git repository”.
Git clone
  • In the second page, keep the “master” branch checkbox selected and click Next.
Git clone
  • In the third page, check the “import all existing projects after clone finishes” and click “Finish”.
Git clone
  • The OM2M project is now cloned and is visible on the Git repositories’ and Package’ explorers.
  • Now we will add the required libraries. This step will be removed when all third libraries will be validated by Eclipse.
  • Download the libraries from this link: http://wiki.eclipse.org/OM2M/Download
  • Extract OM2M-libs and add the following libraries to "org.eclipse.om2m" repository as follows:
    • "db4o-core-java5-8.1-SNAPSHOT.jar" library under "org.eclipse.om2m.core\libs",
    • "obix.jar" library under "org.eclipse.om2m.commons\libs",
    • "xsd" folder under "org.eclipse.om2m.commons\src\main\resources".
  • After adding the required librairies, update the org.eclipse.om2m package. To do so, select the package "org.eclipse.om2m" -> right click -> maven -> update Project.

Build OM2M using Eclipse IDE

  • Select “org.eclipse.om2m” package and right click. Select “Run as -> maven install”.
  • Two Eclipse products will be generated after a successful built:
    • The NSCL product can be found on this directory: "om2m/org.eclipse.om2m/org.eclipse.om2m.site.nscl/target/products/nscl/<os>/<ws>/<arch>"
    • The GSCL product can be found on this directory: "om2m/org.eclipse.om2m/org.eclipse.om2m.site.gscl/target/products/gscl/<os>/<ws>/<arch>"

Back to the top