Skip to main content
Jump to: navigation, search

Difference between revisions of "OM2M/Developer"

(Convert the plugin into maven project)
(Add the plugin as a maven module to the OM2M parent project)
Line 71: Line 71:
 
=== Add the plugin as a maven module to the OM2M parent project ===
 
=== Add the plugin as a maven module to the OM2M parent project ===
  
In this part, we will add the created plug-in as a module to the om2m platform:
+
* In this part, we will add the created plug-in as a module to the om2m platform:
# Open the pom file of the ''org.eclipse.om2m'' package.  
+
** Open the pom file of the ''org.eclipse.om2m'' package.  
# Go to the ''modules'' tab and press ''Add'' button.
+
** Go to the ''modules'' tab and press ''Add'' button.
# Select the org.eclipse.ipu.om2m.sample.ipu plug-in and press ''ok''.
+
** Select the org.eclipse.ipu.om2m.sample.ipu plug-in and press ''ok''.
# Build the om2m package and its sub-projects. To do this, select the "om2m.org.eclipse" package → right click → Run as → maven install.  
+
** Build the om2m package and its sub-projects. To do this, select the "om2m.org.eclipse" package → right click → Run as → maven install.  
# Check the org.eclipse.om2m.sample.ipu was successfully built. At the buid end, we should get this result.  
+
** Check the org.eclipse.om2m.sample.ipu was successfully built. At the buid end, we should get this result.  
 
[[File:build.png|thumb|center|600px|om2m build]]
 
[[File:build.png|thumb|center|600px|om2m build]]
  
Remark: To keep the same display pattern for all the platform' plugins, you can add ''description'' and ''name'' tags to the  ''org.eclipse.om2m.sample.ipu''' ''pom.xml'' file.  
+
*Remark: To keep the same display pattern for all the platform' plugins, you can add ''description'' and ''name'' tags to the  ''org.eclipse.om2m.sample.ipu''' ''pom.xml'' file.  
 
<pre>
 
<pre>
 
<project>
 
<project>

Revision as of 08:29, 5 September 2014

Prerequisite

  • Eclipse kepler (for RCP and RAP Developers).

Build OM2M from source using Eclipse

Clone The OM2M project

  • Select Windiow->Show View -> Other .
  • In the dialog box, select the Git view.
  • Click on “Clone a Git repository”.
Git clone
  • In the second page, keep the “master” branch checkbox selected and click Next.
Git clone
  • In the third page, check the “clone submodules” and “import all existing projects after clone finishes” and click “Finish”.
Git clone
  • The OM2M project is now cloned and is visible on the Git repositories’ and Package’ explorers.
  • Now we will add the required libraries. This step will be removed when all third libraries will be validated by Eclipse.
  • Download the libraries from this link: http://wiki.eclipse.org/OM2M/Download
  • Extract OM2M-libs and add the following libraries to "org.eclipse.om2m" repository as follows:
    • "db4o-core-java5-8.1-SNAPSHOT.jar" library under "org.eclipse.om2m.core\libs",
    • "obix.jar" library under "org.eclipse.om2m.commons\libs",
    • "xsd" folder under "org.eclipse.om2m.commons\src\main\resources".

Build OM2M using maven

  • Before building the OM2M project, you need to add “Tycho” to Maven eclipse plug-in. To do so, click Window -> Preferences -> maven -> discovery -> open catalog and type Tycho. Check the “Tycho Configurator” checkbox.
Git clone
  • Select “org.eclipse.om2m” package and right click. Select “Run as -> maven install”.
  • Two Eclipse products will be generated after a successful built:
    • The NSCL product can be found on this directory: "om2m/org.eclipse.om2m/org.eclipse.om2m.site.nscl/target/products/nscl/<os>/<ws>/<arch>"
    • The GSCL product can be found on this directory: "om2m/org.eclipse.om2m/org.eclipse.om2m.site.gscl/target/products/gscl/<os>/<ws>/<arch>"

Develop a new plug-in

Create a new plug-in project

  • Create a new plug-in project called org.eclipse.om2m.sample.ipu via File → New → Other → Plug-in Project.
  • Enter the data as depicted in the following screenshots.
create a plug-in project: step 1
create a plug-in project: step 2
  • Uncheck the Create a plug-in using one of the templates checkbook and press the Finish button.
create a plug-in project: step 3
  • As result the following project is created.
sample ipu plug-in

Convert the plugin into maven project

  • Open the build.properties file in XML and update the src attributes as depicted in the following figure.
build-properties build
  • Select the created plug-in "org.eclipse.om2m.sample.ipu" → right click → configure → maven to maven project.
  • Enter the data as illustrated in the following and press the Finish button.
maven conversion: POM edition
  • Once the plug-in is converted, open the pom.xml file to edit the parent filed.
  • Click on "select Parent" icon and enter "org.eclipse.om2m" in the "Enter groupId, artifactId or sh1 prefix or pattern" field.
  • Select "org.om2m.eclipse" and press ok.
maven conversion: Parent edition
  • We end this step by updating the plug-inf project. For this, select the "org.eclipse.om2m.sample.ipu" project → maven → update project.

Add the plugin as a maven module to the OM2M parent project

  • In this part, we will add the created plug-in as a module to the om2m platform:
    • Open the pom file of the org.eclipse.om2m package.
    • Go to the modules tab and press Add button.
    • Select the org.eclipse.ipu.om2m.sample.ipu plug-in and press ok.
    • Build the om2m package and its sub-projects. To do this, select the "om2m.org.eclipse" package → right click → Run as → maven install.
    • Check the org.eclipse.om2m.sample.ipu was successfully built. At the buid end, we should get this result.
om2m build
  • Remark: To keep the same display pattern for all the platform' plugins, you can add description and name tags to the org.eclipse.om2m.sample.ipu' pom.xml file.
<project>
......
  <name>org.eclipse.om2m :: sample ipu</name>
  <description>org.eclipse.om2m :: sample ipu</description>
.....
</project>

Add the plugin to the OM2M product(s)

The final step consists of adding the created plug-in to one of om2m platform products, i.e the gscl or the nscl executable. In the following, we choose to add the org.eclipse.om2m.sample.ipu plug-in to the gscl product:

  1. select the org.eclipse.om2m.site.gscl package.
  2. open the om2m.product file.
  3. Press Add button and Type org.eclipse.om2m.sample.ipu
  4. Click on ok button and save.
  5. Build the om2m package and its sub-projects: select the "om2m.org.eclipse" package ? right click ? Run as ? maven install.
  6. To check that the "org.eclipse.om2m.sample.ipu" was successfully added to the gscl product, run the gscl and verify in the console if the "org.eclipse.om2m.sample.ipu" is displayed.
gscl product

Back to the top