Skip to main content
Jump to: navigation, search

Difference between revisions of "OM2M/Developer"

(Create the interworking proxy unit plug-in)
(Create the interworking proxy unit plug-in)
Line 52: Line 52:
 
* The maven conversion,
 
* The maven conversion,
 
* The addition of the created plug-in to a parent project,
 
* The addition of the created plug-in to a parent project,
* Enabling an automatic build,
 
 
* Including the created plug-in to om2m platform' product(s).  
 
* Including the created plug-in to om2m platform' product(s).  
 
   
 
   
Line 110: Line 109:
 
# Click on ok button and save.  
 
# Click on ok button and save.  
 
# Build the om2m package and its sub-projects: select the "om2m.org.eclipse" package → right click → Run as → maven install.
 
# Build the om2m package and its sub-projects: select the "om2m.org.eclipse" package → right click → Run as → maven install.
 +
# To check that the "org.eclipse.om2m.sample.ipu" was successfully added to the gscl product, run the gscl and verify in the console if the "org.eclipse.om2m.sample.ipu" is displayed.
 +
[[File:run.png|thumb|center|600px|gscl product]]
  
 
==== Develop the monitor’ interworking unit  plug-in ====
 
==== Develop the monitor’ interworking unit  plug-in ====

Revision as of 14:58, 3 August 2014

Prerequisite

Build OM2M from source: step by step

Download OM2M source code

  • Select Windiow->Show View -> Other .
  • In the dialog box, select the Git view.
  • Click on “Clone a Git repository”.
Git clone
  • In the second page, keep the “master” branch checkbox selected and click Next.
Git clone
  • In the third page, check the “clone submodules” and “import all existing projects after clone finishes” checkboxes and click “Finish”.
Git clone
  • The OM2M project is now cloned and is visible on the Git repositories’ and Package’ explorers.
Git clone
  • Now we will add the required libraries. This step will be removed when all third libraries will be validated by Eclipse.
  • Download the libraries from this link: http://wiki.eclipse.org/OM2M/Download
  • Extract OM2M-libs and add the following libraries to "org.eclipse.om2m" repository as follows:
    • "db4o-core-java5-8.1-SNAPSHOT.jar" library under "org.eclipse.om2m.core\libs",
    • "obix.jar" library under "org.eclipse.om2m.commons\libs",
    • "xsd" folder under "org.eclipse.om2m.commons\src\main\resources".

Build OM2M using maven

  • Before building the OM2M project, you need to add “Tycho” to Maven plugin. (Why? more details) To do so, click Window -> Preferences -> maven -> discovery -> open catalog and type Tycho. Check the “Tycho Configurator” checkbox.
Git clone
  • Select “org.eclipse.om2m” package and right click. Select “Run as -> maven install”.
  • Two Eclipse products will be generated after a successful built:
    • The NSCL product can be found on this directory: "om2m/org.eclipse.om2m/org.eclipse.om2m.site.nscl/target/products/nscl/<os>/<ws>/<arch>"
    • The GSCL product can be found on this directory: "om2m/org.eclipse.om2m/org.eclipse.om2m.site.gscl/target/products/gscl/<os>/<ws>/<arch>"


Develop your interworking proxy unit plug-in

We will start this section by demonstring how to create a plug-in in eclipse and associate it to the om2m platform. Then, we will implement the created plug-in, named "interworking proxy", by adding a MonitorSample class to simulate a sensor behavior and a ControllerSample class to manage a simulated actuator.

Create the interworking proxy unit plug-in

To create the interworking proxy plug-in, we will follow these steps:

  • The plug-in project creation,
  • The maven conversion,
  • The addition of the created plug-in to a parent project,
  • Including the created plug-in to om2m platform' product(s).
Step 1: The plug-in project creation

Create a new plug-in project called org.eclipse.om2m.sample.ipu via File → New → Other → Plug-in Project. Enter the data as depicted in the following screenshots.

create a plug-in project: step 1
create a plug-in project: step 2

Uncheck the Create a plug-in using one of the templates checkbook and press the Finish button.

create a plug-in project: step 3

As result the following project is created.

sample ipu plug-in


 Step 2: The maven conversion

Once the sample.ipu plug-in created, we will convert it to a maven project. Before that, we will open the build.properties file in XML and update the src attributes as depicted in the following figure.

build-properties build

Select the created plug-in "org.eclipse.om2m.sample.ipu" → right click → configure → maven to maven project. Enter the data as illustrated in the following and press the Finish button.

maven conversion: POM edition

Once the plug-in is converted, open the pom.xml file to edit the parent filed. For this, click on "select Parent" icon and insert "org.eclipse.om2m" in the "Enter groupId, artifactId or sh1 prefix or pattern" field. Select the found jar and press ok.

maven conversion: Parent edition

We end this step by updating the plug-inf project. For this, select the "org.eclipse.om2m.sample.ipu" project → maven → update project.

 Step 3: The addition of the created plug-in to a parent project

In this part, we will add the created plug-in as a module to the om2m platform. For this, we will follow these steps:

  1. Open the pom file of the org.eclipse.om2m package.
  2. Go to the modules tab and press Add button.
  3. Select the org.eclipse.ipu.om2m.sample.ipu plug-in and press ok.
  4. Build the om2m package and its sub-projects. To do this, select the "om2m.org.eclipse" package → right click → Run as → maven install.
  5. Check the org.eclipse.om2m.sample.ipu was successfully built. At the buid end, we should get this result.
om2m build

Remark: To keep the same display pattern for all the platform' plugins, you can add description and name tags to the org.eclipse.om2m.sample.ipu' pom.xml file.

<project>
......
  <name>org.eclipse.om2m :: sample ipu</name>
  <description>org.eclipse.om2m :: sample ipu</description>
.....
</project>

Step 4: Including the created plug-in to om2m platform' product(s)

The final step consists of adding the created plug-in to one of om2m platform products, i.e the gscl or the nscl executable. In the following, we choose to add the org.eclipse.om2m.sample.ipu plug-in to the gscl product. To do so, follow these steps:

  1. select the org.eclipse.om2m.site.gscl package.
  2. open the om2m.product file.
  3. Press Add button and Type org.eclipse.om2m.sample.ipu
  4. Click on ok button and save.
  5. Build the om2m package and its sub-projects: select the "om2m.org.eclipse" package → right click → Run as → maven install.
  6. To check that the "org.eclipse.om2m.sample.ipu" was successfully added to the gscl product, run the gscl and verify in the console if the "org.eclipse.om2m.sample.ipu" is displayed.
gscl product

Develop the monitor’ interworking unit plug-in

Develop the controller’ interworking unit plug-in

Test Scenario

Back to the top