Skip to main content
Jump to: navigation, search

Modeling Ganymede M6 Review

Revision as of 11:59, 13 May 2008 by Richard.gronback.borland.com (Talk | contribs) (UML Modeling)

This wiki page contains the result of the Ganymede M6 Modeling Package review.

Platform: Mac OS X

Installation

  • 153MB download extracts to 183MB on disk
  • Not all features have generated qualifiers, notably: EMF, XSD, UML2, UML2 Tools, and GMF (only the *.tooling.source feature, oddly enough)
  • Not all plug-ins are signed 227333 Fixed in M7
  • Not all sources are packaged in the new method

Startup

  • EPP usage data gathering exception on startup Fixed in M7
  • Standard Eclipse splash and welcome page (should be updated with Modeling project artwork?)
  • Initial perspective is Java (should be an AmalgamModelingPerspective?)
  • Installed Features list shows missing localization strings for *.m2m.qvt.oml source features Not in dialog in M7
  • About dialog: all are using proper modeling image, though some issues:
    • GMF and UML2 Tools (documentation only) features missing buildId token replacement (shows @buildId@) 231420 Fixed post-M7
    • Plug-in org.eclipse.gmf.graphdef.edit shows provider as www.example.org and not Eclipse.org
    • All *.m2m.qvt.oml source plug-ins show provider as providerName and not Eclipse.org Not in dialog in M7
    • UML2 Tools diagram plug-in naming scheme is inconsistent (Activity, Deployment, and Use Case should be prefixed with 'UML2' as are the rest)

User Interface Contributions

  • Preferences
    • UML2 diagrams each have a root category, but would be better under a common 'UML Diagrams' root 226663 Fixed in M7
  • Menus
    • Operational QVT Transformation & Library actions available on New menu within Package Explorer view of Java perspective (appropriate?)
    • A Run -> Transformation... top-level menu item is available in all perspectives
  • New Dialog
    • Eclipse Modeling Framework > EMF Model wizard would be more appropriately named 'EMF Generator Model'
    • Eclipse Modeling Framework category contains no wizard to create a new Ecore model (found in Example EMF Model Creation Wizards category only)
    • UML Model wizard found in Example EMF Model Creation Wizards category, with UML2 Tools diagrams found in UML 2.1 Diagrams category. Why not have both in general 'UML 2.1 Modeling' category?
    • Operational QVT example view, constraints, datatypes, rdb, and simpleuml models are available in EMF Model Creation Wizards category. Move to Operational QVT category below Examples?
    • Ecore Diagram is in the Other category. With the Ecore Tools project available, and as this remains a GMF example, it should be moved to the Examples category?
    • GMF-Xpand top-level category will eventually go away, but for now more appropriate under the existing Graphical Modeling Framework category?
    • GMF wizard names could use some improvement. How about:
      • New GMF Project -> GMF Project (strike the 'New' as it's redundant with dialog purpose and matches EMF counterpart upon which it's based)
      • Simple Graphical Definition Model -> Graphical Definition Model from Domain
      • Simple Tooling Definition Model -> Tooling Definition Model from Domain
      • Reconcile Graphical Definition Model -> Reconcile a Graphical Definition Model
      • Reconcile Tooling Definition Model -> Reconcile a Tooling Definition Model
      • Guide Mapping Model Creation -> Mapping Definition Model from Domain
      • Default subcategory -> Basic
      • GMFGen Model -> Generator Model
      • GMFGraph Model -> Graphical Definition Model
      • GMFMap Model -> Mapping Definition Model
      • GMFTool Model -> Tooling Definition Model
    • Java Emitter Templates category has no wizard to create new JET Template? (seems odd)
  • Show View dialog
    • GMF Dashboard is found in the General category. Perhaps add a Graphical Modeling Framework category? The dashboard is not very 'general'
    • The Operational QVT category has a Metamodel Explorer view, which is fine. As this view is not really QVT specific, but rather a general view for registered metamodels, perhaps it belongs in EMF itself?

UML Modeling

Not looking for usability issues with the diagrams themselves, a few items stand out when creating and working with UML diagrams:

  • When creating a new diagram, several !MESSAGE NLS unused message log entries are made 230847 Fixed in M7
  • The file extension for UML diagrams are rather long. Perhaps an abbreviated form would be better, e.g. *.ucd instead of *umlclass_diagram? Or, even just *.umlclass without _diagram would be better 230873.
  • Each of the right-click actions for creating a new UML diagram for a *.uml model file are also quite long. Perhaps something like "Create UML Class Diagram" instead of "Initialize umlclass_diagram diagram file" would be better? Also, why not have these off the New menu item?
  • Under the *.uml model in the Project Explorer are 5 Package elements for a newly created Class diagram with no content was created, each showing the 4 default Element Imports 221223.
  • UML diagrams need a non-synchronized option, particularly the Class diagram 199731.
  • UML diagram creation wizards should allow you to select an existing *.uml model file and behave similarly to the "Initialize..." menu action, in this case.
  • An error !MESSAGE Invalid preference page path: Icon Style is output. In the Preferences, this option should appear in the root UML Diagrams preference category mentioned above. Fixed in M7

GMF-based Diagrams

  • Perhaps opening the Properties view upon diagram creation is a sensible thing to do? Having the Properties view open within a default Modeling perspective is another way to ensure it's open. Otherwise, a user needs to right-click the diagram and select "Show Properties View"
  • Add a File -> Save as Image... option to the main menu to augment the hard to find diagram right-click File -> Save as Image File... option. Even an Export menu item would be more easily found.

Additional Components

Returning to the ganymede update site to install the remaining components in the Models and Model Development category, the following additional observations were made.

Ecore Tools SDK

  • Installed fine, features/plug-ins look fine (though not signed)
  • Contributes its own perspective (overkill?) with icon that needs transparent background
    • Modeling icon is used (too general?)
    • No default Show View menu contributions, or proper category in Open View dialog (both are in Other)
  • Ecore Tools perspective is Resource perspective + Properties + EClass Hierarchy + EClass References
    • The last two are present and empty until explicitly synchronized with editor (should be default?)
    • Hierarchy doesn't display with menu item or key combination, as expected
    • Reference view doesn't work as expected (outgoing reference on selected class not displayed, though it does when incoming class selected)
    • Menu items for Hierarchy/References available from EMF editor tree and Outline, but not diagram elements?
  • Contributes Ecore Tools project type wizard and nature
    • Project wizard is not associated with perspective (no prompt to open on completion)
    • Can't create new model/diagram when creating project?
  • Contributes Ecore Diagram wizard that creates *.ecore and corresponding *.ecorediag file
  • Form-based properties are available, though excessive vertical spacing between fields
    • Setting EType requires dialog (title is 'Object selection' - perhaps 'Type Selection' is better?)
  • No separate tool for containment reference, as found in GMF Ecore diagram
  • Identical diagram preferences to GMF Ecore diagram example
  • With Ecore Tools and GMF Ecore diagram installed, both contribute Ecore content to generic navigator (duplicates)
  • Outline view has additional domain model tree, duplicating what's in Project Explorer but with different properties provider
    • Additional Resources root provides nice action to invoke Load Resource... but doesn't use the latest dialog from EMF (no Registered models list available)
  • Filter and Validate contributions to main toolbar
    • Error markers appear when validating empty/default diagram
      • Error in Problems view states defaultname.ecorediagram is not well formed (the default is not well formed?)
    • Filter menu is extension of runtime's filter contribution, but not co-located in Filter menu
    • Filter toolbar button is present in GMF toolbar even when GMF Ecore diagram is open, though all items are disabled

EMFT Mint SDK

  • Installed fine, features/plug-ins look fine (though not signed)
  • Help content is empty, and title could be shorter to fit better in Contents
  • TODO: revisit functionality after generating code

EMFT Compare SDK

  • Only source feature shows up in About dialog, though p2 errors in log after install/restart
  • TODO: revisit this component

EMFT Search SDK + UML2 + Ecore

  • Installed fine, though plug-ins not signed
    • org.eclipse.uml2.search.ocl features is named 'Ecore OCL Model Search'
  • No Help contribution?
  • Ecore and GenModel need their own categories in Search dialog?
  • Show Model Result In ... Diagram doesn't open the diagram, though works if already open

ATL SDK

  • Download and installation of features was fine
    • About dialog shows additional Modeling icon, as org.eclipse.m2m.atl feature is by itself 220095
    • org.eclipse.m2m.atl feature and branding plug-in showing 'providerName' and 'pluginName' in About (doc and engine features are fine)
    • Plug-ins are not signed
  • Help contribution limited to javadoc
  • ATL has project type with nature/builder and associated perspective
    • ATL perspective has no views? Is a perspective necessary?
    • Perspective is Resource (using Navigator instead of Project Explorer) + Properties + Console + Error Log
  • ATL Compatibility (2 word) top level menu contribution :(
  • QVTO contributes a general 'Model to Model Transformation' wizard category, while ATL has its own (combine?)

Teneo SDK

  • Installed fine, though missing name strings in UI for Teneo features
    • BuildId = {0} for teneo and teneo.doc features in About dialog (source is OK)
    • Plug-ins not signed

JET SDK

  • Installed fine, plug-ins signed
  • In New dialog, Java Emitter Templates category with conversion wizard, then JET Transformations with JET Project wizard
    • Combine into one? No JET template wizard or editor included?

Back to the top