Skip to main content
Jump to: navigation, search

Difference between revisions of "JDT/Eclipse Java 7 Support (BETA)"

< JDT
Line 3: Line 3:
  
 
#Help &gt; Install New Software...  
 
#Help &gt; Install New Software...  
#enter:
+
#enter into the 'Work with' field:
  - http://build.eclipse.org/eclipse/java7patch/ for 3.7.0 into the 'Work with' field<br>
+
  - http://build.eclipse.org/eclipse/java7patch/ for 3.7.0<br>
  - http://build.eclipse.org/eclipse/java7patch41/ for 4.1.0 into the 'Work with' field
+
  - http://build.eclipse.org/eclipse/java7patch41/ for 4.1.0
 
#press 'Enter'  
 
#press 'Enter'  
 
#select category 'Eclipse Java 7 Support (BETA)'
 
#select category 'Eclipse Java 7 Support (BETA)'

Revision as of 14:58, 23 June 2011

Java 7 is not publicly released yet and hence the Eclipse Java 7 support could not be shipped with 3.7 or 4.1. Those who want to use it in 3.7 or 4.1 can do it using the install instructions below.

  1. Help > Install New Software...
  2. enter into the 'Work with' field:
- http://build.eclipse.org/eclipse/java7patch/ for 3.7.0
- http://build.eclipse.org/eclipse/java7patch41/ for 4.1.0
  1. press 'Enter'
  2. select category 'Eclipse Java 7 Support (BETA)'
  3. for faster install, deselect 'Contact all updates sites during install to find required software'
  4. click 'Next'
  5. click 'Next'
  6. accept the license
  7. click 'Finish'
  8. restart Eclipse when asked

In order to use the batch compiler only, you can follow the steps described at the link Using the batch compiler by replacing org.eclipse.jdt.core_3.4.0<qualifier>.jar with: org.eclipse.jdt.core_3.7.0.v_B63_BETA_JAVA7.jar.

Note: This is an implementation of an early-draft specification developed under the Java Community Process (JCP) and is made available for testing and evaluation purposes only. The code is not compatible with any specification of the JCP.

Copyright © Eclipse Foundation, Inc. All Rights Reserved.