Skip to main content
Jump to: navigation, search

Difference between revisions of "JDT/Eclipse Java 7 Support (BETA)"

< JDT
Line 1: Line 1:
Java 7 is not publicly released yet and hence the Eclipse Java 7 support could not be shipped with 3.7 or 4.1.
+
The Eclipse Java 7 support is no longer in BETA phase. It has been integrated into the existing streams. Those who want to use Java 7 in Eclipse can download a 3.7 maintenance build (>= M20110729-1400), a 3.8 build (>= I20110729-1200), a 4.1.1 (coming in the next days) or a recent 4.2 build (coming in the next days).
Those who want to use it in 3.7 or 4.1 can do it using the install instructions below.
+
 
+
'''Note:''' For those who already installed previous Java 7 patches, you need to first revert to Indigo and then reinstall the newest patch. All patches are based on Indigo features versions (either 3.7 or 4.1).
+
 
+
#Help &gt; Install New Software...
+
#enter into the 'Work with' field:
+
- http://build.eclipse.org/eclipse/java7patch/ for 3.7.0<br>
+
- http://build.eclipse.org/eclipse/java7patch41/ for 4.1.0
+
#press 'Enter'
+
#select category 'Eclipse Java 7 Support (BETA)'
+
#for faster install, deselect 'Contact all updates sites during install to find required software'
+
#click 'Next'
+
#click 'Next'
+
#accept the license
+
#click 'Finish'
+
#restart Eclipse when asked
+
 
+
In order to use the batch compiler only, you can follow the steps described at the link [http://help.eclipse.org/indigo/index.jsp?topic=%2Forg.eclipse.jdt.doc.user%2Ftasks%2Ftask-using_batch_compiler.htm Using the batch compiler], but use the org.eclipse.jdt.core_3.7.0.v_B**_BETA_JAVA7.jar from your updated install or from http://build.eclipse.org/eclipse/java7patch/plugins/.
+
 
+
'''Note:''' This is an implementation of an early-draft specification developed under the Java Community Process (JCP) and is made available for testing and evaluation purposes only. The code is not compatible with any specification of the JCP.
+
 
+
[[Category:JDT]]
+

Revision as of 02:54, 30 July 2011

The Eclipse Java 7 support is no longer in BETA phase. It has been integrated into the existing streams. Those who want to use Java 7 in Eclipse can download a 3.7 maintenance build (>= M20110729-1400), a 3.8 build (>= I20110729-1200), a 4.1.1 (coming in the next days) or a recent 4.2 build (coming in the next days).

Back to the top