Skip to main content
Jump to: navigation, search

Installation steps of Papyrus for Requirements

Revision as of 03:01, 14 April 2017 by Mauricio.alferez.cea.fr (Talk | contribs) (Created page with "= 1. Installation = This installation guide provides instructions on how to install and configure papyrus for requirements. 1.1. Download Papyrus RCP (Neon version) from ht...")

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

1. Installation

This installation guide provides instructions on how to install and configure papyrus for requirements.


1.1. Download Papyrus RCP (Neon version) from https://eclipse.org/papyrus/download.html

1.2. Unzip the downloaded file.

1.3. Open Papyrus by clicking on the file "papyrus.exe".

1.4. Select your workspace

1.6. Install SysML14

1.6.1. Click on "Help" > "Install new software"

1.6.2. Enter the following update site location in the "Work with" field and press "Enter":

http://download.eclipse.org/modeling/mdt/papyrus/components/sysml14

1.6.3. Select "Papyrus SysML 1.4 Feature (Incubation)"

1.6.4. Finish the installation and restart Eclipse.

1.7. Install Papyrus for Requirements

1.7.1. Click on "Help" > "Install new software"

1.7.2. Enter the following update site location in the "Work with" field and press "Enter":

https://hudson.eclipse.org/papyrus/view/Requirements/job/Requirements-Neon/lastSuccessfulBuild/artifact/releng/org.eclipse.papyrus.requirements.p2/target/repository/

1.7.3. If you want to work with SysML 1.4, select all the features except "Papyrus for Requirements based on SysML11 (Incubation)".

1.7.4. Finish the installation and restart Eclipse.

Back to the top