Skip to main content
Jump to: navigation, search

Difference between revisions of "Installation steps of Papyrus for Requirements"

(Created page with "= 1. Installation = This installation guide provides instructions on how to install and configure papyrus for requirements. 1.1. Download Papyrus RCP (Neon version) from ht...")
 
(1. Installation)
Line 1: Line 1:
= 1. Installation =
+
This guide provides instructions on how to install Papyrus for Requirements.
  
This installation guide provides instructions on how to install and configure papyrus for requirements.
+
1. Download Papyrus RCP (Neon version) from https://eclipse.org/papyrus/download.html
  
 +
2. Unzip the downloaded file.
  
1.1. Download Papyrus RCP (Neon version) from https://eclipse.org/papyrus/download.html
+
3. Open Papyrus by clicking on the file "papyrus.exe".
  
1.2. Unzip the downloaded file.
+
4. Select your workspace
  
1.3. Open Papyrus by clicking on the file "papyrus.exe".
+
5. Install SysML14
  
1.4. Select your workspace
+
5.1. Click on "Help" > "Install new software"
  
1.6. Install SysML14
+
5.2. Enter the following update site location in the "Work with" field and press "Enter":   
 
+
1.6.1. Click on "Help" > "Install new software"
+
 
+
1.6.2. Enter the following update site location in the "Work with" field and press "Enter":   
+
  
 
http://download.eclipse.org/modeling/mdt/papyrus/components/sysml14
 
http://download.eclipse.org/modeling/mdt/papyrus/components/sysml14
  
1.6.3. Select "Papyrus SysML 1.4 Feature (Incubation)"
+
5.3. Select "Papyrus SysML 1.4 Feature (Incubation)"
  
1.6.4. Finish the installation and restart Eclipse.  
+
5.4. Finish the installation and restart Eclipse.  
  
1.7. Install Papyrus for Requirements  
+
6. Install Papyrus for Requirements  
  
 
1.7.1. Click on "Help" > "Install new software"  
 
1.7.1. Click on "Help" > "Install new software"  

Revision as of 04:04, 14 April 2017

This guide provides instructions on how to install Papyrus for Requirements.

1. Download Papyrus RCP (Neon version) from https://eclipse.org/papyrus/download.html

2. Unzip the downloaded file.

3. Open Papyrus by clicking on the file "papyrus.exe".

4. Select your workspace

5. Install SysML14

5.1. Click on "Help" > "Install new software"

5.2. Enter the following update site location in the "Work with" field and press "Enter":

http://download.eclipse.org/modeling/mdt/papyrus/components/sysml14

5.3. Select "Papyrus SysML 1.4 Feature (Incubation)"

5.4. Finish the installation and restart Eclipse.

6. Install Papyrus for Requirements

1.7.1. Click on "Help" > "Install new software"

1.7.2. Enter the following update site location in the "Work with" field and press "Enter":

https://hudson.eclipse.org/papyrus/view/Requirements/job/Requirements-Neon/lastSuccessfulBuild/artifact/releng/org.eclipse.papyrus.requirements.p2/target/repository/

1.7.3. If you want to work with SysML 1.4, select all the features except "Papyrus for Requirements based on SysML11 (Incubation)".

1.7.4. Finish the installation and restart Eclipse.

Copyright © Eclipse Foundation, Inc. All Rights Reserved.