Skip to main content
Jump to: navigation, search

Difference between revisions of "ICE Build Instructions"

(Added instructions for the Developer Menu)
Line 4: Line 4:
 
This article assumes that you have already collected the [[Getting_ICE#Prerequisites|ICE third-party dependencies]] and have them in your workspace or stored on your system. All third-party dependencies are required to build ICE from source, unlike the binary distribution of ICE.  Additional dependencies may be required to use certain features of ICE.
 
This article assumes that you have already collected the [[Getting_ICE#Prerequisites|ICE third-party dependencies]] and have them in your workspace or stored on your system. All third-party dependencies are required to build ICE from source, unlike the binary distribution of ICE.  Additional dependencies may be required to use certain features of ICE.
  
''Building ICE from scratch requires access to some test files for its tests to pass. You can either build it without the tests or contact us. Unfortunately we cannot widely distribute these, but if you genuinely need to build ICE from source contact <code>eclipse.ice.project <at> gmail.com</code> for more information.''
+
''Building ICE from scratch requires access to some test files for its tests to pass. You can either build it without the tests by disabling them with Maven or you can check the tests out from https://github.com/jayjaybillings/ICETests. You should clone the tests directly into your home directory using the following command if you are using a shell:''
 +
 
 +
<pre>
 +
git clone https://github.com/jayjaybillings/ICETests
 +
</pre>
  
 
ICE requires Java 1.8 to build and run.
 
ICE requires Java 1.8 to build and run.

Revision as of 15:40, 16 February 2017

We now recommend that all ICE developers hack the code from ICE itself. See Getting ICE to download it.

This article assumes that you have already collected the ICE third-party dependencies and have them in your workspace or stored on your system. All third-party dependencies are required to build ICE from source, unlike the binary distribution of ICE. Additional dependencies may be required to use certain features of ICE.

Building ICE from scratch requires access to some test files for its tests to pass. You can either build it without the tests by disabling them with Maven or you can check the tests out from https://github.com/jayjaybillings/ICETests. You should clone the tests directly into your home directory using the following command if you are using a shell:

git clone https://github.com/jayjaybillings/ICETests

ICE requires Java 1.8 to build and run.

Getting ICE from Git

The first step will be to check ICE out from the Git repository. If you are building ICE using ICE, check it out from Developer > ICE > Clone ICE from the menu bar. If you are using another version of Eclipse you can do it manually. The Git repository is at http://github.com/eclipse/ice.

Open the Git Repositories view (Window > Show View > Other... Expand Git and select Git Repositories.) and choose to clone a repository. Point the wizard to the ICE Git repository, and click Next. The ICE Git repository needs to be cloned into your workspace so that it can run its build properly. If your workspace is at $HOME/workspace, the repository should be cloned into $HOME/workspace/ice as shown in the second picture.

Be sure to check the box that says "Import all existing projects after clone is finished." Selecting this option will automatically import all Eclipse ICE projects into your workspace and save you quite a bit of time by preventing you from having to learn how the repository is organized.

ICEGithubConfig.png ICEGithubLocConfig.png

If you are using a vanilla version of Eclipse for development, all of the projects will show up in your Project Explorer, and most of them will have red error boxes next to them. You will need to load the target platform by opening the org.eclipse.ice.target.mars project, opening the "mars.target" file, and clicking the "Set as target platform" button in the top right of the editor once the platform has resolved. Resolving the platform takes a very long time if you have never done it before, so watch the status bar in the bottom right to monitor its progress.

If you are using ICE to do ICE development, you do not need to resolve the target platform unless you need to make changes to it.

Building ICE Binaries using Maven

ICE is built using the Maven build system and Eclipse Tycho to create binaries for multiple platforms and architectures and to execute the test plugins. The Maven build system can be launched by command line using the mvn command, if it is installed, or from within Eclipse using the m2e Eclipse plugin.

ICE is a big code, so properly building for the first time can be a lengthy process because ICE's dependencies need to be downloaded.

Make sure that you are in the 'next' branch. This should be done automatically if you used the Developer Menu, but if you have [ice master] next to your package names inside Eclipse, then do Window -> Show View -> Other and select Git. Then right click the ice repository and select Switch To... -> New Branch and select next as the source.

In practice, if you are doing development work and don't need to build the binaries, you can just build the bundles and run the tests. It is good practice to build the binaries and run them at least once a day to make sure your code works in the way the user will experience it.

The ICE Development Team builds ICE from both the command line and Eclipse: we build from inside Eclipse while we are developing and before we commit to make sure the tests work, and we use an automated Hudson build that runs hourly on our development server.

To build ICE on the command line, change into the org.eclipse.ice.aggregator directory and run

mvn clean verify

The binaries will be in ice/org.eclipse.ice.repository/target/products within your ICE working copy.

Inside Eclipse

In order to build ICE binaries from Eclipse, you must use the Eclipse plugin for Maven. Once the ICE plugins are checked out from the repository, make sure you can see packages in the Package Explorer. If not, you may not have checked the "Import all existing projects after clone is finished" box when cloning ICE. You can import the projects from the Git perspective by right-clicking on the ICE repository and selecting "Import Projects".

Build and Test the ICE Bundles

You can build and test ICE by simply selecting Developer -> ICE -> build. For better control over the build process, we can create a custom run configuration. Look for pom.xml in the org.eclipse.ice.aggregator/ directory.

FindPOM.png

Right-click this file, and select 'Run As... > Run Configurations' near the bottom of the context menu. In the dialog that appears, select the 'Maven Build' option in the left-side menu, and click the new button (a small button that looks like a blank piece of paper with a gold plus sign on it) near the upper left of the dialog. A new configuration will be created. You need to set the name at the top of the page, choose the org.eclipse.ice.aggregatory/ directory by clicking the "Browse Workspace" button and set the goal to clean verify to properly launch the build. Click 'Apply' and then 'Run.'

Ice build 20160211.png

If the build system encounters any errors or failed tests, they will be reported in the Eclipse console window, and the build will be terminated early. Alternatively, if the build is successful, a "BUILD SUCCESS" message will be displayed in the console once the build completes, and the ICE binaries will have been created in your Eclipse workspace at org.eclipse.ice.repository/target/products. If you experience any issues with the build send your error logs to ice-dev <at> eclipse.org.

The org.eclipse.ice.repository/target/products directory contains a p2 repository; compressed (ZIP) files of ICE for 32- and 64-bit Linux, Mac, and Windows; and unzipped directories with the executables for each platform that can be immediately executed.

A successful build looks like the following:

Ice build console 20160210.png

Tips

Building on Arch Linux

To build ICE on Arch Linux with openjdk it is necessary to install the java-openjfx package from the official repositories.

Back to the top