Skip to main content
Jump to: navigation, search

Higgins 1.1M7

Revision as of 18:10, 12 August 2009 by Bwalker.parityinc.net (Talk | contribs) (Website)

{{#eclipseproject:technology.higgins|eclipse_custom_style.css}}

1.1M7 (Stable) - Target date: 19-Aug-09

Website

  • 273328 Create new downloads page (1832) - DONE - Working on getting the various solutions to build in support of new solutions page mockup design.
    • We have the completed page deployed here on the Higgins/ver2 site.
    • For M7 we are going to focus on fully defining the Windows GTK version.
  • 284462 convert mockup to new downloads page
  • 282699 PHP Components pages - deferred to M8
  • Propose we just make static updates to this new download page here and integrate this page to the website. There will be some solutions that may not be ready by M7 to support this (e.g. AIR selector) and we will just gray out those rows on the table.

iPhone Selector

GTK Selector 1.1-Win

Done:

Coded but not yet checked in:

  • 282693 Use standard Higgins HBX (1980)
  • 273315 Build Higgins Selector Switch connector for GTK selector (1889)
  • 273316 Merge all Higgins Selector Switch connectors (AIR, Cardspace, GTK) into HSS (1890)
  • 282529 Implement support for CardSync Web App within I-Card Service per [1] - DONE
  • 282528 Implement CardSync Web App RESTful binding on Higgins Server per [2] - DONE
    • The code for this is completed, but have not checked into Higgins yet due to jersey and jaxb libs aren't approved by eclipse
  • 273321 For future variants: Port HSS to OSX and Linux. (1765) - DONE
  • 282517 Split the shared tcpserver project into multiple projects (1772) - DONE - working on merging code to check into Higgins.
  • 282720 Update GTK Selector 1.1-Win wiki page - May need to work with Andy on this and Azigo team to write up user perspective.

Scheduled:

Deferred:

STS Client

  • 244073 Add WS-Trust 1.3 support - DONE.
  • 227044 Add SOAP 1.2 support - DONE
    • This work is done - but ran into issue with WS Security spec message mode. WS IT framework does not support the protocol as extension for WS Security. We will need to create a seperate ticket for this for M8. Reference this OSIS test spec
    • Would also need to create tickets for STS sever upgrade for SOAP 1.2 and WSTrust 1.3. This should be done for M8

See Also

Back to the top