Skip to main content
Jump to: navigation, search

Difference between revisions of "Equinox/p2/Removal"

< Equinox‎ | p2
 
(3 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 +
'''Note:''' ''Although you are able to remove p2 from Eclipse SDK 3.4.x builds, it cannot be removed from 3.5.x builds due to increased integration with other components. In the 3.5 build cycle many components in the SDK have changed their dependencies to be on p2 and to call p2 API, rather than rely on the old Update Manager code, in preparation for removal of the Update Manager completely in a future release.''
 +
 
Eclipse platform Ganymede/3.4 contains two provisioning systems: the original Update Manager, and the new [[Equinox p2]] provisioning platform.  By default, p2 is in control of the system and the Update Manager is hidden.  This page describes how to revert to the classic Update Manager and remove p2.
 
Eclipse platform Ganymede/3.4 contains two provisioning systems: the original Update Manager, and the new [[Equinox p2]] provisioning platform.  By default, p2 is in control of the system and the Update Manager is hidden.  This page describes how to revert to the classic Update Manager and remove p2.
  
# Replace the eclipse/configuration/config.ini file with the contents from Eclipse platform version 3.3.2.<ul><li>In the config.ini file, replace the "eclipse.buildId" setting with the correct build id (optional)</li></ul>
+
# '''Scripts available in {{Bug|224908}} automate this process''' (tested on Linux and Cygwin).
# Replace the eclipse/eclipse.ini file with the contents from Eclipse platform version 3.3.2.
+
# For manual removal, the following should be deleted:<ul><li>eclipse/plugins/org.eclipse.*.p2*</li><li>eclipse/features/*.p2*</li><li>eclipse/plugins/org.eclipse.ecf*</li><li>eclipse/plugins/*frameworkadmin*</li><li>eclipse/plugins/*sat4j*</li><li>eclipse/plugins/*simpleconfigurator.manipulator*</li><li>eclipse/dropins*</li><li>eclipse/p2*</li><li>eclipse/configuration/*</li></ul>
# Remove the platform.xml from eclipse/configuration/org.eclipse.update/platform.xml.
+
# Copy '''eclipse/configuration/config.ini''' from a 3.3.2 version of the platform into this release<ul><li>In the config.ini file, replace the "eclipse.buildId" setting with the correct build id (optional)</li></ul>
# Remove the feature org.eclipse.equinox.p2.user.ui.  This feature is optionally required by org.eclipse.platform, but the platform will function without it
+
# Replace the '''eclipse/eclipse.ini''' file with the contents from Eclipse platform version 3.3.2.
# '''Take care removing org.eclipse.equinox.p2.* from the plugins directory''' due to {{Bug|228537}}. If you want to get rid of some plugins, and you have the SDK installed, you need to preserve the equinox.p2.user.ui.source* plugins because they are required by the corresponding source feature, which is required by the SDK feature. If, on the other hand, you do not remove the equinox.p2.* plugins, you run into other troubles like the "old" update manager UI not being available or a message shown in the error log saying "Could not locate the running profile instance".
+
# Remove the eclipse/p2 folder (recommended)
+
# Remove the eclipse/dropins folder (optional)
+
  
You can also find scripts available in https://bugs.eclipse.org/bugs/show_bug.cgi?id=224908 (tested on Linux and Cygwin).
+
Note an issue existed with removing the source plugins and features pre-3.4M7, see {{Bug|228537}}.
  
 
Note that an issue was observed with I20080422-0800 and P2 removed, see {{Bug|228546}}.
 
Note that an issue was observed with I20080422-0800 and P2 removed, see {{Bug|228546}}.
  
 
[[Category:Equinox_p2|Removal]]
 
[[Category:Equinox_p2|Removal]]

Latest revision as of 15:58, 3 January 2011

Note: Although you are able to remove p2 from Eclipse SDK 3.4.x builds, it cannot be removed from 3.5.x builds due to increased integration with other components. In the 3.5 build cycle many components in the SDK have changed their dependencies to be on p2 and to call p2 API, rather than rely on the old Update Manager code, in preparation for removal of the Update Manager completely in a future release.

Eclipse platform Ganymede/3.4 contains two provisioning systems: the original Update Manager, and the new Equinox p2 provisioning platform. By default, p2 is in control of the system and the Update Manager is hidden. This page describes how to revert to the classic Update Manager and remove p2.

  1. Scripts available in bug 224908 automate this process (tested on Linux and Cygwin).
  2. For manual removal, the following should be deleted:
    • eclipse/plugins/org.eclipse.*.p2*
    • eclipse/features/*.p2*
    • eclipse/plugins/org.eclipse.ecf*
    • eclipse/plugins/*frameworkadmin*
    • eclipse/plugins/*sat4j*
    • eclipse/plugins/*simpleconfigurator.manipulator*
    • eclipse/dropins*
    • eclipse/p2*
    • eclipse/configuration/*
  3. Copy eclipse/configuration/config.ini from a 3.3.2 version of the platform into this release
    • In the config.ini file, replace the "eclipse.buildId" setting with the correct build id (optional)
  4. Replace the eclipse/eclipse.ini file with the contents from Eclipse platform version 3.3.2.

Note an issue existed with removing the source plugins and features pre-3.4M7, see bug 228537.

Note that an issue was observed with I20080422-0800 and P2 removed, see bug 228546.

Back to the top