Skip to main content
Jump to: navigation, search

Difference between revisions of "Efxclipse/Tutorials/AddingE(fx)clipse to eclipse"

(Configure eclipse to use a JDK not a JRE)
(Configure eclipse to use a JDK not a JRE)
 
(2 intermediate revisions by the same user not shown)
Line 46: Line 46:
 
= Configure eclipse to use a JDK not a JRE =
 
= Configure eclipse to use a JDK not a JRE =
 
When doing a '''ant build and run''' from the '''FX Build Configuration''' (file: build.fxbuild) the JRE Library must really be a JDK.  The following step show how to configure a JRE as a JDK so the '''ant build and run''' will work.
 
When doing a '''ant build and run''' from the '''FX Build Configuration''' (file: build.fxbuild) the JRE Library must really be a JDK.  The following step show how to configure a JRE as a JDK so the '''ant build and run''' will work.
[[File:FX_Build_Config.png]]
+
[[File:FX_Build_Config.png|none|900px]]
 
# Window -> Preferences
 
# Window -> Preferences
[[File:Window_Preferences.png]]
+
[[File:Window_Preferences.png|none]]
 
# Java -> Installed JREs
 
# Java -> Installed JREs
 
# Press the '''Add...''' button.
 
# Press the '''Add...''' button.
[[File:Java_Installed_JREs.png]]
+
[[File:Java_Installed_JREs.png|none|900px]]
 
# Select '''Standard VM'''  
 
# Select '''Standard VM'''  
 
# Press the '''Next >''' button.
 
# Press the '''Next >''' button.
 
[[File:StandardVM.png]]  
 
[[File:StandardVM.png]]  
 
# Don't press the '''Directory...''' button.  The '''Directory...''' button will filter out JDKs and only show JREs.   
 
# Don't press the '''Directory...''' button.  The '''Directory...''' button will filter out JDKs and only show JREs.   
[[File:JRE_Home.png]]   
+
[[File:JRE_Home.png|none|900px]]   
 
# Use the Operating System's file system browser get the full path of the target JDK.
 
# Use the Operating System's file system browser get the full path of the target JDK.
 
# In this example
 
# In this example
Line 62: Line 62:
 
# Copy and paste the full path into the '''JRE home:''' text box.
 
# Copy and paste the full path into the '''JRE home:''' text box.
 
# Press the '''Finish''' button.
 
# Press the '''Finish''' button.
[[File:JRE_Definition.png]]
+
[[File:JRE_Definition.png|none|900px]]
 
# Make the new JDK the default JRE by checking the check box.
 
# Make the new JDK the default JRE by checking the check box.
 
# Press the '''OK''' button.
 
# Press the '''OK''' button.
[[File:Installed_JREs.png]]
+
[[File:Installed_JREs.png|none|900px]]
 
# Navigate to the '''Execution Environments''' dialog.
 
# Navigate to the '''Execution Environments''' dialog.
 
# Java -> Installed JREs -> Execution Environments.
 
# Java -> Installed JREs -> Execution Environments.
 
# Check the check box next the JDK, not the JRE.
 
# Check the check box next the JDK, not the JRE.
 
# Press the '''OK''' button.
 
# Press the '''OK''' button.
[[File:Execution_Environments.png]]
+
[[File:Execution_Environments.png|none|900px]]
 
# The steps are now complete. All future new projects will point to a JDK, not a JRE.  If you have any existing projects they will still point to the JRE, not the JDK.
 
# The steps are now complete. All future new projects will point to a JDK, not a JRE.  If you have any existing projects they will still point to the JRE, not the JDK.
  

Latest revision as of 11:16, 10 September 2015

Installing e(fx)clipse IDE.

How to install e(fx)clipse on a Mars 4.5.0 version of eclipse. These instructions were written and the screen captures taken with a clean install of the Eclipse for RCP and RAP Developers 64 bit package available here (http://www.eclipse.org/downloads/packages/eclipse-rcp-and-rap-developers/marsr). The Operating system used was Windows 7 SP1. These steps do not include the install of eclipse 4.5.0 (Mars).

Error creating thumbnail: Unable to save thumbnail to destination
  1. Select the Help menu.
  2. Select the Install New Software... option.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Select the --All Available Sites -- option from the Work with: drop down list.
  2. Uncheck the Group items by category check box in the bottom details section.
  3. Check only the e(fx)clipse - IDE Name option. All the other options starting with e(fx)clipse - IDE are subsets of the full e(fx)clipse IDE. The e(fx)clipse - Minimal JavaFX OSGi integration bundles option is out of scope for these instructions.
  4. Press the Next > button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Press the Next > button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Press the I accept the terms of the license agreement radio button.
  2. Press the Finish button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Wait about 2 minutes for the install to complete.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Press the Yes button.

Setup a target platform for your application development

Error creating thumbnail: Unable to save thumbnail to destination
  1. Open Window > Preferences > Plugin-in Development > Target Platform
  2. Click Add ... on the right.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Select Nothing: Start with an empty target definition.
  2. Press the Next > button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Enter e(fx)clipse as the target platform Name:.
  2. Press the Add... button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Select Software Site. Then press the Next > button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Enter http://download.eclipse.org/efxclipse/runtime-released/2.0.0/site as the site. Press the enter key while in the Work with: text box.
  2. Expand FX Target and check Target Platform for Eclipse
  3. Uncheck Include required software check box.
  4. Press the Finish button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. The resolving will take less then one minute on most systems.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Check the e(fx)clipse check box to make the new target platform the (Active) platform.
  2. Press the Apply button.
  3. Press the OK button.

Configure eclipse to use a JDK not a JRE

When doing a ant build and run from the FX Build Configuration (file: build.fxbuild) the JRE Library must really be a JDK. The following step show how to configure a JRE as a JDK so the ant build and run will work.

Error creating thumbnail: Unable to save thumbnail to destination
  1. Window -> Preferences
Error creating thumbnail: Unable to save thumbnail to destination
  1. Java -> Installed JREs
  2. Press the Add... button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Select Standard VM
  2. Press the Next > button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Don't press the Directory... button. The Directory... button will filter out JDKs and only show JREs.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Use the Operating System's file system browser get the full path of the target JDK.
  2. In this example
  3. C:\Program Files\Java\jdk1.8.0_25
  4. Copy and paste the full path into the JRE home: text box.
  5. Press the Finish button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Make the new JDK the default JRE by checking the check box.
  2. Press the OK button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Navigate to the Execution Environments dialog.
  2. Java -> Installed JREs -> Execution Environments.
  3. Check the check box next the JDK, not the JRE.
  4. Press the OK button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. The steps are now complete. All future new projects will point to a JDK, not a JRE. If you have any existing projects they will still point to the JRE, not the JDK.

A quick peak at what is now installed

New Wizards

Error creating thumbnail: Unable to save thumbnail to destination

Package Explorer -> (right mouse click) -> New -> Project...


Error creating thumbnail: Unable to save thumbnail to destination

New, Wizard, JavaFX


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> JavaFX HTML Template


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> JavaFX Library Project


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> JavaFX Product Configuration


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> JavaFX Create a Java Project


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> JavaFXGraph File


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> FXML File


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> JavaFX 3.x ViewPart


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> JavaFX Main Class


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> JavaFX Preloader Class


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> New e4 FX application


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> New FX-OSGi Bundle


New Preferences

Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> CSS


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> CSS -> Syntax Coloring


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> CSS -> Templates


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> CSSEXTDSL


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> CSSEXTDSL -> Syntax Compiler


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> CSSEXTDSL -> Syntax Coloring


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> CSSEXTDSL -> Templates


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> FXGraph


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> FXGraph-> Compiler


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> FXGraph-> Syntax Coloring


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> FXGraph-> Templates


New View

Error creating thumbnail: Unable to save thumbnail to destination
Error creating thumbnail: Unable to save thumbnail to destination

Back to the top